summaryrefslogtreecommitdiff
path: root/dev-libs/elfio
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/elfio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/elfio')
-rw-r--r--dev-libs/elfio/Manifest1
-rw-r--r--dev-libs/elfio/elfio-1.0.3.ebuild30
-rw-r--r--dev-libs/elfio/files/elfio-1.0.3-shared.patch83
-rw-r--r--dev-libs/elfio/metadata.xml10
4 files changed, 124 insertions, 0 deletions
diff --git a/dev-libs/elfio/Manifest b/dev-libs/elfio/Manifest
new file mode 100644
index 00000000000..e489dde8ccd
--- /dev/null
+++ b/dev-libs/elfio/Manifest
@@ -0,0 +1 @@
+DIST ELFIO-1.0.3.tar.gz 308560 SHA256 e8cdd3895c4f6e5ed2422a2151e7940f9085a1c10d1f0508ed03b1c4860bcada SHA512 eb0194ccc9e5194b7ac4ee7dfed06269e5235e72dd72631b63dcc3b0b44c76d44aa30df1332e7424e08ab905d2b243af6e2c183be87766536d588fa6ff719f19 WHIRLPOOL 2c57c0e945daa980324e9d30d67944f4a954e006a6db39a813bf3420fcb9e2d904feea98bbaee1f32c73ebcfdca1e25f569c9c5cfc470eda656752181e4d6d25
diff --git a/dev-libs/elfio/elfio-1.0.3.ebuild b/dev-libs/elfio/elfio-1.0.3.ebuild
new file mode 100644
index 00000000000..042658c341e
--- /dev/null
+++ b/dev-libs/elfio/elfio-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+MY_P=ELFIO-${PV}
+DESCRIPTION="ELF (Executable and Linkable Format) reader and producer implemented as a C++ library"
+HOMEPAGE="http://elfio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elfio/${MY_P}.tar.gz"
+
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-shared.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README
+}
diff --git a/dev-libs/elfio/files/elfio-1.0.3-shared.patch b/dev-libs/elfio/files/elfio-1.0.3-shared.patch
new file mode 100644
index 00000000000..01e67dfe98b
--- /dev/null
+++ b/dev-libs/elfio/files/elfio-1.0.3-shared.patch
@@ -0,0 +1,83 @@
+diff -ur ELFIO-1.0.3.orig/configure.in ELFIO-1.0.3/configure.in
+--- ELFIO-1.0.3.orig/configure.in 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/configure.in 2007-03-06 16:37:08.000000000 +0100
+@@ -7,6 +7,7 @@
+ AC_PROG_CXX
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
++AC_PROG_LIBTOOL
+
+ dnl Checks for libraries.
+
+diff -ur ELFIO-1.0.3.orig/ELFIO/Makefile.am ELFIO-1.0.3/ELFIO/Makefile.am
+--- ELFIO-1.0.3.orig/ELFIO/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/ELFIO/Makefile.am 2007-03-06 16:36:45.000000000 +0100
+@@ -1,6 +1,6 @@
+-lib_LIBRARIES = libELFIO.a
++lib_LTLIBRARIES = libELFIO.la
+
+-libELFIO_a_SOURCES = ELFIDynamic.cpp ELFIImpl.cpp ELFINote.cpp ELFIO.cpp \
++libELFIO_la_SOURCES = ELFIDynamic.cpp ELFIImpl.cpp ELFINote.cpp ELFIO.cpp \
+ ELFIOUtils.cpp ELFIRelocation.cpp ELFISection.cpp \
+ ELFISegment.cpp ELFIStrings.cpp ELFISymbols.cpp \
+ ELFODynamic.cpp ELFOImpl.cpp ELFONote.cpp \
+@@ -10,4 +10,4 @@
+ include_HEADERS = ELFI.h ELFIO.h ELFO.h ELFTypes.h
+ noinst_HEADERS = ELFIImpl.h ELFOImpl.h ELFIOUtils.h
+
+-EXTRA_DIST = ELFIO.dsp ELFIO.dsw ELFIO.mcp
+\ No newline at end of file
++EXTRA_DIST = ELFIO.dsp ELFIO.dsw ELFIO.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/ELFDump/Makefile.am ELFIO-1.0.3/Examples/ELFDump/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/ELFDump/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/ELFDump/Makefile.am 2007-03-06 16:37:51.000000000 +0100
+@@ -3,6 +3,6 @@
+ bin_PROGRAMS = ELFDump
+
+ ELFDump_SOURCES = ELFDump.cpp
+-ELFDump_LDADD = ../../ELFIO/libELFIO.a
++ELFDump_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = ELFDump.dsp ELFDump.dsw ELFDump.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/RelocationTable/Makefile.am ELFIO-1.0.3/Examples/RelocationTable/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/RelocationTable/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/RelocationTable/Makefile.am 2007-03-06 16:38:53.000000000 +0100
+@@ -3,6 +3,6 @@
+ noinst_PROGRAMS = RelocationTable
+
+ RelocationTable_SOURCES = RelocationTable.cpp
+-RelocationTable_LDADD = ../../ELFIO/libELFIO.a
++RelocationTable_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = RelocationTable.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/WriteObj/Makefile.am ELFIO-1.0.3/Examples/WriteObj/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/WriteObj/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/WriteObj/Makefile.am 2007-03-06 16:39:28.000000000 +0100
+@@ -3,6 +3,6 @@
+ noinst_PROGRAMS = WriteObj
+
+ WriteObj_SOURCES = WriteObj.cpp
+-WriteObj_LDADD = ../../ELFIO/libELFIO.a
++WriteObj_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = WriteObj.dsp WriteObj.dsw WriteObj.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/WriteObj2/Makefile.am ELFIO-1.0.3/Examples/WriteObj2/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/WriteObj2/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/WriteObj2/Makefile.am 2007-03-06 16:39:40.000000000 +0100
+@@ -3,4 +3,4 @@
+ noinst_PROGRAMS = WriteObj2
+
+ WriteObj2_SOURCES = WriteObj2.cpp
+-WriteObj2_LDADD = ../../ELFIO/libELFIO.a
++WriteObj2_LDADD = ../../ELFIO/libELFIO.la
+diff -ur ELFIO-1.0.3.orig/Examples/Writer/Makefile.am ELFIO-1.0.3/Examples/Writer/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/Writer/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/Writer/Makefile.am 2007-03-06 16:39:10.000000000 +0100
+@@ -3,6 +3,6 @@
+ noinst_PROGRAMS = Writer
+
+ Writer_SOURCES = Write.cpp
+-Writer_LDADD = ../../ELFIO/libELFIO.a
++Writer_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = Writer.dsp Writer.dsw Writer.mcp
diff --git a/dev-libs/elfio/metadata.xml b/dev-libs/elfio/metadata.xml
new file mode 100644
index 00000000000..ff3b504a335
--- /dev/null
+++ b/dev-libs/elfio/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">elfio</remote-id>
+ </upstream>
+</pkgmetadata>