summaryrefslogtreecommitdiff
path: root/dev-libs/expat
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-07-08 14:36:51 +0200
committerSebastian Pipping <sping@gentoo.org>2016-07-08 14:36:51 +0200
commit41169f960485226b530b0b46dc1c55ea4ab7570f (patch)
treeaa5a057f341bfcf00974fec563ca9dc6209438cd /dev-libs/expat
parent5fa2cd9fe78dbaecf44e6dc74214c9548068e5ff (diff)
downloadgentoo-41169f960485226b530b0b46dc1c55ea4ab7570f.tar.gz
gentoo-41169f960485226b530b0b46dc1c55ea4ab7570f.tar.xz
dev-libs/expat: Remove 2.1.1 (bug #583268)
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/expat')
-rw-r--r--dev-libs/expat/expat-2.1.1.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/dev-libs/expat/expat-2.1.1.ebuild b/dev-libs/expat/expat-2.1.1.ebuild
deleted file mode 100644
index e373b864f58..00000000000
--- a/dev-libs/expat/expat-2.1.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils libtool multilib toolchain-funcs multilib-minimal
-
-DESCRIPTION="Stream-oriented XML parser library"
-HOMEPAGE="http://expat.sourceforge.net/"
-SRC_URI="mirror://sourceforge/expat/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
-IUSE="elibc_FreeBSD examples static-libs unicode"
-RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r6
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
-
-multilib_src_configure() {
- local myconf="$(use_enable static-libs static)"
-
- mkdir -p "${BUILD_DIR}"{u,w} || die
-
- ECONF_SOURCE="${S}" econf ${myconf}
-
- if use unicode; then
- pushd "${BUILD_DIR}"u >/dev/null
- CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}" econf ${myconf}
- popd >/dev/null
-
- pushd "${BUILD_DIR}"w >/dev/null
- CPPFLAGS="${CPPFLAGS} -DXML_UNICODE_WCHAR_T" ECONF_SOURCE="${S}" econf ${myconf}
- popd >/dev/null
- fi
-}
-
-multilib_src_compile() {
- emake
-
- if use unicode; then
- pushd "${BUILD_DIR}"u >/dev/null
- emake buildlib LIBRARY=libexpatu.la
- popd >/dev/null
-
- pushd "${BUILD_DIR}"w >/dev/null
- emake buildlib LIBRARY=libexpatw.la
- popd >/dev/null
- fi
-}
-
-multilib_src_install() {
- emake install DESTDIR="${D}"
-
- if use unicode; then
- pushd "${BUILD_DIR}"u >/dev/null
- emake installlib DESTDIR="${D}" LIBRARY=libexpatu.la
- popd >/dev/null
-
- pushd "${BUILD_DIR}"w >/dev/null
- emake installlib DESTDIR="${D}" LIBRARY=libexpatw.la
- popd >/dev/null
-
- pushd "${ED}"/usr/$(get_libdir)/pkgconfig >/dev/null
- cp expat.pc expatu.pc
- sed -i -e '/^Libs/s:-lexpat:&u:' expatu.pc || die
- cp expat.pc expatw.pc
- sed -i -e '/^Libs/s:-lexpat:&w:' expatw.pc || die
- popd >/dev/null
- fi
-
- if multilib_is_native_abi ; then
- # libgeom in /lib and ifconfig in /sbin require libexpat on FreeBSD since
- # we stripped the libbsdxml copy starting from freebsd-lib-8.2-r1
- use elibc_FreeBSD && gen_usr_ldscript -a expat
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changes README
- dohtml doc/*
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.c
- fi
-
- prune_libtool_files
-}