summaryrefslogtreecommitdiff
path: root/dev-libs/ffcall
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/ffcall
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/ffcall')
-rw-r--r--dev-libs/ffcall/Manifest2
-rw-r--r--dev-libs/ffcall/ffcall-1.10-r2.ebuild49
-rw-r--r--dev-libs/ffcall/ffcall-1.10-r5.ebuild76
-rw-r--r--dev-libs/ffcall/ffcall-1.10.ebuild60
-rw-r--r--dev-libs/ffcall/files/ffcall-make-jN.patch13
-rw-r--r--dev-libs/ffcall/metadata.xml29
6 files changed, 229 insertions, 0 deletions
diff --git a/dev-libs/ffcall/Manifest b/dev-libs/ffcall/Manifest
new file mode 100644
index 00000000000..efd1fbe85f4
--- /dev/null
+++ b/dev-libs/ffcall/Manifest
@@ -0,0 +1,2 @@
+DIST clisp-2.41.tar.bz2 8319471 SHA256 1e5f8d9b04024ae072536ae3271075c1a422c02d3997a729a6b00912ed2ae323 SHA512 638417834cc8b81a893ea98801d8ec3f6e591062bf799a1462fc36ceb3fa0107eb1c55e335cd32e1f9d931692e806d0c59c7557cfaf3af9cb00349b715111489 WHIRLPOOL aaa8a42627621ffc19e527634f0a0f769ffb804132ab29cbe4ca592db03cc10621b968f279f5ba2a92018e16c617f34ddf2ddfbb9993e30b54c8bce643af307a
+DIST ffcall-1.10.tar.gz 914870 SHA256 6f1b5b8fc84b2c0051637fb1e4e4f8b975f5f98bff8fe053c1992347baa4983d SHA512 dceb620907adae5bbbb52cf2d0b0c829242ad22adceb3186b7a887b7ba49e28b607c30179de6b5a0c46a90bd52f9963ce503ca0c69bc3ecf41e3556df094ddca WHIRLPOOL 8f90c8415197ff6d0176b3e95fe8455c0f242264666749ca8228c83df5275fb8c2404a218d0b5170386ad022bc729014cb81b11570e29855305a9efdbfb769d3
diff --git a/dev-libs/ffcall/ffcall-1.10-r2.ebuild b/dev-libs/ffcall/ffcall-1.10-r2.ebuild
new file mode 100644
index 00000000000..48b5104698e
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-1.10-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic
+
+# CLISP maintains ffcall now
+CLISP_PACKAGE="clisp-2.41"
+
+DESCRIPTION="foreign function call libraries"
+HOMEPAGE="http://www.haible.de/bruno/packages-ffcall.html"
+SRC_URI="mirror://sourceforge/clisp/${CLISP_PACKAGE}.tar.bz2"
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~ppc ~ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${CLISP_PACKAGE}/${PN}
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # Because CHOST is set to (for example)
+ # alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
+ # doesn't work in the Makefile (29 Jan 2004 agriffis)
+ local cpu_setting
+ [[ "${ARCH}" == "alpha" ]] && cpu_setting='CPU=alpha'
+
+ append-flags -fPIC
+
+ # Doc goes in datadir
+ econf \
+ --datadir=/usr/share/doc/${PF} \
+ --enable-shared \
+ || die "./configure failed"
+ # bug #298348
+ emake -j1 ${cpu_setting} || die
+}
+
+src_install() {
+ dodoc NEWS README
+ dodir /usr/share/man
+ emake DESTDIR=${D} install || die "Install failed"
+}
diff --git a/dev-libs/ffcall/ffcall-1.10-r5.ebuild b/dev-libs/ffcall/ffcall-1.10-r5.ebuild
new file mode 100644
index 00000000000..92e18c92721
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-1.10-r5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+# CLISP maintains ffcall now
+CLISP_PACKAGE="clisp-2.41"
+
+DESCRIPTION="foreign function call libraries"
+HOMEPAGE="http://www.haible.de/bruno/packages-ffcall.html"
+SRC_URI="mirror://sourceforge/clisp/${CLISP_PACKAGE}.tar.bz2"
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}/${CLISP_PACKAGE}/${PN}
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-make-jN.patch
+
+ # The build system is a strange mix of autogenerated
+ # files and manual tweaks on top. Uses $CFLAGS / $LDFLAGS randomly.
+ # We are adding them consistently here and a bit over the top:
+ # bugs: #334581
+
+ for mfi in {,*/,*/*/,}Makefile.in
+ do
+ elog "Patching '${mfi}'"
+ # usually uses only assembler here, but -march=
+ # and -Wa, are a must to pass here.
+ sed -e 's/$(CC) /&$(CFLAGS) /g' \
+ -i "${mfi}" || die
+
+ # usually uses '$(CC) ... -o something' for linking
+ sed -e 's/\($(CC) .* \)-o /\1 $(LDFLAGS) -o /g' \
+ -i "${mfi}" || die
+ done
+}
+
+src_configure() {
+ append-flags -fPIC
+ append-flags $(test-flags-CC -Wa,--noexecstack) #253963
+
+ # Doc goes in datadir
+ econf \
+ --datadir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-shared \
+ --disable-static
+}
+
+src_compile() {
+ # Because CHOST is set to (for example)
+ # alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
+ # doesn't work in the Makefile (29 Jan 2004 agriffis)
+ local cpu_setting
+ [[ "${ARCH}" == "alpha" ]] && cpu_setting='CPU=alpha'
+
+ emake ${cpu_setting}
+}
+
+src_install() {
+ dodoc NEWS README
+ dodir /usr/share/man
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/ffcall/ffcall-1.10.ebuild b/dev-libs/ffcall/ffcall-1.10.ebuild
new file mode 100644
index 00000000000..75e803d80b6
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-1.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="foreign function call libraries"
+HOMEPAGE="http://www.haible.de/bruno/packages-ffcall.html"
+SRC_URI="ftp://ftp.santafe.edu/pub/gnu/${P}.tar.gz"
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ppc sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # Because CHOST is set to (for example)
+ # alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
+ # doesn't work in the Makefile (29 Jan 2004 agriffis)
+ local cpu_setting
+ [[ "${ARCH}" == "alpha" ]] && cpu_setting='CPU=alpha'
+
+ append-flags -fPIC
+
+ econf || die "./configure failed"
+ make ${cpu_setting} || die
+}
+
+src_install() {
+ dodoc NEWS README
+ dohtml avcall/avcall.html \
+ callback/callback.html \
+ callback/trampoline_r/trampoline_r.html \
+ trampoline/trampoline.html \
+ vacall/vacall.html
+ doman avcall/avcall.3 \
+ callback/callback.3 \
+ callback/trampoline_r/trampoline_r.3 \
+ trampoline/trampoline.3 \
+ vacall/vacall.3
+ dolib.a avcall/.libs/libavcall.a \
+ avcall/.libs/libavcall.la \
+ vacall/libvacall.a \
+ callback/.libs/libcallback.a \
+ callback/.libs/libcallback.la \
+ trampoline/libtrampoline.a
+ insinto /usr/include
+ doins avcall/avcall.h \
+ callback/callback.h \
+ trampoline/trampoline.h \
+ callback/trampoline_r/trampoline_r.h \
+ vacall/vacall.h \
+ callback/vacall_r.h
+}
diff --git a/dev-libs/ffcall/files/ffcall-make-jN.patch b/dev-libs/ffcall/files/ffcall-make-jN.patch
new file mode 100644
index 00000000000..98f4c497504
--- /dev/null
+++ b/dev-libs/ffcall/files/ffcall-make-jN.patch
@@ -0,0 +1,13 @@
+--- ffcall-1.10/callback/Makefile.in~ 2003-10-01 21:46:19.000000000 +0200
++++ ffcall-1.10/callback/Makefile.in 2007-12-18 21:10:51.302118000 +0100
+@@ -51,6 +51,10 @@
+ all-subdirs : force
+ cd @subdir@; $(MAKE) all
+
++vacall_r/libvacall.la: all-subdirs
++
++trampoline_r/libtrampoline.la: all-subdirs
++
+ callback.h :
+ $(LN_S) $(srcdir)/callback.h.in callback.h
+
diff --git a/dev-libs/ffcall/metadata.xml b/dev-libs/ffcall/metadata.xml
new file mode 100644
index 00000000000..74075a222c6
--- /dev/null
+++ b/dev-libs/ffcall/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ffcall - foreign function call libraries
+This is a collection of four libraries which can be used to build foreign
+function call interfaces in embedded interpreters.
+
+The four packages are:
+
+avcall
+- calling C functions with variable arguments
+
+vacall
+- C functions accepting variable argument prototypes
+
+trampoline
+- closures as first-class C functions
+
+callback
+- closures with variable arguments as first-class C functions (a reentrant combination of vacall and trampoline)
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">clisp</remote-id>
+ </upstream>
+</pkgmetadata>