summaryrefslogtreecommitdiff
path: root/dev-libs/geoip
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/geoip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/geoip')
-rw-r--r--dev-libs/geoip/Manifest2
-rw-r--r--dev-libs/geoip/files/geoipupdate-r5.sh46
-rw-r--r--dev-libs/geoip/geoip-1.6.5.ebuild52
-rw-r--r--dev-libs/geoip/geoip-1.6.6.ebuild52
-rw-r--r--dev-libs/geoip/metadata.xml8
5 files changed, 160 insertions, 0 deletions
diff --git a/dev-libs/geoip/Manifest b/dev-libs/geoip/Manifest
new file mode 100644
index 00000000000..da938fb0d89
--- /dev/null
+++ b/dev-libs/geoip/Manifest
@@ -0,0 +1,2 @@
+DIST geoip-1.6.5.tar.gz 156441 SHA256 4a151b35e9d9db976b82645c758662a6cb778c669b2c65635d5834e4f885942e SHA512 1ed223a51d238b6bd8d247e1dcb20f6eb9e3f19d39bd262f7cbefb587ea029ed0abac540208916f3ca06bb86f9ea1e99614484fd1c32535892029e945471e702 WHIRLPOOL ca8cd55e16c9981b443fad9f788dc8f28a64dba86980740efeffaa9c4a9d5da84df8a23fb3710ef13741bb40bec0704ca80991e25d3b11fe10acd5a360c02d77
+DIST geoip-1.6.6.tar.gz 156796 SHA256 db8ed5d07292c75cb3018738e6411037f15cc2a517f38ee04c1232cbe3d30b46 SHA512 4cdd308500bcb827b3dd1c6d981299ea746251758b6a5df97bf2cf098b62b0a736394d5853a06c62437eb0808cb54efb14d0579f5212284f29016e3c8cdd9846 WHIRLPOOL 518749339b094c4166ab53d8ec38020c72f1550923e8c0084f438391dfe7965a9b2f7b3e27ef5ecac85a3f62aa14299e11fbd740ea103c320eef5fad357994b2
diff --git a/dev-libs/geoip/files/geoipupdate-r5.sh b/dev-libs/geoip/files/geoipupdate-r5.sh
new file mode 100644
index 00000000000..484ff7e2227
--- /dev/null
+++ b/dev-libs/geoip/files/geoipupdate-r5.sh
@@ -0,0 +1,46 @@
+#!/bin/sh
+
+GEOIP_MIRROR="https://geolite.maxmind.com/download/geoip/database"
+GEOIPDIR=@PREFIX@/usr/share/GeoIP
+TMPDIR=
+
+DATABASES="
+ GeoIPv6
+ GeoLiteCity
+ GeoLiteCityv6-beta/GeoLiteCityv6
+ GeoLiteCountry/GeoIP
+ asnum/GeoIPASNum
+ asnum/GeoIPASNumv6
+"
+
+if [ "${1}" = -f ] || [ "${1}" = --force ]; then
+ force=true
+fi
+
+if [ -d "${GEOIPDIR}" ]; then
+ cd $GEOIPDIR
+ if [ -n "${DATABASES}" ]; then
+ TMPDIR=$(mktemp -d geoipupdate.XXXXXXXXXX)
+
+ echo "Updating GeoIP databases..."
+
+ for db in $DATABASES; do
+ fname=$(basename $db)
+
+ if [ -f "${GEOIPDIR}/${fname}.dat" ] || [ ${force} ]; then
+ wget --no-verbose -t 3 -T 60 \
+ "${GEOIP_MIRROR}/${db}.dat.gz" \
+ -O "${TMPDIR}/${fname}.dat.gz"
+ if [ $? -eq 0 ]; then
+ gunzip -fdc "${TMPDIR}/${fname}.dat.gz" > "${TMPDIR}/${fname}.dat"
+ mv "${TMPDIR}/${fname}.dat" "${GEOIPDIR}/${fname}.dat"
+ chmod 0644 "${GEOIPDIR}/${fname}.dat"
+ case ${fname} in
+ GeoLite*) ln -sf ${fname}.dat `echo ${fname} | sed 's/GeoLite/GeoIP/'`.dat ;;
+ esac
+ fi
+ fi
+ done
+ [ -d "${TMPDIR}" ] && rm -rf $TMPDIR
+ fi
+fi
diff --git a/dev-libs/geoip/geoip-1.6.5.ebuild b/dev-libs/geoip/geoip-1.6.5.ebuild
new file mode 100644
index 00000000000..0b0a8ac5a5a
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.6.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="https://github.com/maxmind/geoip-api-c"
+SRC_URI="
+ https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
+LICENSE="LGPL-2.1 GPL-2 MaxMind2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+RESTRICT="test"
+
+DEPEND="net-misc/wget"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-api-c-${PV}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+ sed -e "s|@PREFIX@|${ROOT}|g" "${FILESDIR}"/geoipupdate-r5.sh > geoipupdate.sh || die
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS.md README*
+
+ prune_libtool_files
+
+ keepdir /usr/share/GeoIP
+
+ dosbin geoipupdate.sh
+}
+
+pkg_postinst() {
+ ewarn "WARNING: Databases are no longer installed by this ebuild."
+ elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
+ elog "net-misc/geoipupdate) to populate ${ROOT}/usr/share/GeoIP/"
+ elog "with geo-located IP address databases."
+}
diff --git a/dev-libs/geoip/geoip-1.6.6.ebuild b/dev-libs/geoip/geoip-1.6.6.ebuild
new file mode 100644
index 00000000000..f177d8da83f
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.6.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="https://github.com/maxmind/geoip-api-c"
+SRC_URI="
+ https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
+LICENSE="LGPL-2.1 GPL-2 MaxMind2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+RESTRICT="test"
+
+DEPEND="net-misc/wget"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-api-c-${PV}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+ sed -e "s|@PREFIX@|${ROOT}|g" "${FILESDIR}"/geoipupdate-r5.sh > geoipupdate.sh || die
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS.md README*
+
+ prune_libtool_files
+
+ keepdir /usr/share/GeoIP
+
+ dosbin geoipupdate.sh
+}
+
+pkg_postinst() {
+ ewarn "WARNING: Databases are no longer installed by this ebuild."
+ elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
+ elog "net-misc/geoipupdate) to populate ${ROOT}/usr/share/GeoIP/"
+ elog "with geo-located IP address databases."
+}
diff --git a/dev-libs/geoip/metadata.xml b/dev-libs/geoip/metadata.xml
new file mode 100644
index 00000000000..3b26dceb6f1
--- /dev/null
+++ b/dev-libs/geoip/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="github">maxmind/geoip-api-c</remote-id>
+ </upstream>
+</pkgmetadata>