summaryrefslogtreecommitdiff
path: root/dev-libs/glib
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-11-19 01:45:32 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-14 21:32:53 +0100
commitc4a2ee848f7151bb12d262f97633537925b17a20 (patch)
tree81fbcb7483cd055d8f996b61db4780e41dd8c1f8 /dev-libs/glib
parentda90f594219f91865c4310e86f154dbc7dd8d3cd (diff)
downloadgentoo-c4a2ee848f7151bb12d262f97633537925b17a20.tar.gz
gentoo-c4a2ee848f7151bb12d262f97633537925b17a20.tar.xz
dev-libs/glib: libmount support + multilib dependency on util-linux (bug #599586)
Starting with 2.50, libmount support is enabled by default on Linux systems. This commit brings that logic to the ebuild and updates the dependency on util-linux to a multilib one. Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2862
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/glib-2.50.2.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-2.50.2.ebuild b/dev-libs/glib/glib-2.50.2.ebuild
index b40c2d7e7bc..d6ec9771a95 100644
--- a/dev-libs/glib/glib-2.50.2.ebuild
+++ b/dev-libs/glib/glib-2.50.2.ebuild
@@ -30,6 +30,10 @@ REQUIRED_USE="
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+# Added util-linux multilib dependency to have libmount support (which
+# is always turned on on linux systems, unless explicitly disabled, but
+# this ebuild does not do that anyway) (bug #599586)
+
RDEPEND="
!<dev-util/gdbus-codegen-${PV}
>=dev-libs/libpcre-8.13:3[${MULTILIB_USEDEP},static-libs?]
@@ -37,6 +41,7 @@ RDEPEND="
>=virtual/libffi-3.0.13-r1[${MULTILIB_USEDEP}]
>=virtual/libintl-0-r2[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ kernel_linux? ( sys-apps/util-linux[${MULTILIB_USEDEP}] )
selinux? ( >=sys-libs/libselinux-2.2.2-r5[${MULTILIB_USEDEP}] )
xattr? ( >=sys-apps/attr-2.4.47-r1[${MULTILIB_USEDEP}] )
fam? ( >=virtual/fam-0-r1[${MULTILIB_USEDEP}] )
@@ -168,6 +173,7 @@ multilib_src_configure() {
$(usex debug --enable-debug=yes ' ') \
$(use_enable xattr) \
$(use_enable fam) \
+ $(use_enable kernel_linux libmount) \
$(use_enable selinux) \
$(use_enable static-libs static) \
$(use_enable systemtap dtrace) \