summaryrefslogtreecommitdiff
path: root/dev-libs/gnulib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/gnulib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/gnulib')
-rw-r--r--dev-libs/gnulib/Manifest2
-rw-r--r--dev-libs/gnulib/files/gnulib-2008.07.23-rpl_getopt.patch12
-rw-r--r--dev-libs/gnulib/files/gnulib-2009.03.03.14.07.45-scandir.patch15
-rw-r--r--dev-libs/gnulib/gnulib-2009.03.03.14.07.45-r1.ebuild134
-rw-r--r--dev-libs/gnulib/gnulib-2013.10.28.22.33.52.ebuild46
-rw-r--r--dev-libs/gnulib/gnulib-9999-r1.ebuild45
-rw-r--r--dev-libs/gnulib/metadata.xml5
7 files changed, 259 insertions, 0 deletions
diff --git a/dev-libs/gnulib/Manifest b/dev-libs/gnulib/Manifest
new file mode 100644
index 00000000000..2e33c17a9a4
--- /dev/null
+++ b/dev-libs/gnulib/Manifest
@@ -0,0 +1,2 @@
+DIST gnulib-0.1.tar.gz 5374195 SHA256 ce686e0d2b94fed7b8d37853ab56c9b8feebb29317948f3b87b2b454af2a52d5 SHA512 020e1288dbc4daa839368edce4e3ac2f3b3e9d06d414179ee12abfe1603107f03319601c5d81eb089599b519130942d055d65f5dc7059bbe9be563ceac92e0e3 WHIRLPOOL fb61579df2797d751c107991a8697627d3759544b1951e710b84a06e4ee1a5f732f8ffa7683a3f2490cba93c589a1954a0625be3ab8aae6ff865d2e511ad0eaa
+DIST gnulib-8d2524ce78ca107074727cbd8780c26a203a107c.tar.gz 3687831 SHA256 a220080dda77159b2d30bbed93437b97efeef20c417e255296924d580ce6d309 SHA512 3fd621c487f2089c425ee1d7b36947c91ebd96fe88d5426ada9e908e583bc8bf38c98850b1db7157f4d04def5fb2bec664f0d67d86ee612d4448158b2ad84a6a WHIRLPOOL b332579c148accd9c8da7f8bedd65a7aa0d36b0c4aa89797d170fd1b47cf7d2b069ee3c797bb4fd18935affab34536b2b56ae94a1707db3e98133de2d384f2bc
diff --git a/dev-libs/gnulib/files/gnulib-2008.07.23-rpl_getopt.patch b/dev-libs/gnulib/files/gnulib-2008.07.23-rpl_getopt.patch
new file mode 100644
index 00000000000..2ef427a84c3
--- /dev/null
+++ b/dev-libs/gnulib/files/gnulib-2008.07.23-rpl_getopt.patch
@@ -0,0 +1,12 @@
+--- lib/getopt.in.h.orig 2008-07-25 13:40:38 +0200
++++ lib/getopt.in.h 2008-07-25 13:41:25 +0200
+@@ -20,6 +20,9 @@
+
+ #ifndef __need_getopt
+ # define _GETOPT_H 1
++# ifndef __GETOPT_PREFIX
++# define __GETOPT_PREFIX rpl_
++# endif
+ #endif
+
+ /* Standalone applications should #define __GETOPT_PREFIX to an
diff --git a/dev-libs/gnulib/files/gnulib-2009.03.03.14.07.45-scandir.patch b/dev-libs/gnulib/files/gnulib-2009.03.03.14.07.45-scandir.patch
new file mode 100644
index 00000000000..67b1274c802
--- /dev/null
+++ b/dev-libs/gnulib/files/gnulib-2009.03.03.14.07.45-scandir.patch
@@ -0,0 +1,15 @@
+--- a/lib/scandir.c
++++ b/lib/scandir.c
+@@ -18,6 +18,12 @@
+ #include <config.h>
+
+ #include <dirent.h>
++#ifndef _D_EXACT_NAMLEN
++# define _D_EXACT_NAMLEN(d) strlen ((d)->d_name)
++#endif
++#ifndef _D_ALLOC_NAMLEN
++# define _D_ALLOC_NAMLEN(d) (_D_EXACT_NAMLEN (d) + 1)
++#endif
+
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/dev-libs/gnulib/gnulib-2009.03.03.14.07.45-r1.ebuild b/dev-libs/gnulib/gnulib-2009.03.03.14.07.45-r1.ebuild
new file mode 100644
index 00000000000..851dad34a29
--- /dev/null
+++ b/dev-libs/gnulib/gnulib-2009.03.03.14.07.45-r1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils autotools
+
+DESCRIPTION="Gnulib is a library of common routines intended to be shared at the source level"
+HOMEPAGE="http://www.gnu.org/software/gnulib"
+
+# This tar.gz is created on-the-fly when downloaded from
+# http://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=snapshot;h=${GNULIB_COMMIT_GITID};sf=tgz
+# So to have persistent checksums, we need to download once and cache it.
+#
+# To get a new version, download a "snapshot" from
+# http://git.savannah.gnu.org/gitweb/?p=gnulib.git
+# take the commit-id as GNULIB_COMMIT_GITID
+# and the committer's timestamp (not the author's one), year to second, UTC
+# as the ebuild version.
+#
+# To see what the last commit message for the current version was, use
+# http://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=commit;h=${GNULIB_COMMIT_GITID}
+#
+GNULIB_COMMIT_GITID=8d2524ce78ca107074727cbd8780c26a203a107c
+SRC_URI="http://dev.gentoo.org/~drizzt/distfiles/${PN}-${GNULIB_COMMIT_GITID}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"/${PN}
+MY_S="${WORKDIR}"/${P}
+
+src_prepare() {
+ local requested_gnulib_modules
+
+ case ${CHOST} in
+ *-freebsd*)
+ requested_gnulib_modules="mathl strndup"
+ ;;
+ *-solaris2.8|*-solaris2.9)
+ # Don't remove dirfd!
+ requested_gnulib_modules="alphasort dirfd getopt scandir setenv strcasestr stdint strndup xvasprintf"
+ ;;
+ *-solaris2.10|*-solaris2.11)
+ requested_gnulib_modules="dirfd getopt strcasestr strndup xvasprintf"
+ ;;
+ *-aix*)
+ requested_gnulib_modules="alphasort dirfd getopt scandir strcasestr strndup xvasprintf"
+ ;;
+ *-hpux*)
+ requested_gnulib_modules="atoll dirfd getopt setenv strcasestr strndup xvasprintf"
+ ;;
+ *-interix*)
+ requested_gnulib_modules="atoll getopt scandir setenv strcasestr strndup xvasprintf"
+ ;;
+ *-irix*)
+ requested_gnulib_modules="getopt strcasestr strndup xvasprintf"
+ ;;
+ esac
+
+ epatch "${FILESDIR}"/${PN}-2008.07.23-rpl_getopt.patch
+ epatch "${FILESDIR}"/${P}-scandir.patch
+
+ # Solaris 9 ksh makes gnulib-tool to coredump
+ sed -i "1s:/bin/sh:${EPREFIX}/bin/sh:" gnulib-tool || die "sed failed"
+
+ # Remove the broken pxref
+ sed -i '$d' doc/ld-version-script.texi || die "cannot fix ld-version-script.texi"
+
+ [[ -z "$requested_gnulib_modules" ]] && return
+
+ "${S}"/gnulib-tool --create-testdir --dir="${MY_S}" \
+ ${requested_gnulib_modules} || die
+
+ cd "${MY_S}" || die
+
+ # define both libgnu.a and the headers as to-be-installed
+ LANG=C \
+ sed -e '
+ s,noinst_HEADERS,include_HEADERS,;
+ s,noinst_LIBRARIES,lib_LIBRARIES,;
+ s,noinst_LTLIBRARIES,lib_LTLIBRARIES,;
+ s,EXTRA_DIST =$,&\
+EXTRA_HEADERS =,;
+ s,BUILT_SOURCES += \([/a-zA-Z0-9_-][/a-zA-Z0-9_-]*\.h\|\$([_A-Z0-9][_A-Z0-9]*_H)\)$,&\
+include_HEADERS += \1,;
+ ' -i gllib/Makefile.am || die "cannot fix gllib/Makefile.am"
+
+ eautoreconf
+}
+
+src_configure() {
+ cd "${MY_S}" || return
+ econf --prefix="${EPREFIX}"/usr/$(get_libdir)/${PN}
+}
+
+src_compile() {
+ if use doc; then
+ emake -C doc info html || die "emake failed"
+ fi
+ cd "${MY_S}" || return
+ emake || die "cannot make ${P}"
+}
+
+src_install() {
+ dodoc README ChangeLog
+ if use doc; then
+ dohtml doc/gnulib.html
+ doinfo doc/gnulib.info
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r lib
+ doins -r m4
+ doins -r modules
+ doins -r build-aux
+ doins -r top
+
+ # install the real script
+ exeinto /usr/share/${PN}
+ doexe gnulib-tool
+
+ # create and install the wrapper
+ dosym /usr/share/${PN}/gnulib-tool /usr/bin/gnulib-tool
+
+ cd "${MY_S}" || return
+ emake install DESTDIR="${D}" || die "make install failed"
+}
diff --git a/dev-libs/gnulib/gnulib-2013.10.28.22.33.52.ebuild b/dev-libs/gnulib/gnulib-2013.10.28.22.33.52.ebuild
new file mode 100644
index 00000000000..11d1017a720
--- /dev/null
+++ b/dev-libs/gnulib/gnulib-2013.10.28.22.33.52.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+GIT_TAG="0.1"
+
+DESCRIPTION="Gnulib is a library of common routines intended to be shared at the source level"
+HOMEPAGE="http://www.gnu.org/software/gnulib"
+SRC_URI="http://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${PN}-${GIT_TAG}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+S="${WORKDIR}/${PN}-${GIT_TAG}"
+
+src_compile() {
+ if use doc; then
+ emake -C doc info html
+ fi
+}
+
+src_install() {
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins -r build-aux
+ doins -r doc
+ doins -r lib
+ doins -r m4
+ doins -r modules
+ doins -r tests
+ doins -r top
+
+ # install the real script
+ exeinto /usr/share/${PN}
+ doexe gnulib-tool
+
+ # create and install the wrapper
+ dosym /usr/share/${PN}/gnulib-tool /usr/bin/gnulib-tool
+}
diff --git a/dev-libs/gnulib/gnulib-9999-r1.ebuild b/dev-libs/gnulib/gnulib-9999-r1.ebuild
new file mode 100644
index 00000000000..00947d99b27
--- /dev/null
+++ b/dev-libs/gnulib/gnulib-9999-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils git-r3
+
+DESCRIPTION="Gnulib is a library of common routines intended to be shared at the source level"
+HOMEPAGE="http://www.gnu.org/software/gnulib"
+
+EGIT_REPO_URI="
+ git://git.savannah.gnu.org/${PN}.git
+ http://git.savannah.gnu.org/r/${PN}.git
+"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+src_compile() {
+ if use doc; then
+ emake -C doc info html
+ fi
+}
+
+src_install() {
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins -r build-aux
+ doins -r doc
+ doins -r lib
+ doins -r m4
+ doins -r modules
+ doins -r tests
+ doins -r top
+
+ # install the real script
+ exeinto /usr/share/${PN}
+ doexe gnulib-tool
+
+ # create and install the wrapper
+ dosym /usr/share/${PN}/gnulib-tool /usr/bin/gnulib-tool
+}
diff --git a/dev-libs/gnulib/metadata.xml b/dev-libs/gnulib/metadata.xml
new file mode 100644
index 00000000000..46dee96f4e7
--- /dev/null
+++ b/dev-libs/gnulib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>prefix</herd>
+</pkgmetadata>