summaryrefslogtreecommitdiff
path: root/dev-libs/hyperleveldb
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/hyperleveldb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/hyperleveldb')
-rw-r--r--dev-libs/hyperleveldb/Manifest1
-rw-r--r--dev-libs/hyperleveldb/files/snappy.patch31
-rw-r--r--dev-libs/hyperleveldb/hyperleveldb-1.2.2.ebuild28
-rw-r--r--dev-libs/hyperleveldb/metadata.xml8
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/hyperleveldb/Manifest b/dev-libs/hyperleveldb/Manifest
new file mode 100644
index 00000000000..6dd0d41e87c
--- /dev/null
+++ b/dev-libs/hyperleveldb/Manifest
@@ -0,0 +1 @@
+DIST hyperleveldb-1.2.2.tar.gz 584955 SHA256 1e03ac6ebe053128978cefe09ae3316f728ebbc186c22316d826ec185cffdf34 SHA512 6fb7a84ec237a5a1a3f5f7c90965a0b0661a6143722a159a189c4c54231d8c5746dcbb76713fbe9b8b2529467f287365d30dd7115fb5c1ef54f864686a709eb2 WHIRLPOOL a9ea63100b75a508b4cee590a6487231b20a85bfdae584d33375393e7f78e72120d6dd0fc0d96b5e22ad46a1461d5a1270c250b006187b035092ba6bad7801d5
diff --git a/dev-libs/hyperleveldb/files/snappy.patch b/dev-libs/hyperleveldb/files/snappy.patch
new file mode 100644
index 00000000000..f926e3f6a38
--- /dev/null
+++ b/dev-libs/hyperleveldb/files/snappy.patch
@@ -0,0 +1,31 @@
+--- Makefile.am 2014-07-29 14:44:37.851568232 +0800
++++ Makefile.am.new 2014-07-29 14:44:54.687855718 +0800
+@@ -196,7 +196,7 @@
+ TESTS = $(check_PROGRAMS)
+
+ benchmark_SOURCES = benchmark.cc
+-benchmark_LDADD = libhyperleveldb.la -lpthread -le -lpopt -lygor
++benchmark_LDADD = libhyperleveldb.la -lpthread -le -lpopt -lygor -lsnappy
+ benchmark_LDFLAGS = -no-install
+
+ db_bench_SOURCES = db/db_bench.cc $(TESTUTIL)
+
+@@ -200,7 +200,7 @@
+ benchmark_LDFLAGS = -no-install
+
+ db_bench_SOURCES = db/db_bench.cc $(TESTUTIL)
+-db_bench_LDADD = libhyperleveldb.la -lpthread
++db_bench_LDADD = libhyperleveldb.la -lpthread -lsnappy
+
+ db_bench_sqlite3_SOURCES = doc/bench/db_bench_sqlite3.cc $(TESTUTIL)
+ db_bench_sqlite3_LDADD = -lsqlite3
+@@ -215,7 +215,7 @@
+ leveldb_dump_all_LDADD = libhyperleveldb.la -lpthread
+
+ leveldb_verify_SOURCES = leveldb-verify.cc
+-leveldb_verify_LDADD = libhyperleveldb.la -lpthread
++leveldb_verify_LDADD = libhyperleveldb.la -lpthread -lsnappy
+
+ autocompact_test_SOURCES = db/autocompact_test.cc $(TESTHARNESS)
+ autocompact_test_LDADD = libhyperleveldb.la -lpthread
+
diff --git a/dev-libs/hyperleveldb/hyperleveldb-1.2.2.ebuild b/dev-libs/hyperleveldb/hyperleveldb-1.2.2.ebuild
new file mode 100644
index 00000000000..5e8ffcf8710
--- /dev/null
+++ b/dev-libs/hyperleveldb/hyperleveldb-1.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WANT_AUTOMAKE="1.11"
+
+inherit eutils autotools
+
+DESCRIPTION="Hyperdex fork/extension of leveldb"
+HOMEPAGE="http://hyperdex.org/"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/leveldb[snappy]
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/snappy.patch"
+ eautoreconf
+}
diff --git a/dev-libs/hyperleveldb/metadata.xml b/dev-libs/hyperleveldb/metadata.xml
new file mode 100644
index 00000000000..24cbb90cf0c
--- /dev/null
+++ b/dev-libs/hyperleveldb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>