summaryrefslogtreecommitdiff
path: root/dev-libs/json-c/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/json-c/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/json-c/files')
-rw-r--r--dev-libs/json-c/files/json-c-0.10-automake-1.13.patch31
-rw-r--r--dev-libs/json-c/files/json-c-0.10-flags.patch6
-rw-r--r--dev-libs/json-c/files/json-c-0.10-headers.patch27
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/json-c/files/json-c-0.10-automake-1.13.patch b/dev-libs/json-c/files/json-c-0.10-automake-1.13.patch
new file mode 100644
index 00000000000..285c68b8b8a
--- /dev/null
+++ b/dev-libs/json-c/files/json-c-0.10-automake-1.13.patch
@@ -0,0 +1,31 @@
+https://github.com/json-c/json-c/commit/36ec47db49277f4a5eda30823cf6d1f238f34991
+
+From 36ec47db49277f4a5eda30823cf6d1f238f34991 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20Gst=C3=A4dtner?= <thomas@gstaedtner.net>
+Date: Sun, 3 Mar 2013 00:17:25 +0100
+Subject: [PATCH] configure.in: mv AM_CONFIG_HEADER to AC_CONFIG_HEADER
+
+the former has been deprecated and does not work on newer autoconf
+versions.
+---
+ configure.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 1a428b6..d68d7a1 100644
+--- a/configure.in
++++ b/configure.in
+@@ -20,8 +20,8 @@ AM_CONDITIONAL(ENABLE_OLDNAME_COMPAT, [test "x${enable_oldname_compat}" != "xno"
+ # Checks for libraries.
+
+ # Checks for header files.
+-AM_CONFIG_HEADER(config.h)
+-AM_CONFIG_HEADER(json_config.h)
++AC_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADER(json_config.h)
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(fcntl.h limits.h strings.h syslog.h unistd.h [sys/cdefs.h] [sys/param.h] stdarg.h locale.h)
+ AC_CHECK_HEADER(inttypes.h,[AC_DEFINE([JSON_C_HAVE_INTTYPES_H],[1],[Public define for json_inttypes.h])])
+--
+1.8.1.6
+
diff --git a/dev-libs/json-c/files/json-c-0.10-flags.patch b/dev-libs/json-c/files/json-c-0.10-flags.patch
new file mode 100644
index 00000000000..8634f870177
--- /dev/null
+++ b/dev-libs/json-c/files/json-c-0.10-flags.patch
@@ -0,0 +1,6 @@
+--- json-c-0.10/Makefile.am.inc
++++ json-c-0.10/Makefile.am.inc
+@@ -1,2 +1,2 @@
+-AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
++AM_CFLAGS = -Wall -Wwrite-strings -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+
diff --git a/dev-libs/json-c/files/json-c-0.10-headers.patch b/dev-libs/json-c/files/json-c-0.10-headers.patch
new file mode 100644
index 00000000000..f3486739b9d
--- /dev/null
+++ b/dev-libs/json-c/files/json-c-0.10-headers.patch
@@ -0,0 +1,27 @@
+--- json-c-0.10/json.pc.in
++++ json-c-0.10/json.pc.in
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires:
+ Libs: -L${libdir} -ljson
+-Cflags: -I${includedir}/json
++Cflags: -I${includedir}/json-c
+--- json-c-0.10/Makefile.am
++++ json-c-0.10/Makefile.am
+@@ -8,7 +8,7 @@
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = json.pc
+
+-libjsonincludedir = $(includedir)/json
++libjsonincludedir = $(includedir)/json-c
+ libjsoninclude_HEADERS = \
+ arraylist.h \
+ bits.h \
+@@ -17,6 +17,7 @@
+ json_config.h \
+ json_inttypes.h \
+ json_object.h \
++ json_object_iterator.h \
+ json_object_private.h \
+ json_tokener.h \
+ json_util.h \