summaryrefslogtreecommitdiff
path: root/dev-libs/leatherman
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-12-05 17:56:21 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-12-05 17:58:46 -0600
commitc92d4f9415763b6dd7b8356fa668bd5ce6f78bd9 (patch)
tree509101c1b153e9198dbbbe5b220247070a8fb724 /dev-libs/leatherman
parent0244ae37885db15de5c743ea47f3d00ea5b53c50 (diff)
downloadgentoo-c92d4f9415763b6dd7b8356fa668bd5ce6f78bd9.tar.gz
gentoo-c92d4f9415763b6dd7b8356fa668bd5ce6f78bd9.tar.xz
dev-libs/leatherman: fixing bug 601744
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/leatherman')
-rw-r--r--dev-libs/leatherman/leatherman-0.10.0.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-libs/leatherman/leatherman-0.10.0.ebuild b/dev-libs/leatherman/leatherman-0.10.0.ebuild
index 82fafc78c7f..db6472adad1 100644
--- a/dev-libs/leatherman/leatherman-0.10.0.ebuild
+++ b/dev-libs/leatherman/leatherman-0.10.0.ebuild
@@ -6,26 +6,22 @@ EAPI=5
USE_RUBY="ruby21 ruby22"
CMAKE_MIN_VERSION="3.2.2"
-inherit cmake-utils multilib ruby-ng
+inherit cmake-utils multilib
DESCRIPTION="A C++ toolkit"
HOMEPAGE="https://github.com/puppetlabs/leatherman"
SRC_URI="https://downloads.puppetlabs.com/facter/${P}.tar.gz"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${S}/all/${P}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="debug test"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-CDEPEND="
- >=sys-devel/gcc-4.8:*
- >=dev-libs/boost-1.54[nls]
- net-misc/curl"
-
-RDEPEND+=" ${CDEPEND}"
-DEPEND+=" test? ( ${CDEPEND} )"
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.54[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
src_prepare() {
sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die