summaryrefslogtreecommitdiff
path: root/dev-libs/libIDL
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-06-16 12:05:20 -0400
committerIan Stakenvicius <axs@gentoo.org>2016-06-16 13:54:35 -0400
commit28bf1530924ab709fe69fb56c6c56085e4268a33 (patch)
treeba39e5c9f3a3f70f3e218c5c0508514a72d92315 /dev-libs/libIDL
parent0b1358e8ec52fdbd2024a694db7e7c8a36ee1f7b (diff)
downloadgentoo-28bf1530924ab709fe69fb56c6c56085e4268a33.tar.gz
gentoo-28bf1530924ab709fe69fb56c6c56085e4268a33.tar.xz
dev-libs/libIDL: add multilib support
multilib support is needed for multilib gnome-base/orbit Bug: http://bugs.gentoo.org/586014 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/libIDL')
-rw-r--r--dev-libs/libIDL/libIDL-0.8.14-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libIDL/libIDL-0.8.14-r1.ebuild b/dev-libs/libIDL/libIDL-0.8.14-r1.ebuild
new file mode 100644
index 00000000000..bb7b9c901e1
--- /dev/null
+++ b/dev-libs/libIDL/libIDL-0.8.14-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME_TARBALL_SUFFIX="bz2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="CORBA tree builder"
+HOMEPAGE="https://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.44.1-r1:2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig"
+
+DOCS="AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README"
+G2CONF="--disable-static"
+
+multilib_src_configure() {
+ local ECONF_SOURCE="${S}"
+ gnome2_src_configure
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_isntall() {
+ gnome2_src_install
+}