summaryrefslogtreecommitdiff
path: root/dev-libs/libIDL
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-25 12:28:55 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-25 12:28:55 +0200
commit5e6b0f7142addf54e9afc45e53b352aba11ac305 (patch)
tree72daae5cbf6b595744410b0e7c6b6f0656479400 /dev-libs/libIDL
parentf03bc7da70ad8ba36fb23416c1f6ebc7705b9801 (diff)
downloadgentoo-5e6b0f7142addf54e9afc45e53b352aba11ac305.tar.gz
gentoo-5e6b0f7142addf54e9afc45e53b352aba11ac305.tar.xz
dev-libs/libIDL: eapi bump, drop .la files (fix typo in src_install phase), stop using deprecated G2CONF var
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/libIDL')
-rw-r--r--dev-libs/libIDL/libIDL-0.8.14-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libIDL/libIDL-0.8.14-r2.ebuild b/dev-libs/libIDL/libIDL-0.8.14-r2.ebuild
new file mode 100644
index 00000000000..3934aaaac3d
--- /dev/null
+++ b/dev-libs/libIDL/libIDL-0.8.14-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="CORBA tree builder"
+HOMEPAGE="https://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.44.1-r1:2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local ECONF_SOURCE="${S}"
+ gnome2_src_configure --disable-static
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}