summaryrefslogtreecommitdiff
path: root/dev-libs/libattica
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libattica
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libattica')
-rw-r--r--dev-libs/libattica/Manifest1
-rw-r--r--dev-libs/libattica/libattica-0.4.2.ebuild48
-rw-r--r--dev-libs/libattica/metadata.xml5
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libattica/Manifest b/dev-libs/libattica/Manifest
new file mode 100644
index 00000000000..f12e18592a9
--- /dev/null
+++ b/dev-libs/libattica/Manifest
@@ -0,0 +1 @@
+DIST attica-0.4.2.tar.bz2 57093 SHA256 3b9c53770862c0b21b7af7ea15951c35831126022bb8d052760d9cf8bd7ee4f8 SHA512 cef5d5c4bf01ed45ed8b59db354a4ac7949de435a45e4f753c847cadc15855e25997dedf1ff20c7bc4a2724d2cdba15139c54f0682df7d8cc8750de5be6f716e WHIRLPOOL b35c3a072a44031f61e7f048336f552a95a1d9f77838552fc19fbbcf22e66dfa297b9ffccd30cf434be7fe6485209bf6e4622cfa0637a519de6ee5318a947833
diff --git a/dev-libs/libattica/libattica-0.4.2.ebuild b/dev-libs/libattica/libattica-0.4.2.ebuild
new file mode 100644
index 00000000000..3080325b75b
--- /dev/null
+++ b/dev-libs/libattica/libattica-0.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${P#lib}"
+MY_PN="${PN#lib}"
+
+if [[ $PV = *9999* ]]; then
+ EGIT_REPO_URI="git://anongit.kde.org/attica"
+ KEYWORDS=""
+ scm_eclass=git-2
+else
+ SRC_URI="mirror://kde/stable/${MY_PN}/${MY_P}.tar.bz2"
+ KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+DESCRIPTION="A library providing access to Open Collaboration Services"
+HOMEPAGE="http://www.kde.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE="debug test"
+
+RDEPEND="
+ dev-qt/qtcore:4
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ )
+"
+
+DOCS=( AUTHORS ChangeLog README )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT4_BUILD=true
+ $(cmake-utils_use test ATTICA_ENABLE_TESTS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/libattica/metadata.xml b/dev-libs/libattica/metadata.xml
new file mode 100644
index 00000000000..8d1e86a9cef
--- /dev/null
+++ b/dev-libs/libattica/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>