summaryrefslogtreecommitdiff
path: root/dev-libs/libbsd
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-01-09 00:29:28 -0500
committerIan Stakenvicius <axs@gentoo.org>2016-01-11 11:53:11 -0500
commit4b3b5a2eca4461d6a770eb2ad1b9c5ee0d628425 (patch)
tree8c104418b3850af2c15835bd62694b51c1b342a5 /dev-libs/libbsd
parente144880377dd062dbcfd05a7cd8fb1a0dc2e80cc (diff)
downloadgentoo-4b3b5a2eca4461d6a770eb2ad1b9c5ee0d628425.tar.gz
gentoo-4b3b5a2eca4461d6a770eb2ad1b9c5ee0d628425.tar.xz
dev-libs/libbsd: convert to multlib
multilib is needed to support samba-4 (new rdep) Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/libbsd-0.8.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/libbsd/libbsd-0.8.0-r1.ebuild b/dev-libs/libbsd/libbsd-0.8.0-r1.ebuild
new file mode 100644
index 00000000000..3fac9b82fda
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.8.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib-minimal
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="http://libbsd.freedesktop.org/wiki/"
+SRC_URI="http://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+ local f="${ROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # http://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+}
+
+multilib_src_install_all() {
+ dodoc ${DOCS}
+}