summaryrefslogtreecommitdiff
path: root/dev-libs/libbsd
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-26 13:06:48 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-26 13:07:02 +0200
commit5da88f171cdf1514420b32889389d3a0261321d0 (patch)
tree20a94836b0cd7036dabf0b26047cdc7df8d5833c /dev-libs/libbsd
parent5377259a7bfc9aa91aa03f67773465f4799021d5 (diff)
downloadgentoo-5da88f171cdf1514420b32889389d3a0261321d0.tar.gz
gentoo-5da88f171cdf1514420b32889389d3a0261321d0.tar.xz
dev-libs/libbsd: Bump to version 0.8.3
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/Manifest1
-rw-r--r--dev-libs/libbsd/libbsd-0.8.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index f3c612d27ff..0c3df39a67b 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1 +1,2 @@
DIST libbsd-0.8.2.tar.xz 344292 SHA256 b2f644cae94a6e2fe109449c20ad79a0f6ee4faec2205b07eefa0020565e250a SHA512 2230d51a30a0c3a8518c7e325036d2b578c8c2b47525c2d0d5f530d28d82227ad48b50341e44521db21f99208fe7c0df7313254c90e3c92da1c8664a8cbb87c5 WHIRLPOOL 4f9b09aaa7c0775cd46bf0aaaba9e9a7f07040262739002bf3966aace3bb4d782f96b176e2c489e7d7cbc0840eecc463a414dee1b5c92414c9a821796d739290
+DIST libbsd-0.8.3.tar.xz 356772 SHA256 934b634f4dfd865b6482650b8f522c70ae65c463529de8be907b53c89c3a34a8 SHA512 155b895d6bd62b180718d65a2cda7484946c492d52735a57b51005705dfe4528b6a72e8745acea47b01fe68e3bbbe3c036c5e9998a8d06fc79efe2b96a04767f WHIRLPOOL ab74a85813ea3308e7e4c53b7a46f4b93e4dff4d091964a6347f9960729e8eb4c8a2a0866938de508caf47caf9371f14499fcb0cc4aa30da06f501f4ccad9ef2
diff --git a/dev-libs/libbsd/libbsd-0.8.3.ebuild b/dev-libs/libbsd/libbsd-0.8.3.ebuild
new file mode 100644
index 00000000000..59b5735b29b
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils multilib-minimal
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="https://libbsd.freedesktop.org/wiki/"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-3.17"
+RDEPEND=""
+
+pkg_setup() {
+ local f="${ROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # https://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+}