summaryrefslogtreecommitdiff
path: root/dev-libs/libcdio
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libcdio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libcdio')
-rw-r--r--dev-libs/libcdio/Manifest2
-rw-r--r--dev-libs/libcdio/libcdio-0.92.ebuild68
-rw-r--r--dev-libs/libcdio/libcdio-0.93.ebuild68
-rw-r--r--dev-libs/libcdio/metadata.xml12
4 files changed, 150 insertions, 0 deletions
diff --git a/dev-libs/libcdio/Manifest b/dev-libs/libcdio/Manifest
new file mode 100644
index 00000000000..f1ea68e4e9e
--- /dev/null
+++ b/dev-libs/libcdio/Manifest
@@ -0,0 +1,2 @@
+DIST libcdio-0.92.tar.gz 2710084 SHA256 3336bf352aff43b5023e41a6d23525172a3b4ee433c467bd0fab5b8becb33fad SHA512 aeeb51c87f966683a1f10960e4d000098603adfbd8036cff17f62afa5de08a2dbe4f8df7d1bc1fd0438c0ac5f868b2950ed9379ea17b7d98fbd23ef023777747 WHIRLPOOL 051ba189fef5f28ae8ac98caab7bdb7468423f53d7b423e1a2416a8741339ff5aed76115a665f91d406254462c87cf84274a1b777a8f39064624fe908ff1fb0c
+DIST libcdio-0.93.tar.gz 2723371 SHA256 4972cd22fd8d0e8bff922d35c7a645be0db0ab0e7b3dfaecc9cd8272429d6975 SHA512 a2ea7a1f219e1abdbbb42633003e10ff77b6a879133c96a0c8e7a80fe205c08a48bade1d9941c6493f24d6eb2ed410469b57e19d9740a4400266a6f3f9d3da91 WHIRLPOOL ff54f71de82fcb659c2de85e5b1090974273e938a3cd8c6353e37fa7e3c6d793d404eaeb43bebe03e73c51dfde8c6db458911ae799fdce75723a06f8ce7689f8
diff --git a/dev-libs/libcdio/libcdio-0.92.ebuild b/dev-libs/libcdio/libcdio-0.92.ebuild
new file mode 100644
index 00000000000..50759e092a1
--- /dev/null
+++ b/dev-libs/libcdio/libcdio-0.92.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool multilib-minimal
+
+DESCRIPTION="A library to encapsulate CD-ROM reading and control"
+HOMEPAGE="http://www.gnu.org/software/libcdio/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/15" # subslot is based on SONAME
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cddb +cxx minimal static-libs test"
+
+RDEPEND="
+ !minimal? (
+ >=sys-libs/ncurses-5.7-r7
+ cddb? ( >=media-libs/libcddb-1.3.2 )
+ )
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r10
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-lang/perl )"
+DOCS="AUTHORS ChangeLog NEWS README* THANKS TODO"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/cdio/cdio_config.h
+ /usr/include/cdio/version.h
+)
+
+src_prepare() {
+ sed \
+ -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs ncurses):g" \
+ -i configure || die
+
+ elibtoolize # to prevent -L/usr/lib ending up in the linker line wrt 499510
+}
+
+multilib_src_configure() {
+ local util_switch
+ if ! multilib_is_native_abi || use minimal ; then
+ util_switch="--without"
+ else
+ util_switch="--with"
+ fi
+
+ # Tests fail if ECONF_SOURCE is not relative
+ ECONF_SOURCE="../${P}" econf \
+ --disable-maintainer-mode \
+ $(use_enable cxx) \
+ --disable-cpp-progs \
+ --disable-example-progs \
+ $(use_enable static-libs static) \
+ $(use_enable cddb) \
+ --disable-vcd-info \
+ ${util_switch}-{cd-drive,cd-info,cdda-player,cd-read,iso-info,iso-read}
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/dev-libs/libcdio/libcdio-0.93.ebuild b/dev-libs/libcdio/libcdio-0.93.ebuild
new file mode 100644
index 00000000000..35b586fe85d
--- /dev/null
+++ b/dev-libs/libcdio/libcdio-0.93.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool multilib-minimal
+
+DESCRIPTION="A library to encapsulate CD-ROM reading and control"
+HOMEPAGE="http://www.gnu.org/software/libcdio/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/15" # subslot is based on SONAME
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cddb +cxx minimal static-libs test"
+
+RDEPEND="
+ !minimal? (
+ >=sys-libs/ncurses-5.7-r7
+ cddb? ( >=media-libs/libcddb-1.3.2 )
+ )
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r10
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-lang/perl )"
+DOCS="AUTHORS ChangeLog NEWS README* THANKS TODO"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/cdio/cdio_config.h
+ /usr/include/cdio/version.h
+)
+
+src_prepare() {
+ sed \
+ -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs ncurses):g" \
+ -i configure || die
+
+ elibtoolize # to prevent -L/usr/lib ending up in the linker line wrt 499510
+}
+
+multilib_src_configure() {
+ local util_switch
+ if ! multilib_is_native_abi || use minimal ; then
+ util_switch="--without"
+ else
+ util_switch="--with"
+ fi
+
+ # Tests fail if ECONF_SOURCE is not relative
+ ECONF_SOURCE="../${P}" econf \
+ --disable-maintainer-mode \
+ $(use_enable cxx) \
+ --disable-cpp-progs \
+ --disable-example-progs \
+ $(use_enable static-libs static) \
+ $(use_enable cddb) \
+ --disable-vcd-info \
+ ${util_switch}-{cd-drive,cd-info,cdda-player,cd-read,iso-info,iso-read}
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/dev-libs/libcdio/metadata.xml b/dev-libs/libcdio/metadata.xml
new file mode 100644
index 00000000000..4c3108f98b0
--- /dev/null
+++ b/dev-libs/libcdio/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="minimal">
+ Only build the libcdio library and little more, just to be used to
+ link against from multimedia players. With this USE flag enabled,
+ none of the command-line utilities are built, nor is the CDDA library.
+ </flag>
+ </use>
+</pkgmetadata>