summaryrefslogtreecommitdiff
path: root/dev-libs/libclc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libclc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libclc')
-rw-r--r--dev-libs/libclc/Manifest3
-rw-r--r--dev-libs/libclc/files/libclc-llvm-3.5-compat.patch83
-rw-r--r--dev-libs/libclc/libclc-0.0.1_pre20140101-r1.ebuild60
-rw-r--r--dev-libs/libclc/libclc-0.0.1_pre20141027.ebuild56
-rw-r--r--dev-libs/libclc/libclc-0.1.0_pre20150305.ebuild54
-rw-r--r--dev-libs/libclc/metadata.xml5
6 files changed, 261 insertions, 0 deletions
diff --git a/dev-libs/libclc/Manifest b/dev-libs/libclc/Manifest
new file mode 100644
index 00000000000..202fbdef193
--- /dev/null
+++ b/dev-libs/libclc/Manifest
@@ -0,0 +1,3 @@
+DIST libclc-0.0.1_pre20140101.tar.xz 27528 SHA256 990820e918a14b6ef2941ce44e2dca0c6a4025dda8a299af7da8c75bdc40a409 SHA512 460ff4e0c06116000f5f91e35e6118eb117c91b1678473fd25512924e3095693cdd1024db69f9f361c744254df5c2bf8c209096fbad15f48915f3cdd3159ea84 WHIRLPOOL c0753f27925336b45591d2e5d4cda30a685d85629fdcb5dbb8110f59306bed3cdee701c6312ec7da56e1c943a50bdc301d7c59e6b1155bbc1d6da03fb305e0a7
+DIST libclc-0.0.1_pre20141027.tar.xz 43784 SHA256 91f2c78fc31c76112899ce30b529f0dc3fa893f7c839727511d967f751c7d8f3 SHA512 bd63f5e29406e9961b6a33a3a45475563ea26505e7665f1ab2fba060151e15c7a02e5ceaf7f16ae55f23fcd0001be3b8acb57045eccdd5b8b7d2e5c684b84097 WHIRLPOOL 4bdb39324512ca7ac497c63d5d2e00e98c89f78be316368705eb697e268a4f7bedf60b212b93de79ef1258588a3661f5abcd040abe91d70371a1daabadda38f1
+DIST libclc-0.1.0_pre20150305.tar.xz 45492 SHA256 5c221bc70438d50cc5893797ebd59a444910e057ccfce0671f3cdeb118854806 SHA512 5d6aa3d80da161fb987f954a1c192a06bab59de345e31a7fa55be1947feb14439f00e0d1a92d146428bfe257ab4be6ab949b9147e0650e2156124f5e9db7270c WHIRLPOOL 3fed78801b25cdcd56411847a679a511775ca7b42582d0b6791dfbe9ff544e15325cf4e5d528458d4db0334d400d4770ccdefd60db56043cc3508ce82862b1cc
diff --git a/dev-libs/libclc/files/libclc-llvm-3.5-compat.patch b/dev-libs/libclc/files/libclc-llvm-3.5-compat.patch
new file mode 100644
index 00000000000..34b4899e062
--- /dev/null
+++ b/dev-libs/libclc/files/libclc-llvm-3.5-compat.patch
@@ -0,0 +1,83 @@
+diff -urpN libclc-0.0.1_pre20140101.orig/utils/prepare-builtins.cpp libclc-0.0.1_pre20140101/utils/prepare-builtins.cpp
+--- libclc-0.0.1_pre20140101.orig/utils/prepare-builtins.cpp 2014-09-22 13:08:50.236934929 -0700
++++ libclc-0.0.1_pre20140101/utils/prepare-builtins.cpp 2014-09-22 13:12:43.164665140 -0700
+@@ -1,4 +1,3 @@
+-#include "llvm/ADT/OwningPtr.h"
+ #include "llvm/Bitcode/ReaderWriter.h"
+ #include "llvm/IR/Function.h"
+ #include "llvm/IR/GlobalVariable.h"
+@@ -7,11 +6,28 @@
+ #include "llvm/Support/CommandLine.h"
+ #include "llvm/Support/ManagedStatic.h"
+ #include "llvm/Support/MemoryBuffer.h"
++#include "llvm/Support/FileSystem.h"
+ #include "llvm/Support/raw_ostream.h"
+-#include "llvm/Support/system_error.h"
++#include "llvm/Support/ErrorOr.h"
+ #include "llvm/Support/ToolOutputFile.h"
+ #include "llvm/Config/config.h"
+
++#define LLVM_350_AND_NEWER \
++ (LLVM_VERSION_MAJOR > 3 || (LLVM_VERSION_MAJOR == 3 && LLVM_VERSION_MINOR >= 5))
++
++#if LLVM_350_AND_NEWER
++#include <system_error>
++
++#define ERROR_CODE std::error_code
++#define UNIQUE_PTR std::unique_ptr
++#else
++#include "llvm/ADT/OwningPtr.h"
++#include "llvm/Support/system_error.h"
++
++#define ERROR_CODE error_code
++#define UNIQUE_PTR OwningPtr
++#endif
++
+ using namespace llvm;
+
+ static cl::opt<std::string>
+@@ -31,11 +47,26 @@ int main(int argc, char **argv) {
+ std::auto_ptr<Module> M;
+
+ {
+- OwningPtr<MemoryBuffer> BufferPtr;
+- if (error_code ec = MemoryBuffer::getFileOrSTDIN(InputFilename, BufferPtr))
++#if LLVM_350_AND_NEWER
++ ErrorOr<std::unique_ptr<MemoryBuffer>> BufferOrErr =
++ MemoryBuffer::getFile(InputFilename);
++ std::unique_ptr<MemoryBuffer> &BufferPtr = BufferOrErr.get();
++ if (std::error_code ec = BufferOrErr.getError())
++#else
++ UNIQUE_PTR<MemoryBuffer> BufferPtr;
++ if (ERROR_CODE ec = MemoryBuffer::getFileOrSTDIN(InputFilename, BufferPtr))
++#endif
+ ErrorMessage = ec.message();
+- else
++ else {
++#if LLVM_VERSION_MAJOR > 3 || (LLVM_VERSION_MAJOR == 3 && LLVM_VERSION_MINOR > 4)
++ ErrorOr<Module *> ModuleOrErr = parseBitcodeFile(BufferPtr.get(), Context);
++ if (ERROR_CODE ec = ModuleOrErr.getError())
++ ErrorMessage = ec.message();
++ M.reset(ModuleOrErr.get());
++#else
+ M.reset(ParseBitcodeFile(BufferPtr.get(), Context, &ErrorMessage));
++#endif
++ }
+ }
+
+ if (M.get() == 0) {
+@@ -65,10 +95,12 @@ int main(int argc, char **argv) {
+ }
+
+ std::string ErrorInfo;
+- OwningPtr<tool_output_file> Out
++ UNIQUE_PTR<tool_output_file> Out
+ (new tool_output_file(OutputFilename.c_str(), ErrorInfo,
+-#if LLVM_VERSION_MAJOR > 3 || (LLVM_VERSION_MAJOR == 3 && LLVM_VERSION_MINOR > 3)
++#if (LLVM_VERSION_MAJOR == 3 && LLVM_VERSION_MINOR == 4)
+ sys::fs::F_Binary));
++#elif LLVM_VERSION_MAJOR > 3 || (LLVM_VERSION_MAJOR == 3 && LLVM_VERSION_MINOR >= 5)
++ sys::fs::F_None));
+ #else
+ raw_fd_ostream::F_Binary));
+ #endif
diff --git a/dev-libs/libclc/libclc-0.0.1_pre20140101-r1.ebuild b/dev-libs/libclc/libclc-0.0.1_pre20140101-r1.ebuild
new file mode 100644
index 00000000000..595ceeae8ae
--- /dev/null
+++ b/dev-libs/libclc/libclc-0.0.1_pre20140101-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="http://llvm.org/git/${PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit base python-any-r1 $GIT_ECLASS
+
+DESCRIPTION="OpenCL C library"
+HOMEPAGE="http://libclc.llvm.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz ${SRC_PATCHES}"
+fi
+
+LICENSE="|| ( MIT BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sys-devel/clang-3.4
+ >=sys-devel/llvm-3.4
+ <sys-devel/clang-3.6
+ <sys-devel/llvm-3.6"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+src_unpack() {
+ if [[ $PV = 9999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ mv ${PN}-*/ ${P} || die
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/libclc-llvm-3.5-compat.patch"
+}
+
+src_configure() {
+ ./configure.py \
+ --with-llvm-config="${EPREFIX}/usr/bin/llvm-config" \
+ --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake VERBOSE=1
+}
diff --git a/dev-libs/libclc/libclc-0.0.1_pre20141027.ebuild b/dev-libs/libclc/libclc-0.0.1_pre20141027.ebuild
new file mode 100644
index 00000000000..ed10b2011c9
--- /dev/null
+++ b/dev-libs/libclc/libclc-0.0.1_pre20141027.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="http://llvm.org/git/${PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit base python-any-r1 $GIT_ECLASS
+
+DESCRIPTION="OpenCL C library"
+HOMEPAGE="http://libclc.llvm.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz ${SRC_PATCHES}"
+fi
+
+LICENSE="|| ( MIT BSD )"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=sys-devel/clang-3.5
+ >=sys-devel/llvm-3.5
+ <sys-devel/clang-3.6
+ <sys-devel/llvm-3.6"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+src_unpack() {
+ if [[ $PV = 9999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ mv ${PN}-*/ ${P} || die
+ fi
+}
+
+src_configure() {
+ ./configure.py \
+ --with-llvm-config="${EPREFIX}/usr/bin/llvm-config" \
+ --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake VERBOSE=1
+}
diff --git a/dev-libs/libclc/libclc-0.1.0_pre20150305.ebuild b/dev-libs/libclc/libclc-0.1.0_pre20150305.ebuild
new file mode 100644
index 00000000000..d2c5cd37651
--- /dev/null
+++ b/dev-libs/libclc/libclc-0.1.0_pre20150305.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="http://llvm.org/git/${PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+fi
+
+inherit base python-any-r1 $GIT_ECLASS
+
+DESCRIPTION="OpenCL C library"
+HOMEPAGE="http://libclc.llvm.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz ${SRC_PATCHES}"
+fi
+
+LICENSE="|| ( MIT BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sys-devel/clang-3.6
+ >=sys-devel/llvm-3.6"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+src_unpack() {
+ if [[ $PV = 9999* ]]; then
+ git-r3_src_unpack
+ else
+ default
+ mv ${PN}-*/ ${P} || die
+ fi
+}
+
+src_configure() {
+ ./configure.py \
+ --with-llvm-config="${EPREFIX}/usr/bin/llvm-config" \
+ --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake VERBOSE=1
+}
diff --git a/dev-libs/libclc/metadata.xml b/dev-libs/libclc/metadata.xml
new file mode 100644
index 00000000000..01c4c004e73
--- /dev/null
+++ b/dev-libs/libclc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>