summaryrefslogtreecommitdiff
path: root/dev-libs/libdivecomputer
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libdivecomputer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libdivecomputer')
-rw-r--r--dev-libs/libdivecomputer/Manifest2
-rw-r--r--dev-libs/libdivecomputer/libdivecomputer-0.4.1.ebuild75
-rw-r--r--dev-libs/libdivecomputer/libdivecomputer-0.4.2.ebuild75
-rw-r--r--dev-libs/libdivecomputer/libdivecomputer-9999.ebuild63
-rw-r--r--dev-libs/libdivecomputer/metadata.xml21
5 files changed, 236 insertions, 0 deletions
diff --git a/dev-libs/libdivecomputer/Manifest b/dev-libs/libdivecomputer/Manifest
new file mode 100644
index 00000000000..d742d7e701d
--- /dev/null
+++ b/dev-libs/libdivecomputer/Manifest
@@ -0,0 +1,2 @@
+DIST libdivecomputer-0.4.1.tar.gz 481798 SHA256 7d64032d2e5cd4d6315ebb7ed5bcccc9399166d40228ae2e96e435749b950a0a SHA512 a1104981b1820ea93c3b3e389e42996f9199c5a4c37daf16e9577d8fd29b21440521d1ea5f89ec2df2861b582fd2e748d35eb811ad0d484eacce7d13d39bf88f WHIRLPOOL 7bc1d3a856f3f41cd3126ea1df61ead93e549c39442355f7730c3f0db981e1663c1ca86ee0db0b850bc3af55af0694100a1df7ce0754af665be3dc3c9388e919
+DIST libdivecomputer-0.4.2.tar.gz 487401 SHA256 f3c5d0229de9dd82602e309273d0eb48fb0ee07fdcfc1ff8206edb6ba5154460 SHA512 590aca350d86d17a889f47238ad46f0a6a1353b5f7ed67c64a9bae303a010ab042e94a73a36c6f05f2d03d10c80b1fae49431ad581b3024db83b81711d5d1048 WHIRLPOOL c6cd91feae2a0a87bc7fc09021239f7210b99b27e51b372d35090304ce91c2166ac077d211a3aecd18ce7d89bb191c9cf6496bc9f6ddd727832de6eca74c91c3
diff --git a/dev-libs/libdivecomputer/libdivecomputer-0.4.1.ebuild b/dev-libs/libdivecomputer/libdivecomputer-0.4.1.ebuild
new file mode 100644
index 00000000000..566d7aae6da
--- /dev/null
+++ b/dev-libs/libdivecomputer/libdivecomputer-0.4.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://libdivecomputer.git.sourceforge.net/gitroot/libdivecomputer/libdivecomputer"
+ GIT_ECLASS="git-2"
+ AUTOTOOLIZE=yes
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit eutils autotools-utils ${GIT_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.divesoftware.org/libdc/releases/${P}.tar.gz"
+fi
+
+DESCRIPTION="Library for communication with dive computers from various manufacturers"
+HOMEPAGE="http://www.divesoftware.org/libdc"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+IUSE="usb +static-libs -tools"
+
+RDEPEND="usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ -n ${AUTOTOOLIZE} ]]; then
+ autotools-utils_src_prepare
+ else
+ epatch_user
+ fi
+}
+
+src_configure() {
+ autotools-utils_src_configure
+
+ if ! use tools ; then
+ sed -i 's|examples||' Makefile || die "sed failed"
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use tools ; then
+ einfo "prefixing tools with 'dctool_'"
+ pushd "${D}/usr/bin/"
+ for file in * ; do
+ mv "${file}" "dctool_${file}" || die "prefixing tools failed"
+ done
+ popd
+ fi
+}
+
+pkg_postinst() {
+ if use tools ; then
+ elog "The 'tools' USE flag has been enabled,"
+ elog "to avoid file collisions, all ${PN}"
+ elog "related tools have been prefixed with 'dctool_'"
+ fi
+}
diff --git a/dev-libs/libdivecomputer/libdivecomputer-0.4.2.ebuild b/dev-libs/libdivecomputer/libdivecomputer-0.4.2.ebuild
new file mode 100644
index 00000000000..566d7aae6da
--- /dev/null
+++ b/dev-libs/libdivecomputer/libdivecomputer-0.4.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://libdivecomputer.git.sourceforge.net/gitroot/libdivecomputer/libdivecomputer"
+ GIT_ECLASS="git-2"
+ AUTOTOOLIZE=yes
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit eutils autotools-utils ${GIT_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.divesoftware.org/libdc/releases/${P}.tar.gz"
+fi
+
+DESCRIPTION="Library for communication with dive computers from various manufacturers"
+HOMEPAGE="http://www.divesoftware.org/libdc"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+IUSE="usb +static-libs -tools"
+
+RDEPEND="usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ -n ${AUTOTOOLIZE} ]]; then
+ autotools-utils_src_prepare
+ else
+ epatch_user
+ fi
+}
+
+src_configure() {
+ autotools-utils_src_configure
+
+ if ! use tools ; then
+ sed -i 's|examples||' Makefile || die "sed failed"
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use tools ; then
+ einfo "prefixing tools with 'dctool_'"
+ pushd "${D}/usr/bin/"
+ for file in * ; do
+ mv "${file}" "dctool_${file}" || die "prefixing tools failed"
+ done
+ popd
+ fi
+}
+
+pkg_postinst() {
+ if use tools ; then
+ elog "The 'tools' USE flag has been enabled,"
+ elog "to avoid file collisions, all ${PN}"
+ elog "related tools have been prefixed with 'dctool_'"
+ fi
+}
diff --git a/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild b/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
new file mode 100644
index 00000000000..9764283903e
--- /dev/null
+++ b/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://libdivecomputer.git.sourceforge.net/gitroot/libdivecomputer/libdivecomputer"
+ GIT_ECLASS="git-2"
+ AUTOTOOLS_AUTORECONF=1
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit eutils autotools-utils ${GIT_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.divesoftware.org/libdc/releases/${P}.tar.gz"
+fi
+
+DESCRIPTION="Library for communication with dive computers from various manufacturers"
+HOMEPAGE="http://www.divesoftware.org/libdc"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+IUSE="usb +static-libs -tools"
+
+RDEPEND="usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ autotools-utils_src_configure
+
+ if ! use tools ; then
+ sed -i 's|examples||' Makefile || die "sed failed"
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use tools ; then
+ einfo "prefixing tools with 'dctool_'"
+ pushd "${D}/usr/bin/"
+ for file in * ; do
+ mv "${file}" "dctool_${file}" || die "prefixing tools failed"
+ done
+ popd
+ fi
+}
+
+pkg_postinst() {
+ if use tools ; then
+ elog "The 'tools' USE flag has been enabled,"
+ elog "to avoid file collisions, all ${PN}"
+ elog "related tools have been prefixed with 'dctool_'"
+ fi
+}
diff --git a/dev-libs/libdivecomputer/metadata.xml b/dev-libs/libdivecomputer/metadata.xml
new file mode 100644
index 00000000000..567d2b150e4
--- /dev/null
+++ b/dev-libs/libdivecomputer/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>me@bearsh.org</email>
+ <name>Martin Gysel</name>
+ <description>Proxied maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>aaron@flappyport.com</email>
+ <name>Aaron Bauman</name>
+ <description>Proxied maintainer. CC him on bugs.</description>
+ </maintainer>
+ <longdescription lang="en">
+ Library for communication with dive computers from various manufacturers.
+ </longdescription>
+ <use>
+ <flag name="tools">Install tools that can be used to test the library.</flag>
+ </use>
+</pkgmetadata>