summaryrefslogtreecommitdiff
path: root/dev-libs/libevdev
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libevdev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libevdev')
-rw-r--r--dev-libs/libevdev/Manifest3
-rw-r--r--dev-libs/libevdev/libevdev-1.3.ebuild25
-rw-r--r--dev-libs/libevdev/libevdev-1.4.3.ebuild25
-rw-r--r--dev-libs/libevdev/libevdev-1.4.ebuild25
-rw-r--r--dev-libs/libevdev/metadata.xml5
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/libevdev/Manifest b/dev-libs/libevdev/Manifest
new file mode 100644
index 00000000000..15d24fee064
--- /dev/null
+++ b/dev-libs/libevdev/Manifest
@@ -0,0 +1,3 @@
+DIST libevdev-1.3.tar.xz 392744 SHA256 265411ce79a592b3074e9d07fb97d462745d0c7ef178254a6f720245ed253446 SHA512 d208a9be788e5531e2fd83da8bdef58245a0265a0551f28645a7de157d165cee161c8c5cde50156bbf6414b719d6a0125b4263ecf0f60c71ec864a21afcd303c WHIRLPOOL 01335f51ba67c01f9cff15592468bb5ab675fefd75dee859663c8df02c04d52a14f62a442dd841d9473fcefd4ea6fb1abe3e7cc54282a605f8ba0d61ed4d0a7a
+DIST libevdev-1.4.3.tar.xz 408448 SHA256 1c418b26fd78b0e9900872be2f77fb5311c877b34ec5c75efd1b670ed627969b SHA512 b5d9446aa47c2abc2c1476f188400f5fcdd2c1f1f5304cd7ce1731dfcd426f892adebe4958f2f65adb832352f203039a1413636c82e51955583d5ede9d2325af WHIRLPOOL 9188781d3c47cf0efddfe1fa8ab8bf5dd697bf156bdf7ec996abbdd69cf5002735bb9092b8e89a7ba29ac952a9d2c3553ba932e104bd0d4a3940b2cf15a459d5
+DIST libevdev-1.4.tar.xz 396560 SHA256 3223378a5c2b4fea51a1601b0404700a6ddc1e2150eb9d5f62f001ffe21dfa06 SHA512 bc1bb73cde3471727999745187e7bdf9a438c7782d9794723c9235c4121fa607c20a3e616c268f90c8096fcc670bcca27b21bbb9cce363701224c91c0d9a351a WHIRLPOOL 7470a354849394c0caef730e744615782a81b4229886ea08249df0c118d64b702ca998434b83aabadbf49dab1d0d495df27555de9c30efabab19bb1d0cbcc943
diff --git a/dev-libs/libevdev/libevdev-1.3.ebuild b/dev-libs/libevdev/libevdev-1.3.ebuild
new file mode 100644
index 00000000000..8ad8e51aa1a
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_MULTILIB=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}.git"
+
+DESCRIPTION="Handler library for evdev events"
+
+if [[ ${PV} == 9999* ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+fi
+
+RESTRICT="test" # Tests need to run as root.
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
diff --git a/dev-libs/libevdev/libevdev-1.4.3.ebuild b/dev-libs/libevdev/libevdev-1.4.3.ebuild
new file mode 100644
index 00000000000..8873d701d99
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_MULTILIB=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}.git"
+
+DESCRIPTION="Handler library for evdev events"
+
+if [[ ${PV} == 9999* ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+fi
+
+RESTRICT="test" # Tests need to run as root.
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
diff --git a/dev-libs/libevdev/libevdev-1.4.ebuild b/dev-libs/libevdev/libevdev-1.4.ebuild
new file mode 100644
index 00000000000..8873d701d99
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_MULTILIB=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}.git"
+
+DESCRIPTION="Handler library for evdev events"
+
+if [[ ${PV} == 9999* ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+fi
+
+RESTRICT="test" # Tests need to run as root.
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
diff --git a/dev-libs/libevdev/metadata.xml b/dev-libs/libevdev/metadata.xml
new file mode 100644
index 00000000000..01c4c004e73
--- /dev/null
+++ b/dev-libs/libevdev/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>