summaryrefslogtreecommitdiff
path: root/dev-libs/libevocosm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libevocosm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libevocosm')
-rw-r--r--dev-libs/libevocosm/Manifest1
-rw-r--r--dev-libs/libevocosm/files/libevocosm-3.3.1-gcc47.patch20
-rw-r--r--dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild49
-rw-r--r--dev-libs/libevocosm/metadata.xml5
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/libevocosm/Manifest b/dev-libs/libevocosm/Manifest
new file mode 100644
index 00000000000..f1e7e3bfc39
--- /dev/null
+++ b/dev-libs/libevocosm/Manifest
@@ -0,0 +1 @@
+DIST libevocosm-3.3.1.tar.gz 414392 SHA256 a1c7380e627b688540c3dc9652dc38b132beec7afbb7b0420d30e1e605b997ba SHA512 ebb4200ac533bdb86051a8a33e5da08d677ae0aa8c2e65a9855e9465b76827c0a72f31e260ee34be62600cd22794a4e47c4471623de8d9fcb4749dcf0a37d946 WHIRLPOOL 430c4d826ff7106c7a1520f3acfa044f233a381bb9f18a292a495b9db49a4beb9888df5a5afec101b9d8a841c2ec618b213aa9830403db57f9bb95d8d2c17170
diff --git a/dev-libs/libevocosm/files/libevocosm-3.3.1-gcc47.patch b/dev-libs/libevocosm/files/libevocosm-3.3.1-gcc47.patch
new file mode 100644
index 00000000000..1e286a0215e
--- /dev/null
+++ b/dev-libs/libevocosm/files/libevocosm-3.3.1-gcc47.patch
@@ -0,0 +1,20 @@
+ https://bugs.gentoo.org/421607
+
+ evocommon.h:468:29: error: 'usleep' was not declared in this scope
+
+ libevocosm/evocommon.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- a/libevocosm/evocommon.h
++++ b/libevocosm/evocommon.h
+@@ -54,6 +54,10 @@
+ #undef min
+ #endif
+
++#if !defined(_MSC_VER)
++#include "unistd.h"
++#endif
++
+ namespace libevocosm
+ {
+ //! The random number generator used by Evocosm
diff --git a/dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild b/dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild
new file mode 100644
index 00000000000..88c634efeab
--- /dev/null
+++ b/dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A C++ framework for evolutionary computing"
+HOMEPAGE="http://www.coyotegulch.com/products/libevocosm/"
+SRC_URI="http://www.coyotegulch.com/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/libcoyotl
+ dev-libs/libbrahe"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc47.patch"
+ epatch_user
+}
+
+src_configure() {
+ export ac_cv_prog_HAVE_DOXYGEN="false"
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ cd docs
+ doxygen libevocosm.doxygen || die "generating docs failed"
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use doc && dohtml docs/html/*
+}
diff --git a/dev-libs/libevocosm/metadata.xml b/dev-libs/libevocosm/metadata.xml
new file mode 100644
index 00000000000..8434377a604
--- /dev/null
+++ b/dev-libs/libevocosm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cpp</herd>
+</pkgmetadata>