summaryrefslogtreecommitdiff
path: root/dev-libs/libgaminggear
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libgaminggear
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libgaminggear')
-rw-r--r--dev-libs/libgaminggear/Manifest1
-rw-r--r--dev-libs/libgaminggear/files/libgaminggear-0.10.0-doc.patch15
-rw-r--r--dev-libs/libgaminggear/libgaminggear-0.10.1.ebuild56
-rw-r--r--dev-libs/libgaminggear/metadata.xml13
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-libs/libgaminggear/Manifest b/dev-libs/libgaminggear/Manifest
new file mode 100644
index 00000000000..68886a8a2a6
--- /dev/null
+++ b/dev-libs/libgaminggear/Manifest
@@ -0,0 +1 @@
+DIST libgaminggear-0.10.1.tar.bz2 101415 SHA256 1e2626a81b41b74f26ac422c19cdafe858aeb2a572e53c0b2212064e69f14254 SHA512 60f30e1b05c31fb6072f5bd74d7edcd2039fe632c18183e122625bf5f16563e77599e22fc4926e7e6c43d985b3d8840ba9e5cc16b6cb8fb0986c9d49244b3e7c WHIRLPOOL 75e4759d0a2895f7bec0c17a490fbd2c2880fb575e8cdea116d229bab51e747db158c3a90bfb111bebf74bf650438b4c97463ea890592b3984eb77b934dc511e
diff --git a/dev-libs/libgaminggear/files/libgaminggear-0.10.0-doc.patch b/dev-libs/libgaminggear/files/libgaminggear-0.10.0-doc.patch
new file mode 100644
index 00000000000..853684e2b09
--- /dev/null
+++ b/dev-libs/libgaminggear/files/libgaminggear-0.10.0-doc.patch
@@ -0,0 +1,15 @@
+Set install of the docs to DOCDIR
+--- libgaminggear-0.10.0.orig/include/gaminggear/CMakeLists.txt 2015-06-28 12:46:22.615985840 +0100
++++ libgaminggear-0.10.0/include/gaminggear/CMakeLists.txt 2015-06-28 13:01:35.511970664 +0100
+@@ -14,10 +14,10 @@ IF(WITH_DOC)
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/html/index.html
+ )
+-
++
+ INSTALL(
+ DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html
+- DESTINATION share/doc/libgaminggear
++ DESTINATION ${DOCDIR}
+ )
+ ENDIF()
diff --git a/dev-libs/libgaminggear/libgaminggear-0.10.1.ebuild b/dev-libs/libgaminggear/libgaminggear-0.10.1.ebuild
new file mode 100644
index 00000000000..e2cdc0d9913
--- /dev/null
+++ b/dev-libs/libgaminggear/libgaminggear-0.10.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Provides functionality for gaming input devices"
+
+HOMEPAGE="http://sourceforge.net/projects/libgaminggear/"
+SRC_URI="mirror://sourceforge/libgaminggear/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ media-libs/libcanberra
+ virtual/libusb:1
+ dev-libs/dbus-glib
+"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.10.0-doc.patch
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DDOCDIR=share/doc/${PF}
+ $(cmake-utils_use_with doc DOC)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/dev-libs/libgaminggear/metadata.xml b/dev-libs/libgaminggear/metadata.xml
new file mode 100644
index 00000000000..42ec8f86d10
--- /dev/null
+++ b/dev-libs/libgaminggear/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>dpisklov@gmail.com</email>
+ <name>Dmitry Pisklov</name>
+ <description>Proxy maintainer. Assign bugs to him</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">libgaminggear</remote-id>
+ </upstream>
+</pkgmetadata>