summaryrefslogtreecommitdiff
path: root/dev-libs/libgdata
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libgdata
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libgdata')
-rw-r--r--dev-libs/libgdata/Manifest3
-rw-r--r--dev-libs/libgdata/libgdata-0.16.1.ebuild69
-rw-r--r--dev-libs/libgdata/libgdata-0.17.1.ebuild65
-rw-r--r--dev-libs/libgdata/libgdata-0.17.2.ebuild63
-rw-r--r--dev-libs/libgdata/metadata.xml5
5 files changed, 205 insertions, 0 deletions
diff --git a/dev-libs/libgdata/Manifest b/dev-libs/libgdata/Manifest
new file mode 100644
index 00000000000..2ddf6df4f4f
--- /dev/null
+++ b/dev-libs/libgdata/Manifest
@@ -0,0 +1,3 @@
+DIST libgdata-0.16.1.tar.xz 1551960 SHA256 8740e071ecb2ae0d2a4b9f180d2ae5fdf9dc4c41e7ff9dc7e057f62442800827 SHA512 81fd252e24ba0068b401e3de61b4a23575dae0790f4caf646e56a57aab815a70a207b2492efa4213f51ac1d7c752d4ec0c1c9a35d7109f6a63668af05e142039 WHIRLPOOL 892a7823a85bc771b502f7b564156eaede676c3e2cf7406e9b808a3f4fbfa6e9be1ad1ec1cb79ca1b42dc0bf54f6d46560e2a863e8861f186802a91f91de2d4d
+DIST libgdata-0.17.1.tar.xz 1600164 SHA256 5ef1c0f246f60812c43e3a7d077442afc872913a03f3a5eb789698dc2319bd95 SHA512 3fc6c074d413fba76e6e67fa3f4b14881fe9208d7a16c3038353f0a245cadf06bc25d0d7af381b88da965b327e6da9220386c1333942c33f6e4e9d9c2ec82668 WHIRLPOOL 0f9adc9a67edfb2dc0893d90bdf61a51e80e2f95bd4b122d1ba9238c1333fcbda6cf3a2bb32a6274655d318dea95d7dbd7853f86fbd71aea563c16ba74d52a1d
+DIST libgdata-0.17.2.tar.xz 1522224 SHA256 9b9b4f68bef86ee2926ea14f182baf7ddaa6717dd138b5ff670f07d126176fe0 SHA512 e1435a074da1a5f573c0e63f6c3117f0f33cf78929780e26fe60769a6385321808783d7363203e9f9f6ba7529a2214af579e3a4fa2307eab224dc5af77ca7fe6 WHIRLPOOL bbbc6f29fbc33a057702df205aef5f09c21ec789cc9c610a1957b92cdc3cd13703c760e493f2b023ee787662432cd24f997cb6d9179cd6abc40c3204fe651aca
diff --git a/dev-libs/libgdata/libgdata-0.16.1.ebuild b/dev-libs/libgdata/libgdata-0.16.1.ebuild
new file mode 100644
index 00000000000..ee5232f4dc7
--- /dev/null
+++ b/dev-libs/libgdata/libgdata-0.16.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+VALA_MIN_API_VERSION="0.20"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/19" # subslot = libgdata soname version
+IUSE="gnome +introspection static-libs test vala"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+REQUIRED_IUSE="vala? ( introspection )"
+
+# gtk+ is needed for gdk
+# configure checks for gtk:3, but only uses it for demos which are not installed
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/json-glib-0.15
+ >=dev-libs/libxml2-2:2
+ >=net-libs/liboauth-0.9.4
+ >=net-libs/libsoup-2.42.0:2.4[introspection?]
+ >=x11-libs/gdk-pixbuf-2.14:2
+ gnome? (
+ app-crypt/gcr:=
+ >=net-libs/gnome-online-accounts-3.8 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40
+ >=gnome-base/gnome-common-3.6
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ # Disable tests requiring network access, bug #307725
+ sed -e '/^TEST_PROGS = / s:\(.*\):TEST_PROGS = general perf calendar client-login-authorizer contacts documents oauth1-authorizer picasaweb youtube \nOLD_\1:' \
+ -i gdata/tests/Makefile.in || die "network test disable failed"
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_configure \
+ $(use_enable gnome) \
+ $(use_enable gnome goa) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GSETTINGS_BACKEND="memory" #486412
+ dbus-launch emake check
+}
diff --git a/dev-libs/libgdata/libgdata-0.17.1.ebuild b/dev-libs/libgdata/libgdata-0.17.1.ebuild
new file mode 100644
index 00000000000..6a722b4b4ce
--- /dev/null
+++ b/dev-libs/libgdata/libgdata-0.17.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+VALA_MIN_API_VERSION="0.20"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/22" # subslot = libgdata soname version
+IUSE="gnome +introspection static-libs test vala"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_IUSE="vala? ( introspection )"
+
+# gtk+ is needed for gdk
+# configure checks for gtk:3, but only uses it for demos which are not installed
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/json-glib-0.15
+ >=dev-libs/libxml2-2:2
+ >=net-libs/liboauth-0.9.4
+ >=net-libs/libsoup-2.42.0:2.4[introspection?]
+ >=x11-libs/gdk-pixbuf-2.14:2
+ gnome? (
+ app-crypt/gcr:=
+ >=net-libs/gnome-online-accounts-3.8 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40
+ >=gnome-base/gnome-common-3.6
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_configure \
+ $(use_enable gnome) \
+ $(use_enable gnome goa) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GSETTINGS_BACKEND="memory" #486412
+ dbus-launch emake check
+}
diff --git a/dev-libs/libgdata/libgdata-0.17.2.ebuild b/dev-libs/libgdata/libgdata-0.17.2.ebuild
new file mode 100644
index 00000000000..3df650fc790
--- /dev/null
+++ b/dev-libs/libgdata/libgdata-0.17.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/22" # subslot = libgdata soname version
+IUSE="gnome +introspection static-libs test vala"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_IUSE="vala? ( introspection )"
+
+# gtk+ is needed for gdk
+# configure checks for gtk:3, but only uses it for demos which are not installed
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/json-glib-0.15
+ >=dev-libs/libxml2-2:2
+ >=net-libs/liboauth-0.9.4
+ >=net-libs/libsoup-2.42.0:2.4[introspection?]
+ >=x11-libs/gdk-pixbuf-2.14:2
+ gnome? (
+ app-crypt/gcr:=
+ >=net-libs/gnome-online-accounts-3.8 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ test? ( >=net-libs/uhttpmock-0.5 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_configure \
+ $(use_enable gnome) \
+ $(use_enable gnome goa) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_enable static-libs static) \
+ $(use_enable test always-build-tests)
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GSETTINGS_BACKEND="memory" #486412
+ dbus-launch emake check
+}
diff --git a/dev-libs/libgdata/metadata.xml b/dev-libs/libgdata/metadata.xml
new file mode 100644
index 00000000000..da6fd63d008
--- /dev/null
+++ b/dev-libs/libgdata/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>