summaryrefslogtreecommitdiff
path: root/dev-libs/libgit2
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-10 08:56:30 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-10 08:58:06 +0200
commitac69fa3d5bd64b6d798b8ffb4869b646bd5bffa1 (patch)
tree74ec26aa02c0063f325eaf4e0560af5f4f340a4d /dev-libs/libgit2
parentfa3b0b415cd0c9422036864134dcd6b6ef346528 (diff)
downloadgentoo-ac69fa3d5bd64b6d798b8ffb4869b646bd5bffa1.tar.gz
gentoo-ac69fa3d5bd64b6d798b8ffb4869b646bd5bffa1.tar.xz
dev-libs/libgit2: Remove vulnerable 0.27.[12]
Bug: https://bugs.gentoo.org/660834
Diffstat (limited to 'dev-libs/libgit2')
-rw-r--r--dev-libs/libgit2/Manifest2
-rw-r--r--dev-libs/libgit2/libgit2-0.27.1.ebuild80
-rw-r--r--dev-libs/libgit2/libgit2-0.27.2.ebuild80
3 files changed, 0 insertions, 162 deletions
diff --git a/dev-libs/libgit2/Manifest b/dev-libs/libgit2/Manifest
index 046c245c1f2..2ad164151b7 100644
--- a/dev-libs/libgit2/Manifest
+++ b/dev-libs/libgit2/Manifest
@@ -1,5 +1,3 @@
DIST libgit2-0.26.4.tar.gz 4733342 BLAKE2B 76dfacbf6df9128625e52f4c554814a971f446a44c9706a915200976f5a873a2add1869c0534360ccad821df11246faacfff43765f311162bcb6afca46088a77 SHA512 c65a0ef8e7ef2dc60d07bced36b8cfd26ce9c40f99978058fc67b30e5bbda8d6b15e26aec7b1277bb277123685e763d106bab175540fceb449bb5b50f776473a
DIST libgit2-0.26.5.tar.gz 4734075 BLAKE2B cdc34a5792576d97d8bc8a8c998e610e9c2caab4899f55bfd11da382d73d3061277ac068edd20c8e31d7cf5c3b26ca688fd67eb43ca7b9e0b82413fb04d04b3f SHA512 7dd7c567ad776db76b3514e6532f52841a4279b58dc51b44d39ab53b6911220cb60ee8f37b4c6ad6f369edbbd43a2591cf5f46aca354282f56735c8b215d533b
-DIST libgit2-0.27.1.tar.gz 4765926 BLAKE2B 2eb34a621d61b1fb3b770081e27b92d662fd235750fc6ea580ddabeac5cfd20e40a70ce830d45144531c333239d173a322d0de343bb98cc02ce9bfb7822432bf SHA512 4cdee4aec0f0c7b36226ee29276b8802d6b59817f95b1357f35225c23a8d6de70242b2dd9a5fb3b765c3242f4ed1848933e20fc24899071d8b443d46c43ce99d
-DIST libgit2-0.27.2.tar.gz 4770842 BLAKE2B 8a46589a17c4bbd0e821412ad259099a77755073736c7ba469a593252160bb1e5601c8b91e1e26e17c11ae3fd6e3d2bf87d22b638b1d473371311487e96ca39b SHA512 4fa2b6c1bb340d5dbc3106ababb630a4634cee2415d478be986d315ef9c659d772574a56f0b8fa77d26bd793aea92893fddf64b5f21d7c965069f928b9ce5cff
DIST libgit2-0.27.3.tar.gz 4771877 BLAKE2B a15aed24d0391cf8d5c74329f5064d703def5db1cbf132881279d501d1ba31002367e54171e8a341b75862d327eddb1abebdaeeaee6878a14ad1d8abbbc8402d SHA512 e470050b89289908ec64dafaa954ad9bfc8f557ba7dafcab440d9efde474f736c025d8202bfd81a508070d9cf678f3fb1f3687d72a849ce86edd1ee90ad13c3b
diff --git a/dev-libs/libgit2/libgit2-0.27.1.ebuild b/dev-libs/libgit2/libgit2-0.27.1.ebuild
deleted file mode 100644
index 456ded8f18d..00000000000
--- a/dev-libs/libgit2/libgit2-0.27.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~ppc-macos"
-fi
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.github.com/"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/27"
-IUSE="+curl examples gssapi libressl +ssh test +threads trace"
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- sys-libs/zlib
- net-libs/http-parser:=
- curl? (
- !libressl? ( net-misc/curl:=[curl_ssl_openssl(-)] )
- libressl? ( net-misc/curl:=[curl_ssl_libressl(-)] )
- )
- gssapi? ( virtual/krb5 )
- ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
-
-src_prepare() {
- # skip online tests
- sed -i '/libgit2_clar/s/-ionline/-xonline/' tests/CMakeLists.txt || die
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
- -DBUILD_CLAR=$(usex test)
- -DENABLE_TRACE=$(usex trace)
- -DUSE_GSSAPI=$(usex gssapi)
- -DUSE_SSH=$(usex ssh)
- -DTHREADSAFE=$(usex threads)
- -DCURL=$(usex curl)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- if [[ ${EUID} -eq 0 ]] ; then
- # repo::iterator::fs_preserves_error fails if run as root
- # since root can still access dirs with 0000 perms
- ewarn "Skipping tests: non-root privileges are required for all tests to pass"
- else
- local TEST_VERBOSE=1
- cmake-utils_src_test
- fi
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use examples ; then
- find examples -name '.gitignore' -delete || die
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-libs/libgit2/libgit2-0.27.2.ebuild b/dev-libs/libgit2/libgit2-0.27.2.ebuild
deleted file mode 100644
index 456ded8f18d..00000000000
--- a/dev-libs/libgit2/libgit2-0.27.2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~ppc-macos"
-fi
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.github.com/"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/27"
-IUSE="+curl examples gssapi libressl +ssh test +threads trace"
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- sys-libs/zlib
- net-libs/http-parser:=
- curl? (
- !libressl? ( net-misc/curl:=[curl_ssl_openssl(-)] )
- libressl? ( net-misc/curl:=[curl_ssl_libressl(-)] )
- )
- gssapi? ( virtual/krb5 )
- ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
-
-src_prepare() {
- # skip online tests
- sed -i '/libgit2_clar/s/-ionline/-xonline/' tests/CMakeLists.txt || die
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
- -DBUILD_CLAR=$(usex test)
- -DENABLE_TRACE=$(usex trace)
- -DUSE_GSSAPI=$(usex gssapi)
- -DUSE_SSH=$(usex ssh)
- -DTHREADSAFE=$(usex threads)
- -DCURL=$(usex curl)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- if [[ ${EUID} -eq 0 ]] ; then
- # repo::iterator::fs_preserves_error fails if run as root
- # since root can still access dirs with 0000 perms
- ewarn "Skipping tests: non-root privileges are required for all tests to pass"
- else
- local TEST_VERBOSE=1
- cmake-utils_src_test
- fi
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use examples ; then
- find examples -name '.gitignore' -delete || die
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}