summaryrefslogtreecommitdiff
path: root/dev-libs/libindicator
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libindicator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libindicator')
-rw-r--r--dev-libs/libindicator/Manifest2
-rw-r--r--dev-libs/libindicator/libindicator-12.10.0-r200.ebuild43
-rw-r--r--dev-libs/libindicator/libindicator-12.10.0-r300.ebuild40
-rw-r--r--dev-libs/libindicator/libindicator-12.10.1-r200.ebuild43
-rw-r--r--dev-libs/libindicator/libindicator-12.10.1-r201.ebuild50
-rw-r--r--dev-libs/libindicator/libindicator-12.10.1-r300.ebuild40
-rw-r--r--dev-libs/libindicator/libindicator-12.10.1-r301.ebuild46
-rw-r--r--dev-libs/libindicator/metadata.xml11
8 files changed, 275 insertions, 0 deletions
diff --git a/dev-libs/libindicator/Manifest b/dev-libs/libindicator/Manifest
new file mode 100644
index 00000000000..7a579eeb447
--- /dev/null
+++ b/dev-libs/libindicator/Manifest
@@ -0,0 +1,2 @@
+DIST libindicator-12.10.0.tar.gz 427575 SHA256 dd8e5cb40407da9c837793af5c9e62e73c2054525733c7cd654c387bb010c2e4 SHA512 c0b9dc5a6c7b3ddd9392ae5a5db40f216439b869426e5b8a307a4adee5290376c2edc32f3a0268aafe63ae8b80dc0298b125c6c539c50a5c5545d7d727679007 WHIRLPOOL a7252a2646bdb250d4f756439d338e4defda6ff380d864cf97bcc2d2f023ef3f69ca37b28898cb2d5e87523d6cb5c4b690b735869435a020ad2fb49bb22b8fea
+DIST libindicator-12.10.1.tar.gz 427764 SHA256 b2d2e44c10313d5c9cd60db455d520f80b36dc39562df079a3f29495e8f9447f SHA512 d6d77d0309b15cf6b52539323920ab0c1594cb1c1cef8a8d67cd0f76f8ceeeac28eb6db6227563df1932e6f1fadcffac68d82982182b745257dfaf91f1c945af WHIRLPOOL 0fd630c390c16cd42a133c2eb2f7471e7d231de6c1c15a187e608bb305cac1435d5fa753043fc88825e53f081dffe0974d960e047b48fa9871426e09b5e1fd4e
diff --git a/dev-libs/libindicator/libindicator-12.10.0-r200.ebuild b/dev-libs/libindicator/libindicator-12.10.0-r200.ebuild
new file mode 100644
index 00000000000..b95353bf4a8
--- /dev/null
+++ b/dev-libs/libindicator/libindicator-12.10.0-r200.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic virtualx
+
+DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
+HOMEPAGE="http://launchpad.net/libindicator"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.22
+ >=x11-libs/gtk+-2.18:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/dbus-test-runner )"
+
+src_configure() {
+ append-flags -Wno-error
+
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ --with-gtk=2
+}
+
+src_test() {
+ Xemake check #391179
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ prune_libtool_files --all
+
+ rm -vf \
+ "${ED}"/usr/lib*/libdummy-indicator-* \
+ "${ED}"/usr/share/${PN}/*indicator-debugging
+}
diff --git a/dev-libs/libindicator/libindicator-12.10.0-r300.ebuild b/dev-libs/libindicator/libindicator-12.10.0-r300.ebuild
new file mode 100644
index 00000000000..e3ff033d25d
--- /dev/null
+++ b/dev-libs/libindicator/libindicator-12.10.0-r300.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic virtualx
+
+DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
+HOMEPAGE="http://launchpad.net/libindicator"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.22
+ >=x11-libs/gtk+-3.2:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/dbus-test-runner )"
+
+src_configure() {
+ append-flags -Wno-error
+
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ --with-gtk=3
+}
+
+src_test() {
+ Xemake check #391179
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libindicator/libindicator-12.10.1-r200.ebuild b/dev-libs/libindicator/libindicator-12.10.1-r200.ebuild
new file mode 100644
index 00000000000..21495aa2fad
--- /dev/null
+++ b/dev-libs/libindicator/libindicator-12.10.1-r200.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic virtualx
+
+DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
+HOMEPAGE="http://launchpad.net/libindicator"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.22
+ >=x11-libs/gtk+-2.18:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/dbus-test-runner )"
+
+src_configure() {
+ append-flags -Wno-error
+
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ --with-gtk=2
+}
+
+src_test() {
+ Xemake check #391179
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ prune_libtool_files --all
+
+ rm -vf \
+ "${ED}"/usr/lib*/libdummy-indicator-* \
+ "${ED}"/usr/share/${PN}/*indicator-debugging
+}
diff --git a/dev-libs/libindicator/libindicator-12.10.1-r201.ebuild b/dev-libs/libindicator/libindicator-12.10.1-r201.ebuild
new file mode 100644
index 00000000000..f003f7a6332
--- /dev/null
+++ b/dev-libs/libindicator/libindicator-12.10.1-r201.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic virtualx multilib-minimal
+
+DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
+HOMEPAGE="http://launchpad.net/libindicator"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.22[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.18:2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( dev-util/dbus-test-runner )"
+
+multilib_src_configure() {
+ append-flags -Wno-error
+
+ myconf=(
+ --disable-silent-rules
+ --disable-static
+ --with-gtk=2
+ )
+ local ECONF_SOURCE=${S}
+ econf "${myconf[@]}"
+}
+
+multilib_src_test() {
+ Xemake check #391179
+}
+
+multilib_src_install() {
+ emake -j1 DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ rm -vf \
+ "${ED}"/usr/lib*/libdummy-indicator-* \
+ "${ED}"/usr/share/${PN}/*indicator-debugging
+}
diff --git a/dev-libs/libindicator/libindicator-12.10.1-r300.ebuild b/dev-libs/libindicator/libindicator-12.10.1-r300.ebuild
new file mode 100644
index 00000000000..29701d462b7
--- /dev/null
+++ b/dev-libs/libindicator/libindicator-12.10.1-r300.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic virtualx
+
+DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
+HOMEPAGE="http://launchpad.net/libindicator"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.22
+ >=x11-libs/gtk+-3.2:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/dbus-test-runner )"
+
+src_configure() {
+ append-flags -Wno-error
+
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ --with-gtk=3
+}
+
+src_test() {
+ Xemake check #391179
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild b/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
new file mode 100644
index 00000000000..8e863b01d56
--- /dev/null
+++ b/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic virtualx multilib-minimal
+
+DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
+HOMEPAGE="http://launchpad.net/libindicator"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.22[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( dev-util/dbus-test-runner )"
+
+multilib_src_configure() {
+ append-flags -Wno-error
+
+ myconf=(
+ --disable-silent-rules
+ --disable-static
+ --with-gtk=3
+ )
+ local ECONF_SOURCE=${S}
+ econf "${myconf[@]}"
+}
+
+multilib_src_test() {
+ Xemake check #391179
+}
+
+multilib_src_install() {
+ emake -j1 DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libindicator/metadata.xml b/dev-libs/libindicator/metadata.xml
new file mode 100644
index 00000000000..97d25986e74
--- /dev/null
+++ b/dev-libs/libindicator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ayatana</herd>
+ <maintainer>
+ <email>ayatana-bugs@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">libindicator</remote-id>
+ </upstream>
+</pkgmetadata>