summaryrefslogtreecommitdiff
path: root/dev-libs/libinput
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-17 19:03:34 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-17 19:07:28 -0800
commit2a1ac5dee962669ec33f3a7dc756e671cbfec1c4 (patch)
treea9c57f2db32a215842b2d9b30f4d43bd5a83c622 /dev-libs/libinput
parentcc22695d48f81017b3983fae4e367ebdf2d3cc1e (diff)
downloadgentoo-2a1ac5dee962669ec33f3a7dc756e671cbfec1c4.tar.gz
gentoo-2a1ac5dee962669ec33f3a7dc756e671cbfec1c4.tar.xz
dev-libs/libinput: Version bump to 1.5.4.
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.5.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 6ca6dccbc80..717a497f1d2 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -4,3 +4,4 @@ DIST libinput-1.3.3.tar.xz 881992 SHA256 30c8edfe47654a38c235ac6b0541d79fd593d01
DIST libinput-1.4.2.tar.xz 900776 SHA256 8c38826a785594811bef6a9daadbfa2e172e3f070f8863393d6fb7ca4c68e451 SHA512 ecd1ddc737b8207d9e494f809340e2c0ac2927db80cf4c325ba12fb84387138d0128df7e841c87feafe425d6382f87f123f28531f7045fbcdd1176559895b79b WHIRLPOOL 99f18e00e2a4a284b7995f677053501989b526e16f41e508023638a1c0e660940d0cb991f399480a30a49073063aab1651e52bdea7861266300d9db885806ac4
DIST libinput-1.5.2.tar.xz 926048 SHA256 ba26e2bc64ed551eaef193178ed06b07b97a09ac6f4e442f5f15bbc3f3174682 SHA512 a3552f36fc91b523caceb128d048a0a7161335aef78554f202011fcc9acfb5f772d2124a4441f0f542f1b8051b8a2ecb7b00fad5456d8c06b213b96b9ebc91de WHIRLPOOL 025cd1b3261a977b2a579e03766939a443b6fa26b486e9fa16e445b39acf5d31b1f74260670b74718e5d11648c459b42b546e2311d5cac8a713a8a5b0e893791
DIST libinput-1.5.3.tar.xz 928852 SHA256 91206c523b4e7aeecf296d0b94276c61bea90b9260d198c8ee3a91eced10a6e3 SHA512 4d5ca9189275d6f2ed40ff85903bf10ae3b15ceaea43a3565384b6495a9b1764fed1f95c667dfa9e96170b3709a9c8dc1d1bad88cb82d0de69045b7c5f0bc7e6 WHIRLPOOL 548f08f755abf0c01c42a4e21abdcd4068b16dd57d37035922c390f17a9cfba52f56aab1dfb693ed13666a9d94cffef38cb4c7c7d030e9898c1bfdb3fb54d501
+DIST libinput-1.5.4.tar.xz 927448 SHA256 6f9ad1ede468bd54ec4469b8a4eb93a6f62f7fe6480c7a43e36c5d58cc2822b7 SHA512 114f436806fd27ece2b19577eefd3f6299cc88612f8437fd07ba1862c0bf4347ac5cc09fad9f798a5e242abd176cfb271fa52af04b0ef88da3210a96fd57a086 WHIRLPOOL d7c2ffd8212c4808641b65f553ea6c1553188a30279f8e3491767a8ba159d42dbd30a0cebc3a727542a83cf216c17d1b5f1504dc8fbb4f7b5664aac35b8032dc
diff --git a/dev-libs/libinput/libinput-1.5.4.ebuild b/dev-libs/libinput/libinput-1.5.4.ebuild
new file mode 100644
index 00000000000..4a42b03e9e4
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.5.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}