summaryrefslogtreecommitdiff
path: root/dev-libs/libinput
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-19 15:04:12 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-03-19 15:04:45 +0100
commit9db387eea6a180aa7a4e307e3faf86d9fbdc6779 (patch)
treec50912f077c2307f754f532cd8d29bb0316c2f5c /dev-libs/libinput
parent5c39c12df7042b72b40475f86bb8dd80a24bc771 (diff)
downloadgentoo-9db387eea6a180aa7a4e307e3faf86d9fbdc6779.tar.gz
gentoo-9db387eea6a180aa7a4e307e3faf86d9fbdc6779.tar.xz
dev-libs/libinput: Version bump to 1.2.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.2.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index a8e99bef8a5..b974d90b2b8 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -4,3 +4,4 @@ DIST libinput-1.1.0.tar.xz 802348 SHA256 673186ea2a0d2b695afaa9758834f9217b17577
DIST libinput-1.1.5.tar.xz 806960 SHA256 5e08c45dbb8bf32490cc6cd626da098564d646d161a07cba2e3adbd9745c0622 SHA512 031663c46b556048224aab018eb8ea76e34aace77508e52e6ef382a452585fafd4c91b427c0892aab3c624c0cfedc15c388922ae7166248e5da65575ff900c31 WHIRLPOOL 760cc1cf0c6657efbdadadd2f50e188d86465e1aa3f287275323d6fad9156b684de0d3b6dbf6e3fd5213018770726087ee282833f25ba5ef67918c0284b885a1
DIST libinput-1.2.0.tar.xz 866284 SHA256 1754b917fe675507ea80445b4f2e91d76cb6a6935508fe37234807affb316e2c SHA512 ab5b534ac5db7d4142e41c61e1f8fbc7f4c9cf89567fa27196fa9300f57db7328d61af25c93126905ad06061e1b2def0abe70654ac3710b6476379f84343cce8 WHIRLPOOL 2f74bcd3ae694db9f52c450c6b96d24fd320da2002e900cf69a3ce2d9c33b00213097c0330867f32b175b5fe80d06099c3bdc461a2001f4eee4f2481ab1e32fc
DIST libinput-1.2.1.tar.xz 863660 SHA256 e2db8c5357f8859b33c58e583601f50509f085ae9340a58790bcf44f1480c1c3 SHA512 6dceed081bb0c5374d39be7ce14ccbeb7734c50a648a155ca9d57f7dabde80a35a5b3b4eb15f37ce5c475725a13624d4c7f9ab1147f71af2576fdb746310509c WHIRLPOOL 7748530169b95765f5d8a07191c8e3f8e165d5d778f6f9da8ea4dc10164501e9be4166eecb534b69153cb11d48354663739effbd324107596f496c5d38c6b632
+DIST libinput-1.2.2.tar.xz 857176 SHA256 08ac5b3620d86df1cdb4970c4137c8746c9f4b9f0c8e7dfab49858dbceb8f367 SHA512 d738890b7fc34a66cdb6ebb58f28060ffc81dccda56aa144622f62efc054431d75564d11f6d9a96a2c17032f15093ca98db9f087822977cec9fced428efd2f8b WHIRLPOOL 66128be8bc6019a6c8986fa4ea05041fa75da38fc60232e3d1b12e0e4e90c2d049b622cf3cae7b4107cacbacf6139804693695928d1055a5203c664888d59547
diff --git a/dev-libs/libinput/libinput-1.2.2.ebuild b/dev-libs/libinput/libinput-1.2.2.ebuild
new file mode 100644
index 00000000000..3107c89aa9c
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}