summaryrefslogtreecommitdiff
path: root/dev-libs/libixion
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-09-24 21:15:26 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-10-02 00:08:34 +0200
commit27dd01e371adb4e689b203def9e1df9a3a72ce57 (patch)
tree34ad467ae213ffc68414d6dd2df7ba93c8465f68 /dev-libs/libixion
parent15f2493ec2fe1fb901f3d95d3e1494a0555d8557 (diff)
downloadgentoo-27dd01e371adb4e689b203def9e1df9a3a72ce57.tar.gz
gentoo-27dd01e371adb4e689b203def9e1df9a3a72ce57.tar.xz
dev-libs/libixion: Version bump to 0.12.1
Adding USE=debug,threads, dropping boost[threads] build dep Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/Manifest1
-rw-r--r--dev-libs/libixion/libixion-0.12.1.ebuild57
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild14
-rw-r--r--dev-libs/libixion/metadata.xml3
4 files changed, 69 insertions, 6 deletions
diff --git a/dev-libs/libixion/Manifest b/dev-libs/libixion/Manifest
index 04eb638b786..d6e85a3f614 100644
--- a/dev-libs/libixion/Manifest
+++ b/dev-libs/libixion/Manifest
@@ -1,3 +1,4 @@
DIST libixion-0.11.1.tar.xz 366660 SHA256 c9e9f52580d618fa969fc0293f55af21a9c74bfb802e655c6bf239202f95bede SHA512 e205a5cf532e0522291f5f2a52c2e2c0cdf8d2ed094e5553943650744359d67adf629229a6ffff3c8fa90b15dde7765fee14d4f147fe51a6cdf79b2855509858 WHIRLPOOL aff1350bd1e3a5fec3f0a0cd3f51a88c873bd28469884b48d3fc316782819465f7d193e019fc753474663326b27680c1d12ce3050e6a082a75073040147dfbd8
+DIST libixion-0.12.1.tar.xz 406300 SHA256 000820ba51109ec21cbdb7ea83c1fdb0acbcfeb55b4a6a80fe02b71d45c587c2 SHA512 b3ba4c09f3f12df7fe9e6ef19d35e618d0effce2cf0866acdb23c72754ac7168c24cc979d6a49c756cf70b1e4a79e58b33ec6a05b8155b43a1682375eea9d022 WHIRLPOOL 14ae7725312894aca74a8df0a7dcfa6e9800526024d35259cfcf7a6e2cae9aa3564dfe9605ce61ce88972d1436f36e71343c2980c17253c12d603974f26e2249
DIST libixion-0.9.0.tar.xz 351388 SHA256 2112b4304667c4c2cdb8f3d331cc4ba696ea581db7d228b5b06ea2559e7531a5 SHA512 da6ca9e79841f1f529328e39a2977d95a261ddaaf4a254bfc46de004d52d4b1e8fc0c8c1cbeb3e8ee18e9a5663b046cf1d3f232f31bdd83db75a766be654f49b WHIRLPOOL f35087fce0a0e53650b988b36ecde8378aa75d2a4b769f6046dce544b9fe89a0025c82a6ab2564b5a12c813e0726875c088d5cc37cfcad055d79d2c5563d53af
DIST libixion-0.9.1.tar.xz 356500 SHA256 77e35c163cd27657b83626a6da26c3b90f37ba9089d00aa25f384a9ac4b4e3a1 SHA512 074318c6db01ec13f6cbdfb8d7d04aede9f20cac4c23476b570a37638b0e68170aabf977520b94dfc2dce079314109c2e70d64376f9f314890d4d60854458c03 WHIRLPOOL ed79f0ed5705f8f8c5a24603fa4386b8822b477a21896d13eaf5fbe52d0f12fbf451f68de49314d8736160f82895047ba4d387431f989683553316d523bb0ce4
diff --git a/dev-libs/libixion/libixion-0.12.1.ebuild b/dev-libs/libixion/libixion-0.12.1.ebuild
new file mode 100644
index 00000000000..20893819f05
--- /dev/null
+++ b/dev-libs/libixion/libixion-0.12.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit eutils python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/ixion/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.12" # based on SONAME of libixion.so
+[[ ${PV} == 9999 ]] || \
+KEYWORDS=""
+#KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="debug python static-libs +threads"
+
+RDEPEND="
+ dev-libs/boost:=
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-1.2.0:1=
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 62cd38058ae..9fd47304f9f 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
-PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+PYTHON_COMPAT=( python3_{4,5} )
[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
inherit eutils python-single-r1 ${GITECLASS}
@@ -17,13 +17,13 @@ HOMEPAGE="https://gitlab.com/ixion/ixion"
[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/ixion/src/${P}.tar.xz"
LICENSE="MIT"
-SLOT="0/0.11" # based on SONAME of libixion.so
+SLOT="0/0.12" # based on SONAME of libixion.so
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="python static-libs"
+IUSE="debug python static-libs +threads"
RDEPEND="
- dev-libs/boost:=[threads]
+ dev-libs/boost:=
python? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}
@@ -37,14 +37,16 @@ pkg_setup() {
}
src_prepare() {
- eapply_user
+ default
[[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {
econf \
+ $(use_enable debug) \
$(use_enable python) \
- $(use_enable static-libs static)
+ $(use_enable static-libs static) \
+ $(use_enable threads)
}
src_install() {
diff --git a/dev-libs/libixion/metadata.xml b/dev-libs/libixion/metadata.xml
index 4fc2ac069dc..07e60cced83 100644
--- a/dev-libs/libixion/metadata.xml
+++ b/dev-libs/libixion/metadata.xml
@@ -5,6 +5,9 @@
<email>office@gentoo.org</email>
<name>Gentoo Office project</name>
</maintainer>
+ <slots>
+ <subslots>libixion soname version</subslots>
+ </slots>
<upstream>
<remote-id type="gitlab">ixion/ixion</remote-id>
</upstream>