summaryrefslogtreecommitdiff
path: root/dev-libs/libixion
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-02-06 16:09:03 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-22 18:05:07 +0100
commit77d879fe444909e960a42c563cae442e72aabca8 (patch)
treeefec78ce8174fa4f3761f348c6ccc3dc92e41235 /dev-libs/libixion
parentd96e5b156822bb9d758e4f19d140fbce999e52f8 (diff)
downloadgentoo-77d879fe444909e960a42c563cae442e72aabca8.tar.gz
gentoo-77d879fe444909e960a42c563cae442e72aabca8.tar.xz
dev-libs/libixion: Fix DEPENDs, subslot, fix USE=-python (bug 550814)
- >=9999: Pin mdds DEPEND to slot 1 - <9999: Pin mdds DEPEND to slot 0 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/files/libixion-0.9.1-python-optional.patch96
-rw-r--r--dev-libs/libixion/files/libixion-0.9.1-python-symbol.patch13
-rw-r--r--dev-libs/libixion/libixion-0.9.0.ebuild2
-rw-r--r--dev-libs/libixion/libixion-0.9.1.ebuild9
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild11
-rw-r--r--dev-libs/libixion/metadata.xml3
6 files changed, 89 insertions, 45 deletions
diff --git a/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch b/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
index a4e7239568a..df945abc392 100644
--- a/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
+++ b/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
@@ -1,34 +1,48 @@
-commit 59c360c9fe438a2805d65decc6c7889bc99a7747
-Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun May 31 10:14:17 2015 +0200
-
- python: Make it optional
-
- python bindings are built unless disabled
-
-diff --git a/configure.ac b/configure.ac
-index 03f6120..1c7d8b2 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -15,7 +15,6 @@ AC_PREREQ([2.63])
+--- a/configure.ac 2016-02-06 17:08:05.505990463 +0100
++++ b/configure.ac 2016-02-06 17:08:42.316530268 +0100
+@@ -15,18 +15,13 @@
AC_INIT([libixion], [ixion_version])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([1.11 foreign dist-bzip2 dist-xz])
-AM_PATH_PYTHON(2.7.0)
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
- AC_ARG_WITH(hash-container-compat,
-@@ -28,6 +27,9 @@ AC_ARG_WITH(mdds-include-path,
- AS_HELP_STRING([--with-mdds-include-path], [specify include path for mdds headers.])
- ,)
-
+-AC_ARG_WITH(hash-container-compat,
+-[
+- --with-hash-container-compat use std::hash_foo instead of boost::unordered_foo
+-],
+-,with_hash_container_compat=no)
+-
+-AC_ARG_WITH(mdds-include-path,
+- AS_HELP_STRING([--with-mdds-include-path], [specify include path for mdds headers.])
+-,)
+AC_ARG_ENABLE([python],
-+ AS_HELP_STRING([--disable-python], [Disable python bindings]))
-+
++ [AS_HELP_STRING([--disable-python], [Disable python bindings])],
++ [enable_python="$enableval"],
++ [enable_python=yes]
++)
+
IXION_API_VERSION=ixion_api_version
IXION_MAJOR_VERSION=ixion_major_version
- IXION_MINOR_VERSION=ixion_minor_version
-@@ -82,7 +84,11 @@ fi
+@@ -66,23 +61,19 @@
+ AC_FUNC_STRTOD
+ AC_CHECK_FUNCS([gettimeofday])
+
+-CPPFLAGS="$CPPFLAGS -D_REENTRANT -DMDDS_HASH_CONTAINER_BOOST"
++CPPFLAGS="$CPPFLAGS -D_REENTRANT"
+
+-AC_MSG_CHECKING([whether to turn on hash container compatibility])
+-if test "z$with_hash_container_compat" = "zno"; then
+- AC_MSG_RESULT([no])
+- BOOST_REQUIRE([1.36])
+- BOOST_UNORDERED
+-else
+- AC_MSG_RESULT([yes])
+- DEFINES="$DEFINES -D_IXION_HASH_CONTAINER_COMPAT"
+-fi
++BOOST_REQUIRE([1.36])
+
+ # Check for mdds.
PKG_CHECK_MODULES([MDDS],[mdds >= 0.12.0])
# Check for python.
@@ -37,20 +51,32 @@ index 03f6120..1c7d8b2 100644
+ AM_PATH_PYTHON(2.7.0)
+ PKG_CHECK_MODULES([PYTHON], [python >= 0.27.1])
+])
-+AM_CONDITIONAL([PYTHON], [test "x$enable_python" != "xno"])
++AM_CONDITIONAL([BUILD_PYTHON], [test "x$enable_python" != "xno"])
CPPFLAGS="$CPPFLAGS -g -Os -fvisibility=hidden"
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 6e138a4..cd912ab 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -1,4 +1,7 @@
--SUBDIRS = libixion python
-+SUBDIRS = libixion
-+if PYTHON
-+ SUBDIRS += python
-+endif
-
- AM_CPPFLAGS = -I$(top_srcdir)/include $(MDDS_CFLAGS)
+@@ -101,3 +92,10 @@
+ src/libixion/constants.inl
+ src/python/Makefile])
+ AC_OUTPUT
++
++AC_MSG_NOTICE([
++==============================================================================
++Build configuration:
++ python: $enable_python
++==============================================================================
++])
+--- a/src/python/Makefile.am 2016-02-06 17:08:12.138907540 +0100
++++ b/src/python/Makefile.am 2016-02-06 17:08:38.034583800 +0100
+@@ -1,3 +1,5 @@
++if BUILD_PYTHON
++
+ pyexec_LTLIBRARIES = ixion.la
+ ixion_la_SOURCES = \
+ document.hpp \
+@@ -16,3 +18,5 @@
+ AM_TESTS_ENVIRONMENT = PYTHONPATH=.libs$${PYTHONPATH:+:$${PYTHONPATH}}; export PYTHONPATH;
+ TESTS = ../../test/ixion-python-test.py
++
++endif
diff --git a/dev-libs/libixion/files/libixion-0.9.1-python-symbol.patch b/dev-libs/libixion/files/libixion-0.9.1-python-symbol.patch
new file mode 100644
index 00000000000..1a62bbc9b55
--- /dev/null
+++ b/dev-libs/libixion/files/libixion-0.9.1-python-symbol.patch
@@ -0,0 +1,13 @@
+diff --git a/src/python/Makefile.am b/src/python/Makefile.am
+index 0dfae54..094e0cf 100644
+--- a/src/python/Makefile.am
++++ b/src/python/Makefile.am
+@@ -10,7 +10,7 @@ ixion_la_SOURCES = \
+ sheet.hpp \
+ sheet.cpp
+
+-ixion_la_LDFLAGS = -module -avoid-version -export-symbols-regex initixion
++ixion_la_LDFLAGS = -module -avoid-version -export-symbols-regex PyInit_ixion
+ ixion_la_CPPFLAGS = -I$(top_srcdir)/include $(PYTHON_CFLAGS) $(MDDS_CFLAGS)
+ ixion_la_LIBADD = \
+ ../libixion/libixion-@IXION_API_VERSION@.la \
diff --git a/dev-libs/libixion/libixion-0.9.0.ebuild b/dev-libs/libixion/libixion-0.9.0.ebuild
index f36ed2573db..59b884225db 100644
--- a/dev-libs/libixion/libixion-0.9.0.ebuild
+++ b/dev-libs/libixion/libixion-0.9.0.ebuild
@@ -27,7 +27,7 @@ RDEPEND="${PYTHON_DEPS}
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}
- >=dev-util/mdds-0.12.0:=
+ >=dev-util/mdds-0.12.0:0=
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/dev-libs/libixion/libixion-0.9.1.ebuild b/dev-libs/libixion/libixion-0.9.1.ebuild
index ff9dd6d029b..9c993be33bd 100644
--- a/dev-libs/libixion/libixion-0.9.1.ebuild
+++ b/dev-libs/libixion/libixion-0.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,7 +27,7 @@ RDEPEND="
python? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}
- >=dev-util/mdds-0.12.0:=
+ >=dev-util/mdds-0.12.0:0=
"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -37,8 +37,9 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${PN}-0.9.1-typo.patch"
- epatch "${FILESDIR}/${PN}-0.9.1-python-optional.patch"
+ epatch "${FILESDIR}/${PN}-0.9.1-typo.patch" \
+ "${FILESDIR}/${PN}-0.9.1-python-optional.patch" \
+ "${FILESDIR}/${PN}-0.9.1-python-symbol.patch"
eautoreconf
}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 676202bf741..0a1ad431363 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
-PYTHON_COMPAT=( python{3_3,3_4} )
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
inherit eutils python-single-r1 ${GITECLASS}
@@ -17,7 +17,7 @@ HOMEPAGE="https://gitlab.com/ixion/ixion"
[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/ixion/src/${P}.tar.xz"
LICENSE="MIT"
-SLOT="0/0.12"
+SLOT="0/0.11" # based on SONAME of libixion.so
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="python static-libs"
@@ -27,7 +27,7 @@ RDEPEND="
python? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}
- >=dev-util/mdds-0.12.0:=
+ dev-util/mdds:1=
"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -37,6 +37,7 @@ pkg_setup() {
}
src_prepare() {
+ eapply_user
[[ ${PV} == 9999 ]] && eautoreconf
}
diff --git a/dev-libs/libixion/metadata.xml b/dev-libs/libixion/metadata.xml
index 13ce236ee51..4fc2ac069dc 100644
--- a/dev-libs/libixion/metadata.xml
+++ b/dev-libs/libixion/metadata.xml
@@ -5,4 +5,7 @@
<email>office@gentoo.org</email>
<name>Gentoo Office project</name>
</maintainer>
+ <upstream>
+ <remote-id type="gitlab">ixion/ixion</remote-id>
+ </upstream>
</pkgmetadata>