summaryrefslogtreecommitdiff
path: root/dev-libs/liblinebreak
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/liblinebreak
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/liblinebreak')
-rw-r--r--dev-libs/liblinebreak/Manifest1
-rw-r--r--dev-libs/liblinebreak/liblinebreak-2.1.ebuild25
-rw-r--r--dev-libs/liblinebreak/metadata.xml15
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/liblinebreak/Manifest b/dev-libs/liblinebreak/Manifest
new file mode 100644
index 00000000000..013528d0eae
--- /dev/null
+++ b/dev-libs/liblinebreak/Manifest
@@ -0,0 +1 @@
+DIST liblinebreak-2.1.tar.gz 390922 SHA256 dd8cba554d260cf686865cc53d0c6be98102a80f56f8152ca5e7307bf06a66b8 SHA512 063cef3bf2d5266387c00a5f5adce883b6ae9c33e153f5cda5475652a45fe5e3a0b609a56ec1093cfe988869cf3164285756e3b7a7428a02ee7184f683c7eb3a WHIRLPOOL aa4bbc517b09c2f0ccb94d19c10b960cffd1d9c35b9df9b58abbd18fed93549500e890132ff0e188c8d378c2257d666aae21337fe87ad9092af567f688ac9b63
diff --git a/dev-libs/liblinebreak/liblinebreak-2.1.ebuild b/dev-libs/liblinebreak/liblinebreak-2.1.ebuild
new file mode 100644
index 00000000000..67851dca198
--- /dev/null
+++ b/dev-libs/liblinebreak/liblinebreak-2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Line breaking library"
+HOMEPAGE="http://vimgadgets.sourceforge.net/liblinebreak/"
+SRC_URI="mirror://sourceforge/vimgadgets/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/liblinebreak/metadata.xml b/dev-libs/liblinebreak/metadata.xml
new file mode 100644
index 00000000000..2baeb469782
--- /dev/null
+++ b/dev-libs/liblinebreak/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Liblinebreak is an implementation of the line breaking algorithm as described
+ in Unicode 5.1.0 Standard Annex 14, Revision 22. It breaks lines that contain
+ Unicode characters. It is designed to be used in a generic text renderer.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">vimgadgets</remote-id>
+ </upstream>
+</pkgmetadata>