summaryrefslogtreecommitdiff
path: root/dev-libs/libmail
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmail')
-rw-r--r--dev-libs/libmail/Manifest1
-rw-r--r--dev-libs/libmail/files/libmail-0.3-respect-cflags.patch37
-rw-r--r--dev-libs/libmail/libmail-0.3-r3.ebuild54
-rw-r--r--dev-libs/libmail/metadata.xml15
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-libs/libmail/Manifest b/dev-libs/libmail/Manifest
new file mode 100644
index 00000000000..c9cf7cad463
--- /dev/null
+++ b/dev-libs/libmail/Manifest
@@ -0,0 +1 @@
+DIST libmail-0.3.tar.bz2 271946 SHA256 b07db69866ae649d0489b35a38a11692b6e404078931ec384973134b3913db51 SHA512 df4e0e549867f7cf73db8c965a28c14e3e089e54a8272b70be8b00c896dcd91d68625e2287a15d353eff75ec05e702e6d113f8122ed0e9d294766fe4f467e9d3 WHIRLPOOL 9ab90bd0545d52ab692f56fd5c222848a00351bf61b588779bb7de3b1c8e43f2102519fd79e44dca438a71ba693007b58651c63280ea900b258a4ce3cbe38627
diff --git a/dev-libs/libmail/files/libmail-0.3-respect-cflags.patch b/dev-libs/libmail/files/libmail-0.3-respect-cflags.patch
new file mode 100644
index 00000000000..7e22de4c757
--- /dev/null
+++ b/dev-libs/libmail/files/libmail-0.3-respect-cflags.patch
@@ -0,0 +1,37 @@
+--- configure.ac.orig 2013-01-31 16:18:06.537834009 +0400
++++ configure.ac 2013-01-31 16:19:00.138835711 +0400
+@@ -12,7 +12,7 @@
+ AC_PROG_MAKE_SET
+ AC_PROG_LIBTOOL
+
+-CFLAGS="-D_GNU_SOURCE -Wall -Wunused -Wstrict-prototypes"
++CFLAGS="-D_GNU_SOURCE -Wall -Wunused -Wstrict-prototypes ${CFLAGS}"
+
+ use_sasl=false
+ use_apop=false
+@@ -99,7 +99,6 @@
+ ;;
+ yes)
+ AC_DEFINE(NDEBUG, [1], [Use debug functionality])
+- CFLAGS="$CFLAGS -g"
+ optimize="no"
+ ;;
+ *)
+@@ -119,7 +118,6 @@
+ ;;
+ yes)
+ AC_DEFINE(NDEBUG, [1], [Use debug functionality])
+- CFLAGS="$CFLAGS -pg -g"
+ optimize="yes"
+ ;;
+ *)
+@@ -127,9 +125,6 @@
+ ;;
+ esac
+ ])
+-if test $optimize = "yes"; then
+- CFLAGS="$CFLAGS -O2"
+-fi
+ AM_CONDITIONAL([LIBMAIL_USE_SASL], [test x$use_sasl = xtrue])
+ AM_CONDITIONAL([LIBMAIL_USE_APOP], [test x$use_apop = xtrue])
+ AM_CONDITIONAL([LIBMAIL_USE_TLS], [test x$use_tls = xtrue])
diff --git a/dev-libs/libmail/libmail-0.3-r3.ebuild b/dev-libs/libmail/libmail-0.3-r3.ebuild
new file mode 100644
index 00000000000..f1de2c6a1c5
--- /dev/null
+++ b/dev-libs/libmail/libmail-0.3-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A mail handling library"
+HOMEPAGE="http://libmail.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="apop debug gnutls profile sasl static-libs"
+
+DEPEND="gnutls? ( >=net-libs/gnutls-2 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+# Do not unset user's CFLAGS, bug #454558
+PATCHES=( "${FILESDIR}/${P}-respect-cflags.patch" )
+
+src_prepare() {
+ # Drop quotes from ACLOCAL_AMFLAGS otherwise aclocal will fail
+ # see 447760
+ sed -i -e "/ACLOCAL_AMFLAGS/s:\"::g" Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable apop)
+ $(use_enable debug)
+ $(use_enable gnutls tls)
+ $(use_enable profile)
+ $(use_enable sasl)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # headers, that are wrongly skipped from installing
+ insinto /usr/include/libmail
+ doins libmail/libmail_intl.h
+ doins config.h
+}
diff --git a/dev-libs/libmail/metadata.xml b/dev-libs/libmail/metadata.xml
new file mode 100644
index 00000000000..74ca61607e2
--- /dev/null
+++ b/dev-libs/libmail/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="apop">Enables the APOP authentication method</flag>
+ </use>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">libmail</remote-id>
+ </upstream>
+</pkgmetadata>