summaryrefslogtreecommitdiff
path: root/dev-libs/libmcrypt
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmcrypt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmcrypt')
-rw-r--r--dev-libs/libmcrypt/Manifest1
-rw-r--r--dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch18
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild32
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r3.ebuild33
-rw-r--r--dev-libs/libmcrypt/metadata.xml12
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-libs/libmcrypt/Manifest b/dev-libs/libmcrypt/Manifest
new file mode 100644
index 00000000000..ce9f657c03b
--- /dev/null
+++ b/dev-libs/libmcrypt/Manifest
@@ -0,0 +1 @@
+DIST libmcrypt-2.5.8.tar.gz 1335178 SHA256 e4eb6c074bbab168ac47b947c195ff8cef9d51a211cdd18ca9c9ef34d27a373e SHA512 471a4e0dcbede836c975697a4edd5c3a53d555dde122a045d702e619d7e9768c7abc1ab541c79829f644b70241ac2e0cd274cf22499e47862983401566ca1fd1 WHIRLPOOL 2fbe22466ecd42161e0de75dfdcdd42edd7f5f1422a2fd9b8bc4bf81f7005749e500058bbb62827f8be34fb707c70fd5920f37b2e27743814d96dd89c03f7deb
diff --git a/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch b/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch
new file mode 100644
index 00000000000..ca31df4b271
--- /dev/null
+++ b/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch
@@ -0,0 +1,18 @@
+--- KNOWN-BUGS 2008-12-13 15:31:49.000000000 -0500
++++ /dev/null 2008-12-13 02:05:21.751517562 -0500
+@@ -1 +0,0 @@
+-- cast-256 and rc6 do not work properly on Alpha (64 bit) machines
+--- lib/mcrypt_modules.h.orig 2008-12-13 15:33:06.000000000 -0500
++++ lib/mcrypt_modules.h 2008-12-13 15:25:01.000000000 -0500
+@@ -1,7 +1,7 @@
+-#define rotl32(x,n) (((x) << ((word32)(n))) | ((x) >> (32 - (word32)(n))))
+-#define rotr32(x,n) (((x) >> ((word32)(n))) | ((x) << (32 - (word32)(n))))
+-#define rotl16(x,n) (((x) << ((word16)(n))) | ((x) >> (16 - (word16)(n))))
+-#define rotr16(x,n) (((x) >> ((word16)(n))) | ((x) << (16 - (word16)(n))))
++#define rotl32(x,n) (((x) << ((word32)(n & 31))) | ((x) >> (32 - (word32)(n & 31))))
++#define rotr32(x,n) (((x) >> ((word32)(n & 31))) | ((x) << (32 - (word32)(n & 31))))
++#define rotl16(x,n) (((x) << ((word16)(n & 15))) | ((x) >> (16 - (word16)(n & 15))))
++#define rotr16(x,n) (((x) >> ((word16)(n & 15))) | ((x) << (16 - (word16)(n & 15))))
+
+ /* Use hardware rotations.. when available */
+ #ifdef swap32
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild
new file mode 100644
index 00000000000..9c05f5cce79
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms"
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-rotate-mask.patch
+ eautoreconf # need new libtool for interix (elibtoolize would suffice for freebsd)
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failure"
+
+ dodoc AUTHORS NEWS README THANKS TODO ChangeLog
+ dodoc doc/README.* doc/example.c
+ prepalldocs
+}
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r3.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r3.ebuild
new file mode 100644
index 00000000000..c683e2e486e
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms"
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-rotate-mask.patch
+ mv configure.in configure.ac
+ mv libltdl/configure.in libltdl/configure.ac
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac libltdl/configure.ac || die
+ eautoreconf # need new libtool for interix (elibtoolize would suffice for freebsd)
+}
+
+src_install() {
+ default
+ dodoc AUTHORS NEWS README THANKS TODO ChangeLog
+ dodoc doc/README.* doc/example.c
+}
diff --git a/dev-libs/libmcrypt/metadata.xml b/dev-libs/libmcrypt/metadata.xml
new file mode 100644
index 00000000000..0549001de3c
--- /dev/null
+++ b/dev-libs/libmcrypt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">mcrypt</remote-id>
+ </upstream>
+</pkgmetadata>