summaryrefslogtreecommitdiff
path: root/dev-libs/libmemcache
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmemcache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmemcache')
-rw-r--r--dev-libs/libmemcache/Manifest1
-rw-r--r--dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-implicit_pointer.patch12
-rw-r--r--dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-inline.patch33
-rw-r--r--dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-ppc_ftbfs.patch40
-rw-r--r--dev-libs/libmemcache/libmemcache-1.4.0_rc2-r1.ebuild41
-rw-r--r--dev-libs/libmemcache/metadata.xml10
6 files changed, 137 insertions, 0 deletions
diff --git a/dev-libs/libmemcache/Manifest b/dev-libs/libmemcache/Manifest
new file mode 100644
index 00000000000..fca3c49ac26
--- /dev/null
+++ b/dev-libs/libmemcache/Manifest
@@ -0,0 +1 @@
+DIST libmemcache-1.4.0.rc2.tar.bz2 301136 SHA256 f496d41092c697384a7180720689da6a85d7c6ea2283eca69c8aaff2b58bebbf SHA512 4b8c09c425d48d0ad040d3f01ec3c0d88babefb702b666d5cb3d10eac9993be88d00120b57b6224f7d55ae979d3136de10d5ddc793d9aa7f8b9531b5d79449d0 WHIRLPOOL 89cf5df9b87193ce25b3c76086e59c9879fadb6ba9343e6a97a3982fd50976e4ec69668360ceaf5183e73470a4c3841c19eaa65a38a69a472f15dccc9404b540
diff --git a/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-implicit_pointer.patch b/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-implicit_pointer.patch
new file mode 100644
index 00000000000..e944ce1725a
--- /dev/null
+++ b/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-implicit_pointer.patch
@@ -0,0 +1,12 @@
+Index: libmemcache-1.4.0.rc2/test/benchmark/benchmark.c
+===================================================================
+--- libmemcache-1.4.0.rc2.orig/test/benchmark/benchmark.c
++++ libmemcache-1.4.0.rc2/test/benchmark/benchmark.c
+@@ -29,6 +29,7 @@
+
+ #include "memcache.h"
+
++char *strdup(const char *s1);
+ double tt(const struct timeval *t1, const struct timeval *t2);
+
+ double
diff --git a/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-inline.patch b/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-inline.patch
new file mode 100644
index 00000000000..6eba5dffd13
--- /dev/null
+++ b/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-inline.patch
@@ -0,0 +1,33 @@
+http://bugs.gentoo.org/276571
+
+--- include/memcache.h.in
++++ include/memcache.h.in
+@@ -923,7 +923,7 @@ int mcMemGet(mcFreeFunc *freeFunc, mcMallocFunc *mallocFunc,
+ mcMallocFunc *mallocAtomicFunc, mcReallocFunc *reallocFunc);
+
+ /* Returns a pointer to the global context. */
+-inline struct memcache_ctxt *mc_global_ctxt(void);
++struct memcache_ctxt *mc_global_ctxt(void);
+
+ /* The next two functions are used to setup an error handler. */
+ int mcErrSetup(mcErrFunc errFunc);
+--- include/memcache/buffer.h
++++ include/memcache/buffer.h
+@@ -63,14 +63,14 @@ struct memcache_buf *mcm_buf_find_replace(struct memcache_ctxt *, struct memcach
+ struct memcache_buf *mcm_buf_find_replace2(struct memcache_ctxt *, struct memcache_buf *,
+ const char *, struct memcache_buf *);
+ int mcm_buf_free(struct memcache_ctxt *, struct memcache_buf **);
+-inline u_int32_t mcm_buf_len(const struct memcache_ctxt *, const struct memcache_buf *);
++u_int32_t mcm_buf_len(const struct memcache_ctxt *, const struct memcache_buf *);
+ struct memcache_buf *mcm_buf_new(struct memcache_ctxt *);
+ struct memcache_buf *mcm_buf_new2(struct memcache_ctxt *, const char *, const u_int32_t);
+ struct memcache_buf *mcm_buf_new3(struct memcache_ctxt *, const char *);
+ size_t mcm_buf_read(struct memcache_ctxt *, struct memcache_buf *, int);
+ int mcm_buf_realloc(struct memcache_ctxt *, struct memcache_buf *, const u_int32_t);
+-inline size_t mcm_buf_remain(const struct memcache_ctxt *, const struct memcache_buf *);
+-inline size_t mcm_buf_remain_off(const struct memcache_ctxt *, const struct memcache_buf *);
++size_t mcm_buf_remain(const struct memcache_ctxt *, const struct memcache_buf *);
++size_t mcm_buf_remain_off(const struct memcache_ctxt *, const struct memcache_buf *);
+ int mcm_buf_replace(struct memcache_ctxt *, struct memcache_buf *, const char *, const u_int32_t);
+ int mcm_buf_replace2(struct memcache_ctxt *, struct memcache_buf *, const char *);
+ int mcm_buf_replace_buf(struct memcache_ctxt *, struct memcache_buf *, struct memcache_buf *);
diff --git a/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-ppc_ftbfs.patch b/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-ppc_ftbfs.patch
new file mode 100644
index 00000000000..dbeee57b1c6
--- /dev/null
+++ b/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-ppc_ftbfs.patch
@@ -0,0 +1,40 @@
+Debian patch: 10_ftbfs_fix_powerpc.patch
+Fixing build on PowerPC
+https://bugs.gentoo.org/show_bug.cgi?id=365303
+
+--- a/include/memcache.h.in
++++ b/include/memcache.h.in
+@@ -61,6 +61,11 @@
+ #ifndef MEMCACHE_H
+ #define MEMCACHE_H
+
++/* fix FTBFS on powerpc for Debian libmemcache */
++#ifndef __USE_POSIX
++#define __USE_POSIX
++#endif
++
+ #include <netdb.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+--- a/src/memcache.c
++++ b/src/memcache.c
+@@ -39,12 +39,17 @@
+ #include <sysexits.h>
+ #include <errno.h>
+ #include <sys/types.h>
+-#ifdef __linux
++
++/* fix FTBFS on powerpc for Debian libmemcache. I personally think this
++ * shouldnt be the case, as Debian Bug#345587 seems to show. */
++
++/* #ifdef __linux */
+ # ifndef __USE_POSIX
+ # define __USE_POSIX
+ #warning "Working around busted-ass Linux header include problems: use FreeBSD instead"
+ #warning "http://www.FreeBSD.org/ - you won't regret it"
+-# endif
++/* #endif */
++
+ #endif
+ #include <sys/time.h>
+ #include <sys/socket.h>
diff --git a/dev-libs/libmemcache/libmemcache-1.4.0_rc2-r1.ebuild b/dev-libs/libmemcache/libmemcache-1.4.0_rc2-r1.ebuild
new file mode 100644
index 00000000000..b76057467e2
--- /dev/null
+++ b/dev-libs/libmemcache/libmemcache-1.4.0_rc2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit autotools eutils toolchain-funcs
+
+MY_P=${PN}-${PV/_/.}
+
+DESCRIPTION="C API for memcached"
+HOMEPAGE="http://people.freebsd.org/~seanc/libmemcache/"
+SRC_URI="http://people.freebsd.org/~seanc/libmemcache/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~sparc-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-inline.patch
+ epatch "${FILESDIR}"/${P}-implicit_pointer.patch
+ [[ $(tc-arch) == ppc* ]] && epatch "${FILESDIR}"/${P}-ppc_ftbfs.patch
+
+ rm -rf test/unit || die
+ sed -i -e '/DIR/s,unit,,g' test/Makefile.am || die
+ sed -i \
+ -e 's,test/unit/Makefile,,g' \
+ -e '/^CFLAGS=.*Wall.*pipe/s,-Wall,${CFLAGS} -Wall,g' \
+ -e '/^OPTIMIZE=/d' \
+ -e '/^PROFILE=/d' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
diff --git a/dev-libs/libmemcache/metadata.xml b/dev-libs/libmemcache/metadata.xml
new file mode 100644
index 00000000000..dbee0aa46b5
--- /dev/null
+++ b/dev-libs/libmemcache/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>