summaryrefslogtreecommitdiff
path: root/dev-libs/libmoe
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmoe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmoe')
-rw-r--r--dev-libs/libmoe/Manifest1
-rw-r--r--dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch9
-rw-r--r--dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch23
-rw-r--r--dev-libs/libmoe/libmoe-1.5.8-r2.ebuild41
-rw-r--r--dev-libs/libmoe/metadata.xml5
5 files changed, 79 insertions, 0 deletions
diff --git a/dev-libs/libmoe/Manifest b/dev-libs/libmoe/Manifest
new file mode 100644
index 00000000000..0a825f17178
--- /dev/null
+++ b/dev-libs/libmoe/Manifest
@@ -0,0 +1 @@
+DIST libmoe-1.5.8.tar.gz 1559398 SHA256 6a379a7bbd234783a323b85ba8782360391942530290805e37e02e02e656eeb7 SHA512 937e7e0f1d562c5ea1f93ec755d6125f389cffaa2989b4ec4c1c1b42fab927f1884e1dab2c65e1487f4d9fdb0f9ed306a7d32e13e8b24302837a9e7b5634449b WHIRLPOOL 2e514ff03dccc0528b3dd8877dde68397143e49ca83fa3b56a80992482ee1750e044a5c6170819dc3a2547b081822f5c3c78d00ba251964434d92c17b006910f
diff --git a/dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch b/dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch
new file mode 100644
index 00000000000..cf436c11577
--- /dev/null
+++ b/dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch
@@ -0,0 +1,9 @@
+diff -Naur libmoe-1.5.8.orig/altmalloc.c libmoe-1.5.8/altmalloc.c
+--- libmoe-1.5.8.orig/altmalloc.c 2002-02-01 22:25:10.000000000 +0900
++++ libmoe-1.5.8/altmalloc.c 2008-11-19 08:44:34.000000000 +0900
+@@ -1,3 +1,5 @@
++#include <string.h>
++
+ #include "altmalloc.h"
+
+ alt_allocater_t alt_malloc = malloc;
diff --git a/dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch b/dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch
new file mode 100644
index 00000000000..2cdfa1a24c2
--- /dev/null
+++ b/dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index 1bae380..605d674 100644
+--- a/Makefile
++++ b/Makefile
+@@ -72,8 +72,7 @@ AR=ar
+ all: ${INSTLIBA} mbconv mbconv.man
+
+ mbconv: mbconv.c ${ALL}
+- ${CC} ${CF} -o $@ $< -L. -lmoe
+-
++ ${CC} ${CF} ${LDFLAGS} -o $@ $< -L. -lmoe
+
+ ${DEST}.so: ${DEST}.so.${VER}.${RELEASE}
+ ln -sf $< $@
+@@ -116,7 +115,7 @@ ${BTRI_Cs}: %.c: %.mk_btri.c mk_btri
+ ./mk_btri <$< >$@-new && mv $@-new $@
+
+ mk_btri: btri.c btri.h altmalloc.o
+- ${CC} ${CF} -DMAIN -o $@ $< altmalloc.o
++ ${CC} ${CF} ${LDFLAGS} -DMAIN -o $@ $< altmalloc.o
+
+ mbconv.man: mbconv.pod
+ pod2man --section=${MANSECT} --center=' ' $< >$@
diff --git a/dev-libs/libmoe/libmoe-1.5.8-r2.ebuild b/dev-libs/libmoe/libmoe-1.5.8-r2.ebuild
new file mode 100644
index 00000000000..35ccd9f8476
--- /dev/null
+++ b/dev-libs/libmoe/libmoe-1.5.8-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="multi octet character encoding handling library"
+HOMEPAGE="http://pub.ks-and-ks.ne.jp/prog/libmoe/"
+SRC_URI="http://pub.ks-and-ks.ne.jp/prog/pub/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+
+ sed -i \
+ -e "/^PREFIX=/s:=.*:=/usr:" \
+ -e "/^LIBSODIR=/s:=.*:=/usr/$(get_libdir):" \
+ -e "/^MANDIR=/s:=.*:=/usr/share/man:" \
+ -e "/^CF=/s:=:=${CFLAGS} :" \
+ -e "/^LF=/s:=:=${LDFLAGS} :" \
+ -e "s:=gcc:=$(tc-getCC):" \
+ -e "/^AR=/s:=ar:=$(tc-getAR):" \
+ Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog
+ dohtml libmoe.shtml
+}
diff --git a/dev-libs/libmoe/metadata.xml b/dev-libs/libmoe/metadata.xml
new file mode 100644
index 00000000000..2d5852c16c6
--- /dev/null
+++ b/dev-libs/libmoe/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>