summaryrefslogtreecommitdiff
path: root/dev-libs/libmongo-client
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmongo-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmongo-client')
-rw-r--r--dev-libs/libmongo-client/Manifest1
-rw-r--r--dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild39
-rw-r--r--dev-libs/libmongo-client/metadata.xml18
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/libmongo-client/Manifest b/dev-libs/libmongo-client/Manifest
new file mode 100644
index 00000000000..9d0cf59618f
--- /dev/null
+++ b/dev-libs/libmongo-client/Manifest
@@ -0,0 +1 @@
+DIST libmongo-client-0.1.7.tar.gz 122495 SHA256 820d98d1ee06070aa51861d1583dd5b3556b6dbca6fecdc1c91eb3c18360d2d9 SHA512 c8250ee04c01650b624641d8c3e0cb81e17bdc12d1d64ccb173c15db58d39953fec39dcf5b92ec91378b93574319ab47bb523d1c50594cbc89479c65d219b5ee WHIRLPOOL 8a7096b9ba6a43013307ea946edab483bf904794e3d61ab6dc4be4669cc284acabdc8d7bfe0bd5e6d4f3087123bbff9ddb787b90df54003febc1adf102f001bb
diff --git a/dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild b/dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild
new file mode 100644
index 00000000000..50f99d11983
--- /dev/null
+++ b/dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="The alternative C driver for MongoDB"
+HOMEPAGE="https://github.com/algernon/libmongo-client"
+SRC_URI="https://github.com/algernon/${PN}/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa x86"
+IUSE="doc"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+RDEPEND="
+ dev-libs/glib"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_compile() {
+ default
+ use doc && emake DESTDIR="${D}" doxygen
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+ use doc && dohtml -r docs/html/*
+}
diff --git a/dev-libs/libmongo-client/metadata.xml b/dev-libs/libmongo-client/metadata.xml
new file mode 100644
index 00000000000..fd87687030d
--- /dev/null
+++ b/dev-libs/libmongo-client/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vadimk@gentoo.org</email>
+ <name>Vadim Kuznetsov</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is an alternative C driver for MongoDB, with slightly different
+ goals than the official one:
+ libmongo-client is meant to be a stable (API, ABI and quality alike),
+ clean, well documented and well tested shared library, that strives
+ to make the most common use cases as convenient as possible.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">algernon/libmongo-client</remote-id>
+ </upstream>
+</pkgmetadata>