summaryrefslogtreecommitdiff
path: root/dev-libs/liboop
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/liboop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/liboop')
-rw-r--r--dev-libs/liboop/Manifest1
-rw-r--r--dev-libs/liboop/liboop-1.0-r1.ebuild42
-rw-r--r--dev-libs/liboop/metadata.xml7
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/liboop/Manifest b/dev-libs/liboop/Manifest
new file mode 100644
index 00000000000..32028114c5d
--- /dev/null
+++ b/dev-libs/liboop/Manifest
@@ -0,0 +1 @@
+DIST liboop-1.0.tar.bz2 215477 SHA256 4a973d28466fde0b689099192f9bcd081b129d90b3c5a9815e5ade73052cf8d2 SHA512 157385e61af7a5fb055d775f773dc0c455703f86dd3a100b56421b231e8bd78ab9af4712fcfcd07e9344ac2ac4f3cde28e0d966be72061b3b7d50b456ff7818f WHIRLPOOL 791ea83a2e4654c567df768655868563816c57712904ebea054ebd0dc0274e56c5fef3be60b2d3d700691a83b5d18870386502a143d0a15017b3de07d58f19b2
diff --git a/dev-libs/liboop/liboop-1.0-r1.ebuild b/dev-libs/liboop/liboop-1.0-r1.ebuild
new file mode 100644
index 00000000000..d3b4562f9cb
--- /dev/null
+++ b/dev-libs/liboop/liboop-1.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="low-level event loop management library for POSIX-based operating systems"
+HOMEPAGE="http://liboop.ofb.net/"
+SRC_URI="http://download.ofb.net/liboop/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="adns gnome tcl readline"
+
+DEPEND="
+ adns? ( net-libs/adns )
+ gnome? ( dev-libs/glib:2 )
+ tcl? ( dev-lang/tcl:0 )
+ readline? ( sys-libs/readline:0 )"
+
+src_configure() {
+ export ac_cv_path_PROG_LDCONFIG=true
+ econf \
+ $(use_with adns) \
+ $(use_with gnome) \
+ $(use_with tcl tcltk) \
+ $(use_with readline) \
+ --without-libwww \
+ --disable-static
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/liboop/metadata.xml b/dev-libs/liboop/metadata.xml
new file mode 100644
index 00000000000..d9cd2cad66c
--- /dev/null
+++ b/dev-libs/liboop/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>