summaryrefslogtreecommitdiff
path: root/dev-libs/liborcus
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-12 16:01:26 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-19 22:39:38 +0100
commita9723ce508d573dfb047772e2084e5750e5d2d08 (patch)
tree54e02ac16252ab982213bbb8052fbdd182ec7899 /dev-libs/liborcus
parentc87e4c65b4aaddf0a375013589babdb741f5f389 (diff)
downloadgentoo-a9723ce508d573dfb047772e2084e5750e5d2d08.tar.gz
gentoo-a9723ce508d573dfb047772e2084e5750e5d2d08.tar.xz
dev-libs/liborcus: 0.11.1 version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-libs/liborcus')
-rw-r--r--dev-libs/liborcus/Manifest1
-rw-r--r--dev-libs/liborcus/liborcus-0.11.1.ebuild60
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild2
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-libs/liborcus/Manifest b/dev-libs/liborcus/Manifest
index f7f519be4ac..1936012d11a 100644
--- a/dev-libs/liborcus/Manifest
+++ b/dev-libs/liborcus/Manifest
@@ -1,3 +1,4 @@
+DIST liborcus-0.11.1.tar.xz 1627332 SHA256 02a6251a9b732c2c555c1be083411a2d0383dfd2ebc79f60ac282875b1ada49b SHA512 2a818a8888115281ea9c34d8911df99a2af131991b43de77ddf1182592becc9f77ca0df23aac5f2f92e1bcd732a0f704d15b98c66b308eaa1715f66d78a8ab76 WHIRLPOOL 67c616d3509ec18994dae6e4b718014adc3dd385aa9fa4ed5bf8b099c659f1390b15a7d6307b2a409f66abd2a5041942ee5e17e3cb7843fad49129575a829951
DIST liborcus-0.7.0.tar.bz2 1665988 SHA256 7773a8f5f0b810e0f146dbcf3dbb42e89dd8af0868235e01d9f0cdefde41a8a9 SHA512 63aad5154e25d7d7bfd10f07e614e4c1ed2691a31c61c2b1e7ec029fa4d9168eba5b4303f5164ab29ef92843ce8f8afa9682772515c8b5e8ae65f4561b331db8 WHIRLPOOL b555b005b41fb41571ac7dbc63e32541decd0b79d61435a6730de9438761afe363d063905b671e1b724c02f2846e65e2af7fffca40282d08d35e1c4ff787fc63
DIST liborcus-0.7.1.tar.xz 1472804 SHA256 04846b64262210a0d4e18d72779c901633e45dc9cca2108235b38d4715266a43 SHA512 30461311b084f3c91ef8cc504ca7adfd212f95d49c0a320958ca203606901ddf84e37d5c95073437bad21af4c6ce71fa606dd7cdb7cc7bd58b2699d8863a318c WHIRLPOOL af6f4ff639851b94298f847437c25962412f37617f82c143b1bf71aa4f27b26003ffb2dad61fdbe9718f9b42a0f11c1dda71825da8b2ee8bf9e9fd727f309134
DIST liborcus-0.9.2.tar.xz 1558072 SHA256 dd49f9f1b8ff8a648434dd5c8b4fe1081d1118d61d0a71d4effee8f32553199c SHA512 1dd847012cf78df962c28408e0b56412a89e1d978d532a17fa92352f6788bbc1a0fe806c2d886ff148a8ee2db54620ce039b1809f347a976dca0078f248fd8ea WHIRLPOOL fe74951704b4cfbdfeeb894be459c4f7046fc23f813c50e43816943d064cbfc4a4f7feebf6a6737cf94d50826ac23796031b7626b89264ee21f42356ffbb44e8
diff --git a/dev-libs/liborcus/liborcus-0.11.1.ebuild b/dev-libs/liborcus/liborcus-0.11.1.ebuild
new file mode 100644
index 00000000000..baf9cf6ad06
--- /dev/null
+++ b/dev-libs/liborcus/liborcus-0.11.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit eutils python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="Standalone file import filter library for spreadsheet documents"
+HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/orcus/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.11" # based on SONAME of liborcus.so
+[[ ${PV} == 9999 ]] || \
+KEYWORDS=""
+# KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="python +spreadsheet-model static-libs tools"
+
+RDEPEND="
+ >=dev-libs/boost-1.51.0:=
+ sys-libs/zlib:=
+ python? ( ${PYTHON_DEPS} )
+ spreadsheet-model? ( >=dev-libs/libixion-0.11.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/mdds:1
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable python) \
+ $(use_enable spreadsheet-model) \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index 64a4c246dcd..27045e0caff 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -26,7 +26,7 @@ RDEPEND="
>=dev-libs/boost-1.51.0:=
sys-libs/zlib:=
python? ( ${PYTHON_DEPS} )
- spreadsheet-model? ( =dev-libs/libixion-9999:= )
+ spreadsheet-model? ( >=dev-libs/libixion-0.11:= )
"
DEPEND="${RDEPEND}
dev-util/mdds:1