summaryrefslogtreecommitdiff
path: root/dev-libs/librelp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/librelp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/librelp')
-rw-r--r--dev-libs/librelp/Manifest1
-rw-r--r--dev-libs/librelp/files/librelp-1.2.7-prevent-segfault-with-keepalive.patch32
-rw-r--r--dev-libs/librelp/librelp-1.2.7-r1.ebuild44
-rw-r--r--dev-libs/librelp/metadata.xml8
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-libs/librelp/Manifest b/dev-libs/librelp/Manifest
new file mode 100644
index 00000000000..64c28ef1446
--- /dev/null
+++ b/dev-libs/librelp/Manifest
@@ -0,0 +1 @@
+DIST librelp-1.2.7.tar.gz 410896 SHA256 3a434a1c71772706104cfb1c93ba8e6809d257851d60de29ac2142c60c68d7d1 SHA512 f8a71ad037cb5eaeb807b1bcb942893e2d10bcd57b18764bb13700c8e114d59de37b1b36560288abac18a07b6cb2920b46feaef4ae629aa0b3478ed16723542a WHIRLPOOL 784f291d0318b29be33bcd4bdd41e04c2e0fc8f292c6cb7f5985743559aa65f3c10932680f943e065ebf34e3f62c75bf2ed5500aebe0b7ab2fa7e64ced37cc44
diff --git a/dev-libs/librelp/files/librelp-1.2.7-prevent-segfault-with-keepalive.patch b/dev-libs/librelp/files/librelp-1.2.7-prevent-segfault-with-keepalive.patch
new file mode 100644
index 00000000000..2f9803d0d8a
--- /dev/null
+++ b/dev-libs/librelp/files/librelp-1.2.7-prevent-segfault-with-keepalive.patch
@@ -0,0 +1,32 @@
+From 0ca7f807958e8365b2fd2f3fd833814c83594bdc Mon Sep 17 00:00:00 2001
+From: Tomas Heinrich <theinric@redhat.com>
+Date: Sun, 1 Jun 2014 16:44:59 +0200
+Subject: [PATCH] Reorder code, prevent access of uninitialized data
+
+---
+ src/tcp.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/tcp.c b/src/tcp.c
+index 1e0fd11..e21db51 100644
+--- a/src/tcp.c
++++ b/src/tcp.c
+@@ -713,12 +713,12 @@ relpTcpAcceptConnReq(relpTcp_t **ppThis, int sock, relpSrv_t *pSrv)
+ ABORT_FINALIZE(RELP_RET_ACCEPT_ERR);
+ }
+
+- if(pSrv->bKeepAlive)
+- EnableKeepAlive(pThis, pSrv, iNewSock);
+-
+ /* construct our object so that we can use it... */
+ CHKRet(relpTcpConstruct(&pThis, pEngine, RELP_SRV_CONN, pSrv));
+
++ if(pSrv->bKeepAlive)
++ EnableKeepAlive(pThis, pSrv, iNewSock);
++
+ /* TODO: obtain hostname, normalize (callback?), save it */
+ CHKRet(relpTcpSetRemHost(pThis, (struct sockaddr*) &addr));
+ pThis->pEngine->dbgprint("remote host is '%s', ip '%s'\n", pThis->pRemHostName, pThis->pRemHostIP);
+--
+1.9.3
+
diff --git a/dev-libs/librelp/librelp-1.2.7-r1.ebuild b/dev-libs/librelp/librelp-1.2.7-r1.ebuild
new file mode 100644
index 00000000000..d723733143a
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.2.7-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="An easy to use library for the RELP protocol"
+HOMEPAGE="http://www.librelp.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 doc? ( FDL-1.3 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~sparc x86"
+IUSE="debug doc +ssl static-libs"
+
+RDEPEND="
+ ssl? ( >=net-libs/gnutls-2.12.23-r1 )
+"
+
+DEPEND="
+ >=net-libs/gnutls-2.12.23-r1
+ virtual/pkgconfig
+"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}/${P}-prevent-segfault-with-keepalive.patch" )
+
+src_configure() {
+ # gnutls-headers are always required (in src/tcp.h) despite the flag, bug #513754
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable ssl tls)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/relp.html )
+ autotools-utils_src_install
+}
diff --git a/dev-libs/librelp/metadata.xml b/dev-libs/librelp/metadata.xml
new file mode 100644
index 00000000000..31c8b99f54a
--- /dev/null
+++ b/dev-libs/librelp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+</maintainer>
+</pkgmetadata>