summaryrefslogtreecommitdiff
path: root/dev-libs/libxml2
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-29 12:58:28 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-29 12:58:44 +0100
commitbe2fe913ffa1d4acfeeba02f88adfb3d06481095 (patch)
tree5d23ee183da87716d3a33d199d3bb3f7368dc877 /dev-libs/libxml2
parent2a044810afc6f961afcd3a88bc426c7f80c97ef8 (diff)
downloadgentoo-be2fe913ffa1d4acfeeba02f88adfb3d06481095.tar.gz
gentoo-be2fe913ffa1d4acfeeba02f88adfb3d06481095.tar.xz
dev-libs/libxml2: Fix python ABI detection
Gentoo recently moved closer to upstream in terms of naming python with regards to the build ABI. This patch adopts the buildsystem to this change Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=567066 Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/files/libxml2-2.9.2-python-ABIFLAG.patch16
-rw-r--r--dev-libs/libxml2/libxml2-2.9.2-r4.ebuild2
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-libs/libxml2/files/libxml2-2.9.2-python-ABIFLAG.patch b/dev-libs/libxml2/files/libxml2-2.9.2-python-ABIFLAG.patch
new file mode 100644
index 00000000000..14dd5bc7342
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.9.2-python-ABIFLAG.patch
@@ -0,0 +1,16 @@
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 14ac0a8..f787b12 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -844,7 +844,7 @@ if test "$with_python" != "no" ; then
+ fi
+ if test "$PYTHON" != ""
+ then
+- PYTHON_VERSION=`$PYTHON -c "from distutils import sysconfig; print(sysconfig.get_python_version())"`
++ PYTHON_VERSION=`$PYTHON -c "import sysconfig; print(sysconfig.get_config_var('LDVERSION') or sysconfig.get_config_var('py_version_short'))"`
+ PYTHON_INCLUDES=`$PYTHON -c "from distutils import sysconfig; print(sysconfig.get_python_inc())"`
+ # does not work as it produce a /usr/lib/python path instead of/usr/lib64/python
+ #
diff --git a/dev-libs/libxml2/libxml2-2.9.2-r4.ebuild b/dev-libs/libxml2/libxml2-2.9.2-r4.ebuild
index d1f80f04f4c..421a205b90f 100644
--- a/dev-libs/libxml2/libxml2-2.9.2-r4.ebuild
+++ b/dev-libs/libxml2/libxml2-2.9.2-r4.ebuild
@@ -90,6 +90,8 @@ src_prepare() {
# https://bugs.gentoo.org/show_bug.cgi?id=738751
epatch "${FILESDIR}"/${PN}-2.9.2-icu-pkgconfig.patch
+ epatch "${FILESDIR}"/${P}-python-ABIFLAG.patch
+
# Important patches from master
epatch \
"${FILESDIR}"/${PN}-2.9.2-revert-missing-initialization.patch \