summaryrefslogtreecommitdiff
path: root/dev-libs/libyaml
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libyaml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libyaml')
-rw-r--r--dev-libs/libyaml/Manifest1
-rw-r--r--dev-libs/libyaml/libyaml-0.1.6.ebuild40
-rw-r--r--dev-libs/libyaml/metadata.xml12
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libyaml/Manifest b/dev-libs/libyaml/Manifest
new file mode 100644
index 00000000000..18724ada0a4
--- /dev/null
+++ b/dev-libs/libyaml/Manifest
@@ -0,0 +1 @@
+DIST yaml-0.1.6.tar.gz 503012 SHA256 7da6971b4bd08a986dd2a61353bc422362bd0edcc67d7ebaac68c95f74182749 SHA512 eef1f26fec0a305836b8c6a65def4e2864fe2415618e7490717d4e42f0fc51048727ab0e7e4a6c3a2783ae762fddd6b78091a76a6cd3a2710ae18e3dfb27cd44 WHIRLPOOL b3dc733ae79c2798ad80390fee90648ab65b32b9550d6b3d336138e3d664ee6fa50f71594747e49c7e0b9b72600cb4dd22aaac62970bbf50ae343be4a8c956ca
diff --git a/dev-libs/libyaml/libyaml-0.1.6.ebuild b/dev-libs/libyaml/libyaml-0.1.6.ebuild
new file mode 100644
index 00000000000..8be20ac08bd
--- /dev/null
+++ b/dev-libs/libyaml/libyaml-0.1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils eutils libtool
+
+MY_P="${P/lib}"
+
+DESCRIPTION="YAML 1.1 parser and emitter written in C"
+HOMEPAGE="http://pyyaml.org/wiki/LibYAML"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test static-libs"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="README"
+
+src_prepare() {
+ # conditionally remove tests
+ if ! use test; then
+ sed -i -e 's: tests::g' Makefile* || die
+ fi
+ elibtoolize # for FreeMiNT
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml -r doc/html/.
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/example-*.c
+ fi
+}
diff --git a/dev-libs/libyaml/metadata.xml b/dev-libs/libyaml/metadata.xml
new file mode 100644
index 00000000000..4e98176ca8f
--- /dev/null
+++ b/dev-libs/libyaml/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <longdescription lang="en">
+ LibYAML is a YAML 1.1 parser and emitter written in C.
+ It's in an early stage of development.
+ </longdescription>
+</pkgmetadata>