summaryrefslogtreecommitdiff
path: root/dev-libs/log4shib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/log4shib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/log4shib')
-rw-r--r--dev-libs/log4shib/Manifest2
-rw-r--r--dev-libs/log4shib/files/log4shib-doc.patch11
-rw-r--r--dev-libs/log4shib/log4shib-1.0.1.ebuild36
-rw-r--r--dev-libs/log4shib/log4shib-1.0.4.ebuild29
-rw-r--r--dev-libs/log4shib/metadata.xml11
5 files changed, 89 insertions, 0 deletions
diff --git a/dev-libs/log4shib/Manifest b/dev-libs/log4shib/Manifest
new file mode 100644
index 00000000000..ba11b89db0c
--- /dev/null
+++ b/dev-libs/log4shib/Manifest
@@ -0,0 +1,2 @@
+DIST log4shib-1.0.1.tar.gz 498381 SHA256 5d8c647c0acea60fed58c1335ec4008f300f63b40c1651745f49e4080498f938 SHA512 ed64dca5f20c8135944abdfe7e7b66702cd1ae712ba362508759194c8f53c2a9a878142619a4befd3c4180de366fd2c9a6af7af1873b170d45e91b8bf527b836 WHIRLPOOL 676e6a4c21edbf3e265f63f7cb77f122f6fee03e2c88a3d0f939329ec419d1b69626b840cd1f197f8cc22f07038a2668c5d5ecd07cad2c4d29e596a69c3393b0
+DIST log4shib-1.0.4.tar.gz 487529 SHA256 4e5f9e58f14f2498d8be15dc0a6223e83f0510a924494295329b20745cacbc38 SHA512 af31bb436393e1a6a2674c0f4804148dea4f4081bb07b78f158f4109157bef4ed40647a3e4da7ec5eef0ed38b6286aee6d8b8a3320572c2b55df2998850d5245 WHIRLPOOL 70795e38f1a963f6f6fa76d021b7a465fc8067d7e3a73fcc02fdda8d6a0e08f7ac8d094a2b3c4124581cfec01a4e059a45390a92bfae3d204dd5af0a244a9856
diff --git a/dev-libs/log4shib/files/log4shib-doc.patch b/dev-libs/log4shib/files/log4shib-doc.patch
new file mode 100644
index 00000000000..c7c58f0781a
--- /dev/null
+++ b/dev-libs/log4shib/files/log4shib-doc.patch
@@ -0,0 +1,11 @@
+--- doc/Makefile.am.orig 2008-10-18 09:03:48.000000000 +0200
++++ doc/Makefile.am 2008-10-18 09:05:16.000000000 +0200
+@@ -1,7 +1,7 @@
+ SUBDIRS = html
+
+ man3dir = $(DESTDIR)$(mandir)/man3
+-docdir = $(prefix)/doc/@PACKAGE_TARNAME@-@PACKAGE_VERSION@
++docdir = $(DESTDIR)/$(datarootdir)/doc/@PACKAGE_TARNAME@-@PACKAGE_VERSION@
+
+ EXTRA_DIST = \
+ mainPage.txt
diff --git a/dev-libs/log4shib/log4shib-1.0.1.ebuild b/dev-libs/log4shib/log4shib-1.0.1.ebuild
new file mode 100644
index 00000000000..dcdcd7b1a6d
--- /dev/null
+++ b/dev-libs/log4shib/log4shib-1.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="Internet2 version for OpenSAML of log4cpp logging framework"
+HOMEPAGE="https://wiki.shibboleth.net/confluence/display/OpenSAML/log4shib"
+SRC_URI="http://shibboleth.internet2.edu/downloads/${PN}/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # fix sandbox violation by doc installation
+ epatch "${FILESDIR}/${PN}-doc.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf --without-idsa \
+ $(use_enable doc doxygen)
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS || die "dodoc failed"
+}
diff --git a/dev-libs/log4shib/log4shib-1.0.4.ebuild b/dev-libs/log4shib/log4shib-1.0.4.ebuild
new file mode 100644
index 00000000000..76a187fad51
--- /dev/null
+++ b/dev-libs/log4shib/log4shib-1.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Internet2 version for OpenSAML of log4cpp logging framework"
+HOMEPAGE="https://wiki.shibboleth.net/confluence/display/OpenSAML/log4shib"
+SRC_URI="http://shibboleth.internet2.edu/downloads/${PN}/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="debug doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+ econf --without-idsa \
+ $(use_enable debug) \
+ $(use_enable doc doxygen) \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
diff --git a/dev-libs/log4shib/metadata.xml b/dev-libs/log4shib/metadata.xml
new file mode 100644
index 00000000000..51d36d7d1c9
--- /dev/null
+++ b/dev-libs/log4shib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>log4shib is a library of C++ classes for flexible logging
+ to files, syslog, IDSA and other destinations. It is a forked version
+ of log4cpp especially adapted for the shibboleth framework
+ </longdescription>
+</pkgmetadata>