summaryrefslogtreecommitdiff
path: root/dev-libs/mdsplib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/mdsplib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/mdsplib')
-rw-r--r--dev-libs/mdsplib/Manifest1
-rw-r--r--dev-libs/mdsplib/files/mdsplib-0.11-gentoo.patch46
-rw-r--r--dev-libs/mdsplib/mdsplib-0.11.ebuild33
-rw-r--r--dev-libs/mdsplib/metadata.xml7
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/mdsplib/Manifest b/dev-libs/mdsplib/Manifest
new file mode 100644
index 00000000000..39066f9c9b5
--- /dev/null
+++ b/dev-libs/mdsplib/Manifest
@@ -0,0 +1 @@
+DIST mdsplib-0.11.tar.gz 70435 SHA256 bef3e2ecce276e720b903de00ad244e3e56fc2684e91ce5570965819af9577da SHA512 5baf7c23884ab21d2111a05c97a988ff82b003f0b3243ce5fabe5a9757c149a007e7ec6e0baf80de4fa75630c640b2411598a0b06848c7b96fd6ef070e76a687 WHIRLPOOL 525774ac1e1cce1373060adb441325aa6cf68c702d4b22596d860cc81d2d90e96f5142d586b5f62d4c6833e1e8d7f019efa5b8677270590c2eab5ce02563676c
diff --git a/dev-libs/mdsplib/files/mdsplib-0.11-gentoo.patch b/dev-libs/mdsplib/files/mdsplib-0.11-gentoo.patch
new file mode 100644
index 00000000000..92d96147bb7
--- /dev/null
+++ b/dev-libs/mdsplib/files/mdsplib-0.11-gentoo.patch
@@ -0,0 +1,46 @@
+diff -ur mdsplib-0.11.orig/Makefile mdsplib-0.11/Makefile
+--- mdsplib-0.11.orig/Makefile 2003-12-10 21:56:23.000000000 +0200
++++ mdsplib-0.11/Makefile 2009-08-06 13:33:03.000000000 +0300
+@@ -1,5 +1,6 @@
+-CC = gcc
+-CFLAGS = -O3
++AR ?= ar
++CC ?= gcc
++RANLIB ?= ranlib
+ LIBS =
+
+ library: libmetar.a
+@@ -7,11 +8,11 @@
+ all: dmetar library
+
+ libmetar.a: src/antoi.o src/charcmp.o src/dcdmetar.o src/dcdmtrmk.o src/fracpart.o src/prtdmetr.o src/stspack2.o src/stspack3.o
+- ar ruv libmetar.a src/antoi.o src/charcmp.o src/dcdmetar.o src/dcdmtrmk.o src/fracpart.o src/prtdmetr.o src/stspack2.o src/stspack3.o
+- ranlib libmetar.a
++ $(AR) ruv libmetar.a src/antoi.o src/charcmp.o src/dcdmetar.o src/dcdmtrmk.o src/fracpart.o src/prtdmetr.o src/stspack2.o src/stspack3.o
++ $(RANLIB) libmetar.a
+
+ dmetar: src/drvmetar.o libmetar.a
+- $(CC) $(CFLAGS) -o dmetar src/drvmetar.o libmetar.a $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o dmetar src/drvmetar.o libmetar.a $(LIBS)
+
+ src/antoi.o: src/antoi.c src/local.h
+ $(CC) $(CFLAGS) -c src/antoi.c -o src/antoi.o
+@@ -48,5 +49,5 @@
+ chmod 0644 /usr/local/include/metar.h
+ cp libmetar.a /usr/local/lib/
+ chmod 0644 /usr/local/lib/libmetar.a
+- ranlib /usr/local/lib/libmetar.a
++ $(RANLIB) /usr/local/lib/libmetar.a
+
+diff -ur mdsplib-0.11.orig/src/local.h mdsplib-0.11/src/local.h
+--- mdsplib-0.11.orig/src/local.h 2003-12-10 23:30:56.000000000 +0200
++++ mdsplib-0.11/src/local.h 2009-08-06 13:27:03.000000000 +0300
+@@ -1175,7 +1175,7 @@
+ char *strupr(char *);
+ char *strlwr(char *);
+ /* char *strdup(char *); */
+-char *strndup(char *, int);
++/* char *strndup(char *, int); */
+ int strcmpi(char *, char *);
+
+ /* void *memccpy(void *, void *, int, unsigned); */
diff --git a/dev-libs/mdsplib/mdsplib-0.11.ebuild b/dev-libs/mdsplib/mdsplib-0.11.ebuild
new file mode 100644
index 00000000000..82029d0f7dd
--- /dev/null
+++ b/dev-libs/mdsplib/mdsplib-0.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="METAR Decoder Software Package Library"
+HOMEPAGE="http://limulus.net/mdsplib/"
+SRC_URI="http://limulus.net/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ emake all || die "emake all failed"
+}
+
+src_install() {
+ insinto /usr/include
+ insopts -m0644
+ doins metar.h || die "doins failed"
+ dolib.a libmetar.a || die "dolib.a failed"
+ dodoc README README.MDSP
+ dobin dmetar || die "dobin failed"
+}
diff --git a/dev-libs/mdsplib/metadata.xml b/dev-libs/mdsplib/metadata.xml
new file mode 100644
index 00000000000..ff62877c67a
--- /dev/null
+++ b/dev-libs/mdsplib/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>