summaryrefslogtreecommitdiff
path: root/dev-libs/mongo-c-driver
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-25 19:44:09 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-25 19:44:09 -0400
commit19239aaef7013ca1a51fd6d0b55c55c7382104c0 (patch)
tree6108625a33449a80bb7a9815934c91137e29715f /dev-libs/mongo-c-driver
parent14a4f4f05ada7f789e5db7991b6a0f2b76b68a23 (diff)
downloadgentoo-19239aaef7013ca1a51fd6d0b55c55c7382104c0.tar.gz
gentoo-19239aaef7013ca1a51fd6d0b55c55c7382104c0.tar.xz
dev-libs/mongo-c-driver: add libressl support
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/mongo-c-driver')
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild9
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild9
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild9
3 files changed, 18 insertions, 9 deletions
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild
index 0bb5f3ecb4e..2b0d4acb7df 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,11 +13,14 @@ SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
-IUSE="debug examples sasl ssl static-libs test"
+IUSE="debug examples libressl sasl ssl static-libs test"
RDEPEND=">=dev-libs/libbson-0.98.0
sasl? ( dev-libs/cyrus-sasl )
- ssl? ( dev-libs/openssl:= )"
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
DEPEND="${RDEPEND}
test? ( dev-db/mongodb )"
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild
index a745d2d8fe0..ab6aedf2d83 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,11 +13,14 @@ SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
-IUSE="debug examples sasl ssl static-libs test"
+IUSE="debug examples libressl sasl ssl static-libs test"
RDEPEND=">=dev-libs/libbson-1.1.10
sasl? ( dev-libs/cyrus-sasl )
- ssl? ( dev-libs/openssl:= )"
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
DEPEND="${RDEPEND}
test? ( dev-db/mongodb )"
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
index 65f19c5a2e2..b5b39fd6e45 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,11 +13,14 @@ SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
-IUSE="debug examples sasl ssl static-libs test"
+IUSE="debug examples libressl sasl ssl static-libs test"
RDEPEND=">=dev-libs/libbson-1.0
sasl? ( dev-libs/cyrus-sasl )
- ssl? ( dev-libs/openssl:= )"
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
DEPEND="${RDEPEND}
test? ( dev-db/mongodb )"