summaryrefslogtreecommitdiff
path: root/dev-libs/oniguruma
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-09-08 10:27:20 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-08 10:27:33 +0200
commit3826b9ae650aebb62795543839197d673a695161 (patch)
tree5e2a7898042d5d726746e7f0dd2b578bb19a81b2 /dev-libs/oniguruma
parentfe107052fb2aea50a0406a9fa39bbc0900e6926a (diff)
downloadgentoo-3826b9ae650aebb62795543839197d673a695161.tar.gz
gentoo-3826b9ae650aebb62795543839197d673a695161.tar.xz
dev-libs/oniguruma: EAPI 5 bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/oniguruma')
-rw-r--r--dev-libs/oniguruma/oniguruma-5.9.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/oniguruma/oniguruma-5.9.5-r1.ebuild b/dev-libs/oniguruma/oniguruma-5.9.5-r1.ebuild
new file mode 100644
index 00000000000..928a15d0ef9
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-5.9.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Needed for a sane .so versionning on fbsd, please dont drop
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-multilib
+
+MY_P=onig-${PV}
+
+DESCRIPTION="a regular expression library for different character encodings"
+HOMEPAGE="http://www.geocities.jp/kosako3/oniguruma"
+SRC_URI="http://www.geocities.jp/kosako3/oniguruma/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="combination-explosion-check crnl-as-line-terminator static-libs"
+
+PATCHES=( "${FILESDIR}"/${PN}-5.9.3-makefile.patch )
+DOCS=( AUTHORS HISTORY README{,.ja} doc/{API,FAQ,RE}{,.ja} )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable combination-explosion-check)
+ $(use_enable crnl-as-line-terminator)
+ )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ use static-libs || prune_libtool_files
+}