summaryrefslogtreecommitdiff
path: root/dev-libs/pcre++
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/pcre++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/pcre++')
-rw-r--r--dev-libs/pcre++/Manifest2
-rw-r--r--dev-libs/pcre++/files/pcre++-0.9.5-nodoc.patch12
-rw-r--r--dev-libs/pcre++/metadata.xml5
-rw-r--r--dev-libs/pcre++/pcre++-0.9.5-r1.ebuild40
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/pcre++/Manifest b/dev-libs/pcre++/Manifest
new file mode 100644
index 00000000000..17959326dc8
--- /dev/null
+++ b/dev-libs/pcre++/Manifest
@@ -0,0 +1,2 @@
+DIST pcre++-0.9.5-patches.tar.bz2 3733 SHA256 d7c5e7881f56cbb11109313375893b95358e3cf4922ffaf0fa812e1df6ff4226 SHA512 ddfb13575f7950c7298ddce5fd603c8f34c1e901c8fef71f7591d0c4a49dc36cf5204240dbb23078346a4497f69b541374633e9f3f17b045fc58ba3ccd0f8019 WHIRLPOOL 2fd628f2ebdc9dda64125468c014f54316110270c9841d45dfe26c47030fc3016d9cdb2500a47d1114b2a7e639169a5a3919821a811da130cb5882769487e9b7
+DIST pcre++-0.9.5.tar.gz 381589 SHA256 77ee9fc1afe142e4ba2726416239ced66c3add4295ab1e5ed37ca8a9e7bb638a SHA512 509080e31483ea82f13873423b48adfcf78ff8d4b5480fb8d46f6bb4a596a0480e4ae32da9e5518b1a6e98679b4e1a523cc9d6f8d8373dcec6f73d18479712e5 WHIRLPOOL 8fc722852bb7b0d46ae7569f08b15eea6ddd0861a0dea25b77874ffbdf62b54a121a2052ff0fc429673654cbd575ba277b69fec91ea5a220b3ee9941a640c177
diff --git a/dev-libs/pcre++/files/pcre++-0.9.5-nodoc.patch b/dev-libs/pcre++/files/pcre++-0.9.5-nodoc.patch
new file mode 100644
index 00000000000..cddae01421c
--- /dev/null
+++ b/dev-libs/pcre++/files/pcre++-0.9.5-nodoc.patch
@@ -0,0 +1,12 @@
+diff -Naur pcre++-0.9.5.orig/Makefile.in pcre++-0.9.5/Makefile.in
+--- pcre++-0.9.5.orig/Makefile.in 2004-08-24 16:38:03.000000000 -0700
++++ pcre++-0.9.5/Makefile.in 2004-09-05 16:16:58.818627842 -0700
+@@ -77,7 +77,7 @@
+ STRIP = @STRIP@
+ VERSION = @VERSION@
+
+-SUBDIRS = libpcre++ doc examples test
++SUBDIRS = libpcre++
+
+ bin_SCRIPTS = pcre++-config
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/dev-libs/pcre++/metadata.xml b/dev-libs/pcre++/metadata.xml
new file mode 100644
index 00000000000..8434377a604
--- /dev/null
+++ b/dev-libs/pcre++/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cpp</herd>
+</pkgmetadata>
diff --git a/dev-libs/pcre++/pcre++-0.9.5-r1.ebuild b/dev-libs/pcre++/pcre++-0.9.5-r1.ebuild
new file mode 100644
index 00000000000..8a8b374be09
--- /dev/null
+++ b/dev-libs/pcre++/pcre++-0.9.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="A C++ support library for libpcre"
+HOMEPAGE="http://www.daemon.de/PCRE"
+SRC_URI="http://www.daemon.de/files/mirror/ftp.daemon.de/scip/Apps/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-patches.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+DEPEND="dev-libs/libpcre"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/${P}-patches" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ dohtml -r doc/html/.
+ doman doc/man/man3/Pcre.3
+
+ rm -rf "${D}/usr/doc"
+}