summaryrefslogtreecommitdiff
path: root/dev-libs/pugixml/pugixml-1.7.ebuild
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-10-21 11:39:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-10-21 12:05:29 +0200
commit461fef7f522798dd8fd3689c9e79e4d7e909fe6a (patch)
tree01ce1bec28aebd4c0005477bbc06444cc2c054dd /dev-libs/pugixml/pugixml-1.7.ebuild
parent117373679b00e587f969d3e47fc7cddba30743f2 (diff)
downloadgentoo-461fef7f522798dd8fd3689c9e79e4d7e909fe6a.tar.gz
gentoo-461fef7f522798dd8fd3689c9e79e4d7e909fe6a.tar.xz
dev-libs/pugixml: Bump to version 1.7
Package-Manager: portage-2.2.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/pugixml/pugixml-1.7.ebuild')
-rw-r--r--dev-libs/pugixml/pugixml-1.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/pugixml/pugixml-1.7.ebuild b/dev-libs/pugixml/pugixml-1.7.ebuild
new file mode 100644
index 00000000000..2b07f83f431
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="http://pugixml.org/ https://github.com/zeux/pugixml/"
+SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+S=${WORKDIR}/${P}/scripts
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=ON )
+ cmake-utils_src_configure
+}