summaryrefslogtreecommitdiff
path: root/dev-libs/qoauth
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/qoauth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/qoauth')
-rw-r--r--dev-libs/qoauth/Manifest1
-rw-r--r--dev-libs/qoauth/files/qoauth-1.0.1-disable-ft.patch20
-rw-r--r--dev-libs/qoauth/metadata.xml5
-rw-r--r--dev-libs/qoauth/qoauth-1.0.1.ebuild69
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-libs/qoauth/Manifest b/dev-libs/qoauth/Manifest
new file mode 100644
index 00000000000..bdad95ef7b0
--- /dev/null
+++ b/dev-libs/qoauth/Manifest
@@ -0,0 +1 @@
+DIST qoauth-1.0.1-src.tar.bz2 42298 SHA256 b8579a77cecb07928e557c4a019db902a0f040b22f7926f147299e87ac5a54fd SHA512 86869c82e6efd490888f3bb16cba5bb014821e35507d3d396a84f5112a2d0bd7cb1251ba5dff82a8913eeae77a0feeebfdf4a7d1e9870023fb3c106d603c3dd8 WHIRLPOOL e990ad4fbaa7ce3c45eec6f3a49d9404139432e5941882cc73d85520868bdc592604c8b7058866648d27b2001b310848edd239f8c3f9fc4f0bc66c79fee7f8bd
diff --git a/dev-libs/qoauth/files/qoauth-1.0.1-disable-ft.patch b/dev-libs/qoauth/files/qoauth-1.0.1-disable-ft.patch
new file mode 100644
index 00000000000..1fd6fd0fc8c
--- /dev/null
+++ b/dev-libs/qoauth/files/qoauth-1.0.1-disable-ft.patch
@@ -0,0 +1,20 @@
+diff --git a/qoauth.pro b/qoauth.pro
+index f09b3be..27d7bb3 100644
+--- a/qoauth.pro
++++ b/qoauth.pro
+@@ -5,6 +5,6 @@ SUBDIRS += src tests
+ CONFIG += ordered
+
+ check.target = check
+-check.commands = ( cd tests/ut_interface && ./ut_interface ) && ( cd tests/ft_interface && ./ft_interface )
++check.commands = ( cd tests/ut_interface && ./ut_interface )
+ check.depends = sub-tests
+ QMAKE_EXTRA_TARGETS += check
+diff --git a/tests/tests.pro b/tests/tests.pro
+index d582750..e010bb0 100644
+--- a/tests/tests.pro
++++ b/tests/tests.pro
+@@ -1,2 +1,2 @@
+ TEMPLATE = subdirs
+-SUBDIRS += ut_interface ft_interface
++SUBDIRS += ut_interface
diff --git a/dev-libs/qoauth/metadata.xml b/dev-libs/qoauth/metadata.xml
new file mode 100644
index 00000000000..dc439f7e84f
--- /dev/null
+++ b/dev-libs/qoauth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+</pkgmetadata>
diff --git a/dev-libs/qoauth/qoauth-1.0.1.ebuild b/dev-libs/qoauth/qoauth-1.0.1.ebuild
new file mode 100644
index 00000000000..a2fc0305f23
--- /dev/null
+++ b/dev-libs/qoauth/qoauth-1.0.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="A Qt-based library for OAuth support"
+HOMEPAGE="http://wiki.github.com/ayoy/qoauth"
+SRC_URI="http://files.ayoy.net/qoauth/release/${PV}/src/${P}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="debug doc static-libs test"
+
+COMMON_DEPEND="app-crypt/qca:2[debug?,qt4(+)]"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-qt/qttest:4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[openssl]
+"
+
+S=${WORKDIR}/${P}-src
+
+DOCS="README CHANGELOG"
+PATCHES=(
+ # disable functional tests that require network connection
+ # and rely on 3rd party external server (bug #341267)
+ "${FILESDIR}/${P}-disable-ft.patch"
+)
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ if ! use test; then
+ sed -i -e '/SUBDIRS/s/tests//' ${PN}.pro || die "sed failed"
+ fi
+
+ sed -i -e '/^ *docs \\$/d' \
+ -e '/^ *build_all \\$/d' \
+ -e 's/^\#\(!macx\)/\1/' \
+ src/src.pro || die "sed failed"
+
+ sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" src/pcfile.sh || die "sed failed"
+}
+
+src_compile() {
+ default
+ if use static-libs; then
+ emake -C src static
+ fi
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use static-libs; then
+ dolib.a "${S}"/lib/lib${PN}.a
+ fi
+
+ if use doc; then
+ doxygen "${S}"/Doxyfile || die "failed to generate documentation"
+ dohtml "${S}"/doc/html/*
+ fi
+}