summaryrefslogtreecommitdiff
path: root/dev-libs/qoauth
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-01-07 17:52:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-01-07 18:22:14 +0100
commit5daee0b96948535deae6b5d1a651065403d5a1fe (patch)
tree5f35121c6bd17bac4d151d270471bc8f8d49b3a5 /dev-libs/qoauth
parent742942fdf3a30f797d56aa4ea77a3713095fe260 (diff)
downloadgentoo-5daee0b96948535deae6b5d1a651065403d5a1fe.tar.gz
gentoo-5daee0b96948535deae6b5d1a651065403d5a1fe.tar.xz
dev-libs/qoauth: Drop broken USE=static-libs, fix DEPEND, bump EAPI 6
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/qoauth')
-rw-r--r--dev-libs/qoauth/qoauth-2.0.1_pre20160315-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/qoauth/qoauth-2.0.1_pre20160315-r1.ebuild b/dev-libs/qoauth/qoauth-2.0.1_pre20160315-r1.ebuild
new file mode 100644
index 00000000000..80398f30f74
--- /dev/null
+++ b/dev-libs/qoauth/qoauth-2.0.1_pre20160315-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Qt-based library for OAuth support"
+HOMEPAGE="https://wiki.github.com/ayoy/qoauth"
+SRC_URI="https://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug doc test"
+
+COMMON_DEPEND="
+ app-crypt/qca:2[debug?,qt5]
+ dev-qt/qtnetwork:5
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-qt/qttest:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[ssl]
+ !dev-libs/qoauth:0
+"
+
+# disable functional tests that require network connection
+# and rely on 3rd party external server (bug #341267)
+PATCHES=( "${FILESDIR}/${PN}-1.0.1-disable-ft.patch" )
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e '/SUBDIRS/s/tests//' ${PN}.pro || die "sed failed"
+ fi
+
+ sed -i -e '/^ *docs \\$/d' \
+ -e '/^ *build_all \\$/d' \
+ -e 's/^\#\(!macx\)/\1/' \
+ src/src.pro || die "sed failed"
+
+ sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" src/pcfile.sh || die "sed failed"
+}
+
+src_configure() {
+ eqmake5 qoauth.pro
+}
+
+src_install() {
+ if use doc; then
+ doxygen "${S}"/Doxyfile || die "failed to generate documentation"
+ HTML_DOCS=( "${S}"/doc/html/. )
+ fi
+
+ INSTALL_ROOT="${D}" default
+}