summaryrefslogtreecommitdiff
path: root/dev-libs/qoauth
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-03-15 22:57:23 +0100
committerJohannes Huber <johu@gentoo.org>2016-03-15 22:57:35 +0100
commitb492b531d05766bed121f51d9ff59fe57540e09a (patch)
treeaadda09184ddcb4c6b121763b9f2879bd7580a3f /dev-libs/qoauth
parent37235adcb5836ae5dae998e98777d74c31f801a0 (diff)
downloadgentoo-b492b531d05766bed121f51d9ff59fe57540e09a.tar.gz
gentoo-b492b531d05766bed121f51d9ff59fe57540e09a.tar.xz
dev-libs/qoauth: Add Qt5 compat snapshot
Gentoo-bug: 556180 Acked-by: Michael Palimaka <kensington@gentoo.org> Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/qoauth')
-rw-r--r--dev-libs/qoauth/Manifest1
-rw-r--r--dev-libs/qoauth/qoauth-2.0.1_pre20160315.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/qoauth/Manifest b/dev-libs/qoauth/Manifest
index bdad95ef7b0..006859b7818 100644
--- a/dev-libs/qoauth/Manifest
+++ b/dev-libs/qoauth/Manifest
@@ -1 +1,2 @@
DIST qoauth-1.0.1-src.tar.bz2 42298 SHA256 b8579a77cecb07928e557c4a019db902a0f040b22f7926f147299e87ac5a54fd SHA512 86869c82e6efd490888f3bb16cba5bb014821e35507d3d396a84f5112a2d0bd7cb1251ba5dff82a8913eeae77a0feeebfdf4a7d1e9870023fb3c106d603c3dd8 WHIRLPOOL e990ad4fbaa7ce3c45eec6f3a49d9404139432e5941882cc73d85520868bdc592604c8b7058866648d27b2001b310848edd239f8c3f9fc4f0bc66c79fee7f8bd
+DIST qoauth-2.0.1_pre20160315.tar.xz 45604 SHA256 9e5e29b4258d878e9e1f8afdbc8ae94e68040d35d4f87e209b703e090fe278b4 SHA512 ec44c597c7b9729645ab98e2c71c805d01eab4c0684b7ea0da6b015a052b0ad6e3aa9352ef53e36a67ff99b9f75fb9b89156ca8b23c639a70cc49aab656366c3 WHIRLPOOL 3a082480c75aaa49a24937a0707e703dbabb1484d9cb467141bfd14f56169319018ff4b5e3026c59cab2199ca884686002790bc5927c0b2d56d170a34a3b7b5e
diff --git a/dev-libs/qoauth/qoauth-2.0.1_pre20160315.ebuild b/dev-libs/qoauth/qoauth-2.0.1_pre20160315.ebuild
new file mode 100644
index 00000000000..d9ab014a98a
--- /dev/null
+++ b/dev-libs/qoauth/qoauth-2.0.1_pre20160315.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils
+
+DESCRIPTION="Qt-based library for OAuth support"
+HOMEPAGE="https://wiki.github.com/ayoy/qoauth"
+SRC_URI="https://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug doc static-libs test"
+
+COMMON_DEPEND="app-crypt/qca:2[debug?,qt5]"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-qt/qttest:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[openssl]
+ !dev-libs/qoauth:0
+"
+
+DOCS=( README CHANGELOG )
+
+src_prepare() {
+ default
+
+ # disable functional tests that require network connection
+ # and rely on 3rd party external server (bug #341267)
+ epatch "${FILESDIR}/${PN}-1.0.1-disable-ft.patch"
+
+ if ! use test; then
+ sed -i -e '/SUBDIRS/s/tests//' ${PN}.pro || die "sed failed"
+ fi
+
+ sed -i -e '/^ *docs \\$/d' \
+ -e '/^ *build_all \\$/d' \
+ -e 's/^\#\(!macx\)/\1/' \
+ src/src.pro || die "sed failed"
+
+ sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" src/pcfile.sh || die "sed failed"
+}
+
+src_configure() {
+ eqmake5 qoauth.pro
+}
+
+src_compile() {
+ default
+ if use static-libs; then
+ emake -C src static
+ fi
+}
+
+src_install() {
+ INSTALL_ROOT="${D}" default
+
+ if use static-libs; then
+ dolib.a "${S}"/lib/lib${PN}.a
+ fi
+
+ if use doc; then
+ doxygen "${S}"/Doxyfile || die "failed to generate documentation"
+ dohtml "${S}"/doc/html/*
+ fi
+}