summaryrefslogtreecommitdiff
path: root/dev-libs/rlog
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/rlog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/rlog')
-rw-r--r--dev-libs/rlog/Manifest1
-rw-r--r--dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch10
-rw-r--r--dev-libs/rlog/metadata.xml8
-rw-r--r--dev-libs/rlog/rlog-1.4.ebuild24
4 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/rlog/Manifest b/dev-libs/rlog/Manifest
new file mode 100644
index 00000000000..3405fa06d70
--- /dev/null
+++ b/dev-libs/rlog/Manifest
@@ -0,0 +1 @@
+DIST rlog-1.4.tar.gz 640641 SHA256 a938eeedeb4d56f1343dc5561bc09ae70b24e8f70d07a6f8d4b6eed32e783f79 SHA512 a0af9afd6c5329ec4269a7778c3236b9e0b438cba65ed0a6f9cd7e802d196b7908eed5ab663f52905869cacffc7f1964b20ab2a53b37dbe65f1c8a9226cc423e WHIRLPOOL 9b190b73595d9aea29ffd5e1ce0d94cad720d9643bdba5faf4eac04a32c365a3ebd0283c8aa4892dd14958fed850d1266e4b48889c3d23286c1cf29e2a736f88
diff --git a/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch b/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
new file mode 100644
index 00000000000..5e4bb91bf1e
--- /dev/null
+++ b/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- rlog/RLogChannel.cpp
++++ rlog/RLogChannel.cpp
+@@ -20,6 +20,7 @@
+ #include "RLogChannel.h"
+ #include "rlog.h"
+ #include "Lock.h"
++#include <cstring>
+
+ using namespace std;
+ using namespace rlog;
diff --git a/dev-libs/rlog/metadata.xml b/dev-libs/rlog/metadata.xml
new file mode 100644
index 00000000000..cc9a8c3e469
--- /dev/null
+++ b/dev-libs/rlog/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <upstream>
+ <remote-id type="google-code">rlog</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/rlog/rlog-1.4.ebuild b/dev-libs/rlog/rlog-1.4.ebuild
new file mode 100644
index 00000000000..b85be5c5a44
--- /dev/null
+++ b/dev-libs/rlog/rlog-1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="A C++ logging library"
+HOMEPAGE="http://code.google.com/p/rlog/"
+SRC_URI="http://rlog.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3.7-gcc-4.3.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="/usr/share/doc/${PF}" install || die
+ dodoc AUTHORS ChangeLog README
+}