summaryrefslogtreecommitdiff
path: root/dev-libs/softhsm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/softhsm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/softhsm')
-rw-r--r--dev-libs/softhsm/Manifest2
-rw-r--r--dev-libs/softhsm/metadata.xml8
-rw-r--r--dev-libs/softhsm/softhsm-1.3.5.ebuild36
-rw-r--r--dev-libs/softhsm/softhsm-1.3.6.ebuild36
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/softhsm/Manifest b/dev-libs/softhsm/Manifest
new file mode 100644
index 00000000000..2dfa037fba7
--- /dev/null
+++ b/dev-libs/softhsm/Manifest
@@ -0,0 +1,2 @@
+DIST softhsm-1.3.5.tar.gz 440157 SHA256 28b5062a13450faf6099fcb82d25d21f0ac7d202ba31ec85e943246cdcf87ebd SHA512 8da873d84ce3f554ff90975f2c37750c24ee4b254b480a203bfe600d2314ae1aba4d67b96bc9c5cb6787f592e597551e850a84ee36046f408aea7d5d5d7c8787 WHIRLPOOL d01878dbf17d4e06305df23826bc07fff535c9e9734be376ef2d0a99891ddca0bdd1689285e199a6f81143d38c55334c8df9969470cc0098724fb5d24871ad92
+DIST softhsm-1.3.6.tar.gz 435893 SHA256 e39ac8e851220edd2b2afbe4d9e06d956bccc20bc72752740eabf95692359486 SHA512 fa344b298da6f15a616eaaa90e9e2153cb48ee1a5d4c3089a4195080efc5d15cccf27536279206587f8e1a55ac1b3745303712797296aba560be5ca958783b70 WHIRLPOOL 6451e039d31932306627f6af23041dbd7d386d1b137eb529332f45ce523ae0c61b736876815ca614a8ec54b0dbae9d83b510bbf126dafd17cbf6d12c745ed7a8
diff --git a/dev-libs/softhsm/metadata.xml b/dev-libs/softhsm/metadata.xml
new file mode 100644
index 00000000000..77def0a20ae
--- /dev/null
+++ b/dev-libs/softhsm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/dev-libs/softhsm/softhsm-1.3.5.ebuild b/dev-libs/softhsm/softhsm-1.3.5.ebuild
new file mode 100644
index 00000000000..84317908fa6
--- /dev/null
+++ b/dev-libs/softhsm/softhsm-1.3.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A software PKCS#11 implementation"
+HOMEPAGE="http://www.opendnssec.org/"
+SRC_URI="http://www.opendnssec.org/files/source/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+SLOT="0"
+LICENSE="BSD"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/botan-1.10.1[threads]
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ econf \
+ --disable-static \
+ --localstatedir=/var \
+ --with-botan="${EPREFIX}/usr/" \
+ $(use_enable amd64 64bit) \
+ $(use debug && echo "--with-loglevel=4")
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}
diff --git a/dev-libs/softhsm/softhsm-1.3.6.ebuild b/dev-libs/softhsm/softhsm-1.3.6.ebuild
new file mode 100644
index 00000000000..1e91c5cab67
--- /dev/null
+++ b/dev-libs/softhsm/softhsm-1.3.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A software PKCS#11 implementation"
+HOMEPAGE="http://www.opendnssec.org/"
+SRC_URI="http://www.opendnssec.org/files/source/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+SLOT="0"
+LICENSE="BSD"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/botan-1.10.1[threads]
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS )
+
+src_configure() {
+ econf \
+ --disable-static \
+ --localstatedir=/var \
+ --with-botan="${EPREFIX}/usr/" \
+ $(use_enable amd64 64bit) \
+ $(use debug && echo "--with-loglevel=4")
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}