summaryrefslogtreecommitdiff
path: root/dev-libs/syncdir
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/syncdir
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/syncdir')
-rw-r--r--dev-libs/syncdir/Manifest1
-rw-r--r--dev-libs/syncdir/metadata.xml7
-rw-r--r--dev-libs/syncdir/syncdir-1.0-r1.ebuild40
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/syncdir/Manifest b/dev-libs/syncdir/Manifest
new file mode 100644
index 00000000000..23944c6491f
--- /dev/null
+++ b/dev-libs/syncdir/Manifest
@@ -0,0 +1 @@
+DIST syncdir-1.0.tar.gz 8878 SHA256 f30d8e0acb0e56dd5c8e90107d79fcaafe40bdc030a0ea66c152b9f54fc2eff0 SHA512 0b5262e23e43f34be7bc31ed6baf7624a115a509e459504651b184a0856c7918671db4be1b8e14552f275c49c5c6bbc00d786c57f1d96548a491048674f58317 WHIRLPOOL b82b06a6e3a179a6e32402b2b50fe1488159dde323011a5934cca80c1097ce54a869e888fa9734c643447a6ce1d3aec4acc545cdf9634e24218a3e762e37cc9b
diff --git a/dev-libs/syncdir/metadata.xml b/dev-libs/syncdir/metadata.xml
new file mode 100644
index 00000000000..d9cd2cad66c
--- /dev/null
+++ b/dev-libs/syncdir/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/syncdir/syncdir-1.0-r1.ebuild b/dev-libs/syncdir/syncdir-1.0-r1.ebuild
new file mode 100644
index 00000000000..f7890403a4c
--- /dev/null
+++ b/dev-libs/syncdir/syncdir-1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Provides an alternate implementation for open, link, rename, and unlink"
+HOMEPAGE="http://untroubled.org/syncdir"
+SRC_URI="http://untroubled.org/syncdir/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 x86"
+IUSE="static-libs"
+
+src_prepare() {
+ if ! use static-libs; then
+ sed -i Makefile \
+ -e '/^all:/s|libsyncdir.a||' \
+ -e '/install -m 644 libsyncdir.a/d' \
+ || die "sed Makefile"
+ fi
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ libsyncdir.so \
+ $(use static-libs && echo libsyncdir.a)
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)
+ emake libdir="${D}/usr/$(get_libdir)" install
+ dodoc testsync.c
+}